Contents

1 • Introducing FactoryTalk View Site Edition ............................................. 1
   About RSView Enterprise ............................................................................. 1
   About the FactoryTalk View SE documentation............................................ 2
   The FactoryTalk View Site Edition software.................................................. 3
   FactoryTalk Services Platform....................................................................... 3
   FactoryTalk View Studio................................................................................. 3
   FactoryTalk View SE Client............................................................................. 4
   FactoryTalk View SE Server............................................................................ 4
   FactoryTalk Alarms and Events services....................................................... 5
   FactoryTalk Activation services..................................................................... 5
   RSLinx Enterprise and RSLinx Classic............................................................. 5
   About FactoryTalk services and products...................................................... 6
   Services installed with the FactoryTalk Services Platform............................ 6
   Finding more information about FactoryTalk............................................... 7
   FactoryTalk View tools and utilities............................................................... 7
   FactoryTalk View SE tools............................................................................. 8
   FactoryTalk tools........................................................................................... 9
   FactoryTalk Activation Manager.................................................................... 9
   Finding information about using FactoryTalk View SE.................................. 10
   Finding information in the FactoryTalk View SE Help.................................. 10
   Opening the FactoryTalk View online manuals.......................................... 10
   Finding information on the Internet............................................................. 12
   Contacting Rockwell Automation Technical Support.................................. 12

2 • Setting up the installation environment.................................................. 15
   About the architecture of your FactoryTalk View application...................... 15
   Finding information on the Rockwell Automation Web site............................ 16
   Overview of tasks: setting up computers to run FactoryTalk View............... 17
   Task checklist for setting up application computers...................................... 17
   Limits for application server host computers.............................................. 18
   Hardware requirements for running FactoryTalk View SE............................ 18
   Hardware requirements for operator workstations....................................... 19
   Hardware requirements for engineering workstations.................................. 19
   Hardware requirements for application servers.......................................... 19
   Operating system requirements for running FactoryTalk View SE............... 20
   Operating system recommendations for application servers....................... 21
   About Windows Service Packs and compatibility...................................... 21
Set up the Windows domain or workgroup.................................................................................. 22
Domain controller requirements ..................................................................................................... 22
Windows workgroup requirements .................................................................................................. 22
Set up computers with names to be used in production ................................................................. 23
Disable operating system themes ..................................................................................................... 23
Manually configure Network Interface Cards (NICs) and switch ports .................................... 24
  To set up the NIC link speed and duplex .................................................................................. 25
  To disable power saving for the NIC ....................................................................................... 26
Remove unnecessary DCOM networking protocols ................................................................. 26
Establish network connections ........................................................................................................ 27
Disable or uninstall third-party firewalls ....................................................................................... 27
Install Microsoft Internet Information Services............................................................................ 28
  About uninstalling IIS ............................................................................................................. 35
Set up Internet Explorer for optimal access to components ....................................................... 35
  Turn off the Work Offline setting ............................................................................................ 35
  Check for newer versions with every visit to a page ............................................................... 35
  Specifying enough usable disk space ...................................................................................... 36
Set up Data Execution Prevention (DEP) ..................................................................................... 37
  Remove Internet Explorer Enhanced Security Configuration .............................................. 38

3 • Installing FactoryTalk View Site Edition ............................................................................. 41
Deciding which FactoryTalk View SE components to install ...................................................... 41
  When to install all FactoryTalk View SE components............................................................ 41
  When to install selected FactoryTalk View SE components.................................................. 41
About FactoryTalk Alarms and Events ....................................................................................... 42
Overview of tasks: installing the FactoryTalk View SE software .............................................. 42
  Task checklist for installing FactoryTalk View SE ................................................................. 43
  About the Installation Assistant .............................................................................................. 43
  Opening the online Installation Guide ...................................................................................... 44
Ensure that the logged-on user is a Windows administrator ....................................................... 44
Check for earlier versions of FactoryTalk View Site Edition .................................................. 44
Install the FactoryTalk Services Platform .................................................................................... 45
Install SQL Server Express Prerequisites ................................................................................... 45
Install FactoryTalk View Site Edition .......................................................................................... 46
  About specifying the Network Directory server location ...................................................... 50
  FactoryTalk View SE program folders ................................................................................... 51
Install RSLinx Enterprise or RSLinx Classic ............................................................................. 51
  When to use RSLinx Classic .................................................................................................... 52
Recreate SQL Server 2008 Express instance ................................................................. 53
About installing product updates .................................................................................. 54

4 • Activating FactoryTalk View software ................................................................. 55

About FactoryTalk Activation ....................................................................................... 55
FactoryTalk Activation types ....................................................................................... 55
Finding more information about FactoryTalk Activation ........................................... 56
Activating software on Windows Vista ....................................................................... 57
What happens if FactoryTalk View SE is not activated .............................................. 57
Overview of tasks: activating the FactoryTalk View SE software .............................. 57
Task checklist for activating FactoryTalk View SE ..................................................... 58
Install the activation software ...................................................................................... 59
Get activation files to the activation server computer .............................................. 60
To get activation files through another computer's Internet ................................... 61
Protecting activation files ......................................................................................... 62
Set up client computers to obtain floating activations ............................................. 63
Ensuring that network application components stay activated .............................. 64
Borrow activations for development computers ...................................................... 65
Obtaining borrowable activations ............................................................................ 65
Borrowing activations from a server ....................................................................... 67
Activation keys for FactoryTalk View software components ................................... 69
Sharing keys among multiple software components .............................................. 70
How FactoryTalk View SE Clients use floating activations ................................... 70
........................................................................................................................................ 71

5 • Deploying network applications ........................................................................... 73

Overview of tasks: deploying network applications ............................................... 73
Task checklist for deploying a network application .................................................... 73
Back up the network application .............................................................................. 74
Ensure that the FactoryTalk Network Directory is set up ........................................ 76
Move the application’s HMI project files .................................................................. 76
Where HMI project files are stored .......................................................................... 77
Restore the network application ............................................................................... 77
Specify the Network Directory location on application computers ...................... 79
Move the application’s data server files ................................................................. 79
Restoring RSLinx Enterprise configurations ......................................................... 79
Backing up and restoring RSLinx Classic configurations .......................................... 80
Specify data server host computer names ................................................................. 81
Renew data server shortcuts, topics, and device paths ........................................... 81
Specify HMI server host computer names ................................................................. 82
Set up additional HMI server properties ................................................................. 83
  Synchronizing redundant HMI servers and projects .............................................. 84
Set up the FactoryTalk View SE Clients ................................................................. 85
  Creating a new FactoryTalk View SE Client file .................................................. 85
  Copying existing FactoryTalk View SE Client files .............................................. 85
  Locking operators into the run-time environment ................................................. 86
Run the FactoryTalk View SE Clients ................................................................. 87
  About logging on to the FactoryTalk View SE Client ........................................ 88
Administering deployed network applications ...................................................... 88

6 • Deploying local applications ................................................................................. 89

Overview of tasks: deploying local applications .................................................... 89
  Task checklist for deploying a local application .................................................. 89
Move the local application ..................................................................................... 90
  About restoring System information with the application ................................... 91
Move data servers and change their properties .................................................... 91
  Backing up and restoring RSLinx Enterprise files .............................................. 91
  Moving RSLinx Classic files ............................................................................. 92
Specify OPC data server host computer names ..................................................... 93
Specify when HMI server components start or stop .............................................. 93
  How HMI server components start and stop ..................................................... 94
Set up the FactoryTalk View SE Client ................................................................. 94
  Creating a new FactoryTalk View SE Client file .............................................. 95
  Locking operators into the run-time environment .............................................. 95
Run the FactoryTalk View SE Client ................................................................. 96
  Logging users on to the FactoryTalk View SE Client ........................................ 96
Administering deployed local applications .......................................................... 97

7 • Upgrading FactoryTalk View Site Edition ......................................................... 99

Overview: Upgrading of a redundant network application .................................... 100
About upgrading a non-redundant network application ........................................ 101
Finding out about features in the new product version ........................................ 102
Step 1 – Prepare for the upgrade ........................................................................... 102
Step 2 – Back up the deployed application ............................................................ 104
  Back up the HMI project .................................................................................. 104
  Back up the application .................................................................................... 104
Part 1: Set up a temporary system and perform a partial upgrade ................................. 107

Step 3 – Set up a temporary upgrade system .............................................................. 108
  Shut down all client computers ........................................................................... 108
  Disable HMI and data server redundancy ........................................................... 108
  Set up Server #2 as the temporary primary server............................................... 109
  Restart Server #1 and all client computers .......................................................... 111

Step 4 – Upgrade software components on Server #2 ................................................ 112
  Uninstall FactoryTalk View SE ........................................................................... 112
  Install the FactoryTalk Services Platform ........................................................... 112
  Install SQL Server Express Prerequisites ............................................................ 112
  Install FactoryTalk View SE ............................................................................... 113
  Install RSLinx Enterprise .................................................................................... 113
  Install any necessary product updates ................................................................. 113

Step 5 – Upgrade software components on Workstation #1 ....................................... 113
  Shut down software running on Workstation #1 ................................................. 113
  Set up Workstation #1 as the Network Directory location .................................. 114
  Uninstall FactoryTalk View SE .......................................................................... 114
  Install the FactoryTalk Services Platform ........................................................... 114
  Install SQL Server Express Prerequisites ............................................................ 114
  Install FactoryTalk View SE ............................................................................... 114
  Install RSLinx Enterprise .................................................................................... 114
  Install any necessary product updates ................................................................. 115
  Specify Server #2 as the Network Directory location ......................................... 115

Step 6 – Migrate the FactoryTalk View SE application ............................................. 115
  Open the application in FactoryTalk View Studio .............................................. 115
  Verify RSLinx Enterprise shortcuts .................................................................... 116
  Test the migrated application .............................................................................. 116

Step 7 – Upgrade software on selected run-time clients ............................................. 116
  Shut down software running on the client ........................................................... 117
  Set up the client as the Network Directory location ............................................ 117
  Uninstall FactoryTalk View SE .......................................................................... 117
  Install the FactoryTalk Services Platform ........................................................... 118
  Install SQL Server Express Prerequisites ............................................................ 118
  Install FactoryTalk View SE ............................................................................... 118
  Install any necessary product updates ................................................................. 118
  Specify Server #2 as the Network Directory location ......................................... 118

Step 8 – Test the migrated FactoryTalk View SE application .................................... 119
  Start Server #2 and wait for it to finish starting .................................................. 119
  Run the migrated application on upgraded clients .............................................. 119
  Verify that the system is functioning as expected .............................................. 119
Part 2: Upgrade Server #1 and remaining clients .......................................................... 120
Step 9 – Upgrade remaining client computers ............................................................... 120
Step 10 – Upgrade software components on Server #1 .................................................. 121
  Uninstall FactoryTalk View SE ................................................................................... 121
  Install the FactoryTalk Services Platform .................................................................. 121
  Install SQL Server Express Prerequisites ................................................................... 121
  Install FactoryTalk View SE ...................................................................................... 121
  Install RSLinx Enterprise ......................................................................................... 121
  Install any necessary product updates ....................................................................... 121
Step 11 – Restore Server #1 as the primary application server .................................. 122
  On Server #2, back up the migrated application ...................................................... 122
  Copy backed-up application files to Server #1 ......................................................... 123
  On Server #1, restore the HMI project and application........................................... 123
  Specify Server #1 as the primary HMI and data server ......................................... 125
  Specify Server #1 as the Network Directory for clients ......................................... 125
  Test run the application from all upgraded clients ................................................. 126
Step 12 – Set up redundancy for the upgraded system .............................................. 126
  Specify Server #1 as the Network Directory for Server #2 ..................................... 126
  Shut down all client computers ............................................................................. 127
  Set up HMI server redundancy ............................................................................... 127
  Set up data server redundancy ............................................................................... 127
  Replicate primary server files to the secondary server ......................................... 128
Step 13 – Restart the entire upgraded application ..................................................... 129
  Start Server #1 and Server #2 ................................................................................ 129
  Start all run-time clients ....................................................................................... 129

A • Common upgrade procedures ............................................................................ 131
  How to uninstall FactoryTalk View SE and supporting software ................................ 132
  How to install the FactoryTalk Services Platform ..................................................... 133
  Install SQL Server Express Prerequisites ............................................................... 134
  How to install FactoryTalk View SE ......................................................................... 134
  How to install or upgrade FactoryTalk Activation ..................................................... 138
    Upgrading FactoryTalk Activation ......................................................................... 138
  How to install RSLinx Enterprise ............................................................................ 138
  How to install any necessary product updates ....................................................... 139

I • Index .................................................................................................................... i
Introducing FactoryTalk View Site Edition

FactoryTalk® View Site Edition is an integrated software package for developing and running human-machine interface (HMI) applications that can involve multiple users and servers, distributed over a network.

A member of the FactoryTalk View family of products, FactoryTalk View Site Edition (also called FactoryTalk View SE) provides all the tools you need to create powerful, dependable process monitoring and supervisory control applications.

About RSView Enterprise

RSView® Enterprise is the former name of the FactoryTalk View family of software products.

As of version 5.00 (CPR 9), Rockwell Software products that depend on and can share FactoryTalk services in an integrated control system have been renamed to represent the FactoryTalk brand.

The following table shows the new names for members of the product family formerly known as RSView Enterprise.

<table>
<thead>
<tr>
<th>RSView name (CPR 7 and earlier)</th>
<th>FactoryTalk View name (CPR 9 and later)</th>
</tr>
</thead>
<tbody>
<tr>
<td>RSView Enterprise</td>
<td>FactoryTalk View</td>
</tr>
<tr>
<td>RSView Supervisory Edition (SE)</td>
<td>FactoryTalk View Site Edition (SE)</td>
</tr>
<tr>
<td>RSView SE Distributed</td>
<td>FactoryTalk View SE (Network)</td>
</tr>
<tr>
<td>RSView SE Stand-alone</td>
<td>FactoryTalk View SE (Local)</td>
</tr>
<tr>
<td>RSView Studio</td>
<td>FactoryTalk View Studio</td>
</tr>
<tr>
<td>RSView SE Client™</td>
<td>FactoryTalk View SE Client</td>
</tr>
<tr>
<td>RSView SE Server™</td>
<td>FactoryTalk View SE Server</td>
</tr>
<tr>
<td>RSView SE Administration Console™</td>
<td>FactoryTalk View SE Administration Console</td>
</tr>
<tr>
<td>RSView ME Station™</td>
<td>FactoryTalk View Machine Edition Station</td>
</tr>
</tbody>
</table>

If you are upgrading from a version of RSView, information in this manual that refers to FactoryTalk View as the previous product version still applies to you.
About the FactoryTalk View SE documentation

In addition to the *FactoryTalk View Site Edition Installation Guide*, the FactoryTalk View SE documentation set includes:

- **Release Notes.** Read the Release Notes before you begin installing or working with FactoryTalk View SE and supporting software.

  Release Notes for FactoryTalk View SE, RSLinx Enterprise, and RSLinx Classic are available from the FactoryTalk View Site Edition DVD.

  Release Notes for the FactoryTalk Services Platform are available from the Contents page in the FactoryTalk Help. To open the Help, click Start > All Programs > Rockwell Software > FactoryTalk Tools, and then click **FactoryTalk Help**.

- **Online Help.** Online procedures and reference information are available from the Help menu in FactoryTalk View Studio, and from editors and dialog boxes used to develop FactoryTalk View SE applications.

- **FactoryTalk View Site Edition User’s Guide.** The User’s Guide contains comprehensive information about designing and developing FactoryTalk View SE applications. For details, see page 11.

  The User’s Guide is available in PDF format, from the Help menu in FactoryTalk View Studio, and from the Rockwell Automation Literature Library.

What’s in this manual

In addition to the printed version included with the software, the Installation Guide is available in PDF format from the FactoryTalk View Site Edition DVD, from the Help menu in FactoryTalk View Studio, and from the Rockwell Automation Literature Library.

In the Literature Library, to find the current version of the Installation Guide and the User’s Guide, search for Publication Numbers containing the string **VIEWSE**.

Chapters in this manual describe how to:

- set up the computers that will run FactoryTalk View SE.
- install FactoryTalk View SE and supporting software.
- activate the FactoryTalk View SE software.
- deploy FactoryTalk View SE network and local applications.
- upgrade FactoryTalk View SE components.

Each chapter includes a task check list, which you can use to create customized procedures suited to the needs of your application.
The FactoryTalk View Site Edition software

FactoryTalk View SE consists of several pieces of software you can use to build network and local HMI applications, customized to your needs.

Following is an overview of the software components that you can install from the FactoryTalk View Site Edition DVD. To learn how to install the software, see Chapter 3.

**FactoryTalk Services Platform**

The FactoryTalk Services Platform provides a set of common services (such as diagnostic messages, health monitoring services, and access to real-time data) for all the FactoryTalk products and applications used in a control system.

You must install the FactoryTalk Services Platform first, on any computer where you plan to install or run FactoryTalk View SE.

For an overview of services installed with the FactoryTalk Services Platform, see page 6.

**FactoryTalk View Studio**

FactoryTalk View Studio is the configuration software for developing and testing FactoryTalk View SE network and local applications.

FactoryTalk View Studio contains editors for creating complete applications, and includes client and server software for testing the applications you create. Use the editors to create applications that are as simple or as complex as you need.


You can also use FactoryTalk View Studio to set up FactoryTalk Security services for the applications you develop. For information about setting up security, see Chapter 5, “Setting up security” in the *FactoryTalk View Site Edition User’s Guide*.


The following illustration shows what a FactoryTalk View SE network application looks like, when it’s open in FactoryTalk View Studio.
In the illustration, a graphic display named Aeration is open in the workspace on the right, along with the undocked Objects toolbar.

**FactoryTalk View SE Client**

FactoryTalk View SE Client is software for viewing and interacting with FactoryTalk View SE local and network applications at run time.

Use the FactoryTalk View SE Client Wizard to create client configuration files that can be deployed to client host computers. For details, see the FactoryTalk View SE Client Help.

**FactoryTalk View SE Server**

FactoryTalk View SE Server, also called the HMI server, stores HMI project components (for example, graphic displays) and serves them to clients. The server also contains a database of tags, and performs alarm detection and historical data logging.

The FactoryTalk View SE Server has no user interface. Once installed, it runs as a set of ‘headless’ Windows® services that supply information to clients as they request it.
FactoryTalk Alarms and Events services

FactoryTalk Alarms and Events, which installs behind the scenes during FactoryTalk View SE installation, provides system-wide alarm monitoring and control centralized at the FactoryTalk Directory.

To distribute device- and tag-based alarms in a FactoryTalk View SE application, you can set up FactoryTalk Alarms and Events servers in the application. For more information, see Chapter 11, “Setting up FactoryTalk alarms” in the FactoryTalk View Site Edition User’s Guide.

Even if you don’t plan to use FactoryTalk Alarms and Events services, do not uninstall the software, or you will not be able to run FactoryTalk View SE.

For additional information about FactoryTalk Alarms and Events, see the FactoryTalk Alarms and Events System Configuration Guide and the Release Notes.

To open the Alarms and Events System Configuration Guide

- On the desktop click Start >All Programs > Rockwell Software > FactoryTalk Tools, and then click FactoryTalk Alarms and Events System Configuration Guide.

To open the Alarms and Events Release Notes

- On the desktop click Start >All Programs > Rockwell Software > FactoryTalk Tools, and then click FactoryTalk Help.


FactoryTalk Activation services

FactoryTalk Activation services provide a secure, software-based system for activating Rockwell Software products and managing software activation files. For details, see Chapter 4, Activating FactoryTalk View software.

RSLinx Enterprise and RSLinx Classic

How you plan to obtain data for an application will determine which communications software you install.
You can use the RSLinx® Enterprise or RSLinx Classic software shipped with FactoryTalk View SE, or use other software and devices that support OPC (OLE for Process Control) communications.

RSLinx Enterprise is recommended for FactoryTalk View SE applications. For information about why you might choose RSLinx Classic, see page 52.

About FactoryTalk services and products

FactoryTalk View SE and other Rockwell Automation software products use a set of common FactoryTalk services to support several functions, for example, how application servers gain access to live data.

An automation and control system that uses FactoryTalk services, and integrates FactoryTalk products and components, is known as a FactoryTalk system. FactoryTalk View SE provides the HMI, or visualization component, in a FactoryTalk system.

Services installed with the FactoryTalk Services Platform

To provide essential FactoryTalk services, such as diagnostics messages, health monitoring, and access to real-time data, the FactoryTalk Services Platform must be installed on every computer that will run FactoryTalk View SE software components.

Using these services, FactoryTalk View SE and other FactoryTalk products can share and gain simultaneous access to resources such as tags and graphic displays, that only need to be defined once in the system.

Following is an overview of services installed with the FactoryTalk Services Platform. For installation instructions, see page 45.

FactoryTalk Alarms and Events and FactoryTalk Activation are installed during FactoryTalk View SE installation. These FactoryTalk services are described on page 5.

- **FactoryTalk Directory** centralizes access to system resources and names (for example, data tags and graphic displays) for all FactoryTalk products and components participating in an automated control system.


FactoryTalk Security centralizes user authentication and authorization at the FactoryTalk Directory.


FactoryTalk Live Data manages connections between FactoryTalk products and data servers.

For information about data communications in FactoryTalk View SE applications, see Chapter 8, “Setting up communications” in the FactoryTalk View Site Edition User’s Guide.

FactoryTalk Diagnostics collects and provides access to activity, status, warning, and error messages generated throughout a FactoryTalk system.

For information about setting up system diagnostics in FactoryTalk View SE applications, see Chapter 14, “Logging system activity” in the FactoryTalk View Site Edition User’s Guide.

FactoryTalk Administration Console is a stand-alone tool for developing, managing, and securing multiple applications.

To open the Administration Console, on the desktop click Start > All Programs > Rockwell Software, and then click FactoryTalk Administration Console.

Finding more information about FactoryTalk

For detailed information about FactoryTalk services, concepts, and components, including FactoryTalk Alarms and Events, see the FactoryTalk Help.

To open the FactoryTalk Help

On the desktop click Start > All Programs > Rockwell Software > FactoryTalk Tools, and then click FactoryTalk Help.

You can also open the FactoryTalk Help by clicking Help in dialog boxes used to set up FactoryTalk components and services.

FactoryTalk View tools and utilities

This section describes the tools and utilities installed with FactoryTalk View SE components, the FactoryTalk Services Platform, and the FactoryTalk Activation software.
FactoryTalk View SE tools

To run the following set of tools, on the desktop click Start > All Programs > Rockwell Software > FactoryTalk View > Tools, and then click the tool you want to run.

- **Application Documenter** is a stand-alone utility that provides detailed information on FactoryTalk View SE and ME applications. This utility is a browser that allows you to view the contents of the application’s components and the tags used in these components. You can also print and export the information.

- **Application Manager** is software for renaming, copying, deleting, backing up, and restoring FactoryTalk View SE local and FactoryTalk View Machine Edition applications.

  For FactoryTalk View SE network applications, use the Application Manager to rename and delete an application only.

- **DeskLock** is software that locks users into the FactoryTalk View SE Client and prevents them from gaining access to the Windows desktop and system keys.

- **FactoryTalk View SE Secure Web Site Setup** is software for setting up secure access to application components under Internet Information Services (IIS).

- **FTVIEWUSER Account Reset** is software for resetting the FTVIEWUSER account back to its default.

- **FTView Graphic Strings Search Replace** is software for performing search and replace operations on STRINGS that are contained within graphic displays. STRINGS include: tags, expressions, commands or text assigned to objects.

- **HMI Server Backup and Restore** is a utility for backing up FactoryTalk View SE HMI servers while they are running. Use this utility when backing up or restoring a stand-alone system, or when deploying a distributed system from one set of computers to another.

- **Legacy Tag database conversion** is software for converting your legacy tag database to a new format to work with Microsoft SQL database.

- **ME Firmware Upgrade Wizard** is a FactoryTalk View Machine Edition program for upgrading firmware on an operator interface terminal.

- **ME Transfer Utility** is a FactoryTalk View Machine Edition program for transferring applications to an operator interface terminal.

- **SE Administration Console** is software for administering FactoryTalk View SE applications after they are deployed.

  The Administration Console contains a sub-set of the FactoryTalk View Studio editors, which you can use to make minor changes to an application at run time.
SE HMI Tag Alarm Log Setup is software for setting up HMI tag alarm logging.

SE HMI Tag Alarm Log Viewer is software for viewing the contents of HMI tag alarm log files.

SE Service Manager is a tool that allows you to stop or start the FactoryTalk View HMI Service manually on the computer.

Tag Import and Export Wizard is software for importing or exporting the FactoryTalk View SE Server's tag database.

FactoryTalk tools

To run the following set of tools, on the desktop click Start > All Programs > Rockwell Software > FactoryTalk Tools, and then click the tool you want to run.

Diagnostics Viewer is software for viewing the contents of FactoryTalk Diagnostics logs, to help with troubleshooting the system.

FactoryTalk Directory Configuration Wizard is software for setting up the FactoryTalk Network Directory or Local Directory on the computer.

Import RSSecurity Configuration is software for importing RSSecurity setup information to FactoryTalk Security.

Log On to FactoryTalk is software for logging users on and off the FactoryTalk Directory.

Rockwell Software Data Client is diagnostic software for testing client and server data connections in an application.

RSSecurity Emulator Install is software for installing the RSSecurity Emulator, which emulates an RSSecurity Server for legacy products.

Specify FactoryTalk Directory Location is software for specifying which computer on the network contains the FactoryTalk Network Directory service.

Windows Firewall Configuration Utility is software for configuring firewall settings for FactoryTalk View.

FactoryTalk Activation Manager

To run FactoryTalk Activation Manager on the desktop click Start > All Programs > Rockwell Software > FactoryTalk Activation, and then click FactoryTalk Activation Manager.
Finding information about using FactoryTalk View SE

There are a number of resources available, if you need information about how to use or how to solve problems with using FactoryTalk View.

Try the FactoryTalk View product documentation first. The Help system and online user’s guides provide comprehensive information about typical uses of FactoryTalk View.

If you need to look further, you can also find information on the Internet, or contact Rockwell Automation Technical Support.

Finding information in the FactoryTalk View SE Help

The FactoryTalk View Help provides step-by-step procedures and reference information for working with all the features in FactoryTalk View.

While creating FactoryTalk View application components, you can get assistance with the task you are performing, or you can open the main Help file at the Contents tab, to search for the assistance you need.

To focus your search for information in the Help, use the index and search features:

- The Help index lists key words for topics in the Help. To use the index, click the Index tab, and then find and select key words you want information about.

- The search feature lets you find key words across all the text in the Help. To use the search feature, click the Search tab, and then type the key words you want to find.

![FactoryTalk View Site Edition Help](image-url)

To open a topic in the right-hand window, click the topic.

To see the topics in a book, double-click the book.

Working in the Explorer window

The Explorer window displays the FactoryTalk Directory icon at the top, and at the next level down, the FactoryTalk View application folder and the System folder. The FactoryTalk View application folder contains the editors and components you use to develop an application. In the System folder, you use FactoryTalk Security to specify which users, groups and computers have access to which resources in the system.

When you open an application in FactoryTalk View Studio, the Explorer window is docked on the left-hand side of the main window beside the workspace.

To open a folder

- Click the + symbol beside the folder’s icon, or double-click the folder.
To open the FactoryTalk View Site Edition Help

- In FactoryTalk View Studio, on the Help menu, click Contents.

To get help with the task you are performing

- In dialog boxes and wizards, click Help.

Opening the FactoryTalk View online manuals


To open the online manuals

1. Open FactoryTalk View Studio.
2. On the Help menu, click Online Books, and then click the manual you want to open.

To open the online manuals, Adobe® Reader® must be installed on the computer. If needed, you can install the software from the FactoryTalk View Site Edition DVD. For instructions, see page 44. For information about using Adobe Reader, see the product documentation.

What’s in the FactoryTalk View Site Edition User’s Guide

The FactoryTalk View Site Edition User’s Guide contains comprehensive information about developing FactoryTalk View SE applications, including information about how FactoryTalk services and products support FactoryTalk View SE. For example:

- working in the FactoryTalk View SE development environment.
- the key features of FactoryTalk View SE network and local applications.
- setting up communications and alarms for an application and working with tags.
- features that support system availability at run time.
- creating graphic displays and objects that operators can interact with at run time.
- animating graphic objects.
- gaining access to data using FactoryTalk View expressions and embedded variables.
- monitoring historical data using data log models and trends.
- using macros and FactoryTalk View commands in an application.
- processing data using derived tags and event detection.
Finding information on the Internet

If you can’t find the answer to your question in the user’s guides or Help, try the Web sites you can connect to from within FactoryTalk View Studio.

- The **Rockwell Automation Home Page** offers general information about Rockwell Automation products and services.

  To open the Rockwell Automation Web site in a Web browser, in the Address bar, enter [www.rockwellautomation.com](http://www.rockwellautomation.com).

- The **Rockwell Automation Downloads** page provides access to various resources, including information, drivers, and software extensions that you might need to develop your FactoryTalk View SE applications.

- The **Rockwell Automation Knowledgebase** offers a comprehensive, searchable database of support information for all Rockwell Automation products, including FactoryTalk View SE.


To connect to Web sites from within FactoryTalk View Studio

- On the Help menu, click **Rockwell Automation on the Web**, and then click the name of the Web site you want to visit.

  To connect to any Web site, you must have a Web browser installed on your computer, and you must have an active Internet connection.

Contacting Rockwell Automation Technical Support

If you can’t find the answer to your question in the documentation or on the Internet, contact Rockwell Automation Technical Support, using any of these methods:

- Telephone: 1-440-646-3434

- Online: [http://support.rockwellautomation.com](http://support.rockwellautomation.com)

Support staff are available Monday to Friday from 8 a.m. to 5 p.m. local time (North America only), except on statutory holidays.

If you plan to use Kepware data servers in a FactoryTalk View application, for information about how to get technical support, see Rockwell Automation Knowledgebase Answer ID 42951. FactoryTalk View ME and FactoryTalk View SE support different versions of Kepware. For details, see the FactoryTalk View Release Notes.
**When you call**

When you call, be at your computer and ready to provide the following information:

- the product's Serial Number and Product Key, which are printed on the Activation Certificate enclosed with the product software DVD.
- the product version number
- the Coordinated Product Release (CPR) number
- the type of hardware you are using
- the names of other Rockwell Automation products installed on the computer
- the exact wording of any messages displayed on the computer
- a description of what happened and what you were doing when the problem occurred
- a description of how you tried to solve the problem

If you are running a FactoryTalk View SE network application, also note:

- how many computers are participating in the network application.
- whether computers on the network are connected using a Windows domain controller, or a workgroup.
- which FactoryTalk View SE components are installed on participating computers.
- which computers are running servers (the Network Directory server, HMI servers, data servers, or tag alarm and event servers), and whether the servers are set up with redundancy.
- which computers are running clients (FactoryTalk View SE Client or FactoryTalk View Studio).
Before you install FactoryTalk® View Site Edition and any supporting software, to ensure that the software will run smoothly on computers in your application, review this chapter carefully, and then perform the necessary tasks.

The computer where you are installing FactoryTalk View SE will determine which tasks are appropriate: some tasks depend on the operating system installed on the computer; others depend on whether the computer will host an application client or server.

For example, it is recommended that you set up Data Execution Prevention (DEP) on computers running Microsoft® Windows® XP, Windows Server 2003, Windows 7 Professional, Windows Vista, and Windows Server 2008. For details, see page 37.

After you have read this chapter and set up the appropriate installation environment on all application computers, turn to other chapters in this manual for help with installing and activating FactoryTalk View Site Edition (also called FactoryTalk View SE).

For information about:

- installing the software from the FactoryTalk View Site Edition DVD, see Chapter 3, Installing FactoryTalk View Site Edition.
- activating the software, see Chapter 4, Activating FactoryTalk View software.
- deploying new applications to production computers, see Chapter 5, Deploying network applications or Chapter 6, Deploying local applications.

**About the architecture of your FactoryTalk View application**

The FactoryTalk View Site Edition DVD provides all the software you need to develop and run local applications confined to a single computer, or distributed control systems that involve several computers, connected over a network.

Depending on needs, the architecture of a FactoryTalk View distributed application (also called a network application) can be extremely complex, involving multiple devices, clients, and servers that represent different parts of your plant or process.

The application design should consider the network structure, device dependencies, and system availability strategies. It might also require the use of other Rockwell Automation products, such as RSLogix® 5000 or FactoryTalk Gateway.
If you have questions about architectural elements that are not covered in the FactoryTalk View SE documentation, look for answers in other Rockwell Automation product documentation, and on the Rockwell Automation Web site.

**Supporting documentation and resources**

Following are some recommended resources:

- *FactoryTalk View Site Edition v6.00 (CPR9) Distributed System Design Considerations.* This document is attached to Knowledgebase Answer ID 32549.

- *FactoryTalk View Site Edition v5.00 (CPR9) Server Redundancy Guidelines.* This document is attached to Knowledgebase Answer ID 40891.

- *Ethernet Design Considerations for Control System Networks.* This document is in the Literature Library. Search for Publication Number ENET-SO001A-EN-E.

- *Integrated Architecture for Process Control Systems.* This document is in the Literature Library. Search for Publication Number PROCES-RM001A-EN-P.

- *FactoryTalk View (RSView SE) Tips and Best Practices TOC.* Knowledgebase Answer ID 37110 is a list of links to Answers that are specific to FactoryTalk View SE.

**Finding information on the Rockwell Automation Web site**

The Rockwell Automation Web site has links to a Literature Library and Knowledgebase that provide additional product documentation and answers to technical questions you might have about your FactoryTalk View SE application.

**To open the Rockwell Automation Web site**

In your Web browser’s Address bar, type [www.rockwellautomation.com](http://www.rockwellautomation.com), and then press Enter.

**To find Answers in the Knowledgebase**

On the right side of the Rockwell Automation home page, under Resources, click Knowledgebase.

Follow the instructions on the Knowledgebase home page. You can search for answers by product, by entering key words or phrases, or by entering an Answer ID.

**To find documents in the Literature Library**

On the right side of the Rockwell Automation home page, under Resources, click Literature.

Follow the instructions on the Literature Library home page. You can search for documents by product, by entering key words or phrases, or by entering the publication number.
Overview of tasks: setting up computers to run FactoryTalk View

The checklist in this section summarizes the basic tasks involved in setting up application host computers, before you install FactoryTalk View SE.

Use the checklist to guide you through the tasks you need to perform. Each task is described in detail, in the rest of this chapter.

If appropriate, add or remove details to create a customized procedure that reflects which operating system will be installed on a computer, and the role the computer will play in your FactoryTalk View application.

For example, on a computer running Windows XP, you don’t need to remove the Internet Explorer Enhanced Security configuration. Or, on a computer that will run only the FactoryTalk View SE Client, you don’t need to install Internet Information Services (IIS).

Task checklist for setting up application computers

- Limits for application server host computers
- Hardware requirements for running FactoryTalk View SE
- Operating system requirements for running FactoryTalk View SE
- Set up the Windows domain or workgroup
- Set up computers with names to be used in production
- Disable operating system themes
- Manually configure Network Interface Cards (NICs) and switch ports
- Remove unnecessary DCOM networking protocols
- Establish network connections
- Disable or uninstall third-party firewalls
- Install Microsoft Internet Information Services
- Set up Internet Explorer for optimal access to components
- Set up Data Execution Prevention (DEP)
- On computers running Windows Server 2003 and Windows Server 2008:
  - Remove Internet Explorer Enhanced Security Configuration
Limits for application server host computers

In a network application, it is possible for a single server computer that meets the recommended requirements to host all of the following components:

- one FactoryTalk View SE Server (also called the HMI server)
- one RSLinx Enterprise data server (which can also be set up as FactoryTalk Alarms and Events device-based alarm server)
- one OPC®-DA server (RSLinx Classic or some other OPC data server)
- one FactoryTalk Tag Alarm and Event Server
- the FactoryTalk Network Directory

If a network application requires multiple HMI servers, data servers, or alarm servers, to distribute the load, it is recommended that you install the necessary software and run the servers on multiple host computers.

Running more than one HMI server on a single computer is not recommended.

For information about hardware requirements for running FactoryTalk View SE servers, see the next section. For information about operating system requirements, see page 20.

If you plan to deploy a network application that uses more than two servers (or two pairs of redundant servers) and 20 clients, it is recommended that you contact your local Rockwell Automation Sales office for architectural assistance. For information about setting up redundant FactoryTalk View SE Servers, see Chapter 13, “Setting up FactoryTalk system availability” in the FactoryTalk View Site Edition User’s Guide.

Hardware requirements for running FactoryTalk View SE

The hardware (or software) you use to run FactoryTalk View SE components depends on the demands your application places on the system. The greater the demand, the more powerful a system you need.

To develop applications with FactoryTalk View Studio, or to host large or complex applications, use computers with faster CPUs and more RAM. In any application, faster CPUs and more RAM will result in better performance.
It is also recommended that you have enough disk space to provide virtual memory that is at least twice the size of the physical RAM.

**Hardware requirements for operator workstations**

For computers hosting FactoryTalk View SE Clients in a network application, or for a FactoryTalk View SE Client running a local application:

- **Recommended requirements** are Intel Core 2 Duo, 2.66 GHz or higher, and 2 GB RAM or more.
- **Minimum requirements** are Intel Pentium 4, 2 GHz or higher, 1GB RAM or more.

Do not run FactoryTalk View SE Clients on computers that meet only minimum requirements, if the clients will connect to FactoryTalk Alarms and Events servers (Rockwell Automation Device Servers or Tag Alarm and Event Servers).

**Hardware requirements for engineering workstations**

For computers hosting FactoryTalk View Studio or FactoryTalk View SE Administration Console in a network application:

- **Recommended requirements** are Intel Core 2 Duo, 2.66 GHz or higher, and 2 GB RAM or more.
- **Minimum requirements** are Intel Pentium 4, 2 GHz or higher, 1GB RAM or more.

**Hardware requirements for application servers**

To support any number of clients (FactoryTalk View SE Client, FactoryTalk View Studio, the FactoryTalk View SE Administration Console, a FactoryTalk Transaction Manager connector, or a FactoryTalk View SE Server), for computers hosting application servers:

- **Recommended requirements** are Quad core Intel Xeon, 2.33 GHz or higher, 4 GB RAM.
- **Minimum requirements** are Intel Pentium 4, dual CPU, 3 GHz or higher, 2GB RAM or more.

Do not run FactoryTalk Alarms and Events servers (Rockwell Automation Device Server or Tag Alarm and Event Server) on computers that meet only minimum server requirements.
Operating system requirements for running FactoryTalk View SE

FactoryTalk View SE software is designed to run on Microsoft Windows operating systems, including:

- Windows 7 Professional (32-bit)
- Windows 7 Professional (64-bit)
- Windows 7 Professional with Service Pack 1 (32-bit)
- Windows 7 Professional with Service Pack 1 (64-bit)
- Windows Server 2008 Standard Edition (64-bit)
- Windows Server 2008 R2 Standard Edition with Service Pack 1 (64-bit)
- Windows Vista Business with Service Pack 2 (32-bit)
- Windows XP Professional with Service Pack 3 (32-bit)
- Windows Server 2003 R2 Standard Edition with Service Pack 2 (64-bit)

You can use Windows Vista only to run the FactoryTalk View SE Client, develop stand-alone or distributed applications on a single computer, or to run FactoryTalk View Studio and connect to remote HMI servers. You **cannot** use Windows Vista to host HMI servers that other clients connect to. To host HMI servers, use Windows7, Professional, Windows XP, Windows Server 2003, or Windows Server 2008 instead.

The choices you make will depend in part on whether the computer is to host an application client or server. You might choose to run operator or engineering workstations in a Windows Server operating system, but that is not required.
Recommended requirements for application servers are not as flexible, because server computers are more likely to host critical components and to bear more of the processing load in a FactoryTalk View SE application.

FactoryTalk View SE software is tested and supported on Windows operating systems installed from original Microsoft media only. Using unsupported operating systems is not recommended. If you plan to upgrade to Windows XP Professional from an earlier version of Windows, follow the instructions in Rockwell Automation Knowledgebase Answer ID 29104; otherwise, you will not be able to create or run FactoryTalk View applications.

**Operating system recommendations for application servers**

For computers hosting application servers (HMI servers, data servers, or Tag Alarm and Event Servers), operating system requirements depend on whether the server will support more or fewer than 10 client connections.

A *client* can be any of FactoryTalk View SE Client, FactoryTalk View Studio, the FactoryTalk View SE Administration Console, a FactoryTalk Transaction Manager connector, or another FactoryTalk View SE Server.

For application servers that support:

- **For more than 10 client connections**, the recommended operating system is either Windows Server 2008 Service Pack 1 or Service Pack 2 or Windows Server 2003 R2 Standard Edition with Service Pack 2 or Windows Server 2008 R2 Standard Edition with Service Pack 1, with the appropriate number of client access licenses (CAL) installed.

- **For 10 or fewer client connections**, the minimum requirement is Windows XP Professional with Service Pack 3 or Windows 7 Professional.

Windows Vista cannot be used as an application server with remote clients.

Do not run the primary and secondary servers in a redundant server pair on computers that have different operating systems. For example, do not run the primary server on a Windows Server 2003 computer and the secondary server on a Windows 2008 Server computer.

**About Windows Service Packs and compatibility**

When you install Microsoft Service Pack releases and other Windows operating system updates, you introduce new software that could affect the operation of FactoryTalk View SE components on the computer.

For this reason, installing Windows updates automatically on production computers is not recommended.
To stop automatic Windows updates

1. Open the Windows Control Panel, and then double-click System.
2. In the Automatic Updates tab, select the option, Turn off Automatic Updates.

For more information about Windows operating systems and Service Pack compatibility, see Rockwell Automation Knowledgebase Answer ID 20450.

Set up the Windows domain or workgroup

The number of computers participating in a FactoryTalk View SE network application determines whether the computers can belong to a Windows domain or a workgroup.

Workgroups can be used only in applications that include 10 or fewer computers. Do not use Windows Workgroups with more than 10 computers; windows domain is recommended in that case.

For more information about setting up domains and workgroups, see the document, FactoryTalk View Site Edition v6.10 (CPR9 SR4) System Design Considerations, attached to Rockwell Automation Knowledgebase Answer ID 32549.

Domain controller requirements

For network applications consisting of more than 10 computers, FactoryTalk View SE requires a domain controller.

The following domains are supported:

- Windows Server 2008 with Service Pack 2 (Standard Edition)
- Windows Server 2008 R2 with Service Pack 1 (Standard Edition)

For more information about Windows operating systems and Service Pack compatibility, see Rockwell Automation Knowledgebase Answer ID 20450.

Do not install FactoryTalk Directory, the FactoryTalk View SE Server, or any other application software on the same computer as the Windows domain controller.

Windows workgroup requirements

For network applications consisting of 10 computers or fewer, you can run FactoryTalk View SE in a Windows workgroup network environment.

For workgroup applications running in Windows XP, you must turn off simple file sharing and fast user switching on each computer in the workgroup.
To turn off simple file sharing in Windows XP
1. On the desktop or in Windows Explorer, right-click My Computer, and then click Explore.
2. On the Tools menu, click Folder Options.
3. In the View tab, under Advanced settings, clear the check box Use simple file sharing.

To turn off fast user switching in Windows XP
1. Open the Windows Control Panel, and then double-click User Accounts.
2. Click the link, Change the way Users Log on and Off.
3. Clear the check box Use Fast User Switching, and then click Apply Options.

Set up computers with names to be used in production
When you install the FactoryTalk Services Platform with FactoryTalk View SE, the program creates a FactoryTalk account for the current computer, under the Local and Network FactoryTalk Directories.

As a result, if you rename the computer after installing FactoryTalk View SE or when you deploy an application, the FactoryTalk Directory will not recognize the new name.

To avoid this problem, it is recommended that you give the application client and server host computers the names they will use in a production setting, before you install the FactoryTalk View SE software.

If you must rename a computer and you encounter problems, for assistance see Rockwell Automation Answer ID 35169 (for FactoryTalk View SE network applications) or Answer ID 38775 (for FactoryTalk View SE local and Machine Edition applications).

About synchronizing time on application computers
In a networked system, to ensure that time stamps on alarms, historical data, and diagnostics are accurate, it is highly recommended that time synchronization be configured on all application computers.

For more information about synchronizing application computer clocks to an authoritative time server, see FactoryTalk View SE v6.0 (CPR9) Distributed Design Considerations, attached to Rockwell Automation Answer ID 32549.

Disable operating system themes
Operating system themes, which allow for effects such as sounds, icons, and other elements that personalize the computer, can cause heavy loads on the computer’s
processor when running some FactoryTalk View SE graphic components, such as alarm summaries.

For best performance, disable all themes.

**To disable themes in Windows XP or Windows Server 2003**

1. Click **Start > Control Panel**.
2. In Control Panel, double-click **Displays**.
3. On the Themes tab, in the Theme list, click **Windows Classic**, and then click **OK**.

**To disable themes in Windows 7, Windows Vista or Windows Server 2008**

1. Click **Start > Control Panel**.
2. In Control Panel, click **Appearance and Personalization**.
3. Under Personalization, click **Change the theme**.
4. On the Themes tab, in the Theme list, click **Windows Classic**, and then click **OK**.

**Manually configure Network Interface Cards (NICs) and switch ports**

The Network Interface Card (NIC) is the hardware in a computer that lets it connect to other devices on the network. A switch manages traffic on the Ethernet network. Some switches allow ports (physical connections) to be configured individually.

The link speed and duplex settings for network connections can be auto-negotiated, which means that the device determines the best way to communicate, or manually configured, which means that the settings are hard coded.

Many Network Interface Cards also offer a power-saving feature that turns off the network card if it is not being used. This setting sometimes interferes with the ability of the computer to receive data, causing errors such as wireframes, stale data and other failures. To prevent these errors, disable power saving for your computer’s network interface cards. For details, see “To disable power saving for the NIC”.

For FactoryTalk View SE applications, it is recommended that you use managed switches across the control system network and that you manually configure the same link speed and duplex setting for all network connections into the managed switches.

It is also recommended that you manually configure the managed switch ports, using the same settings. To learn how to configure switch ports, see the product documentation provided with the switches you are using.
For an overview of best practices for connecting devices over a network, see the *Ethernet Design Considerations for Control System Networks* document in the Rockwell Automation Literature Library. (Search for Publication Number ENET-SO001A-EN-E.)

If you are using unmanaged switches the NIC settings must remain auto-negotiated. Connecting an auto-negotiated device to a manually configured device can result in network communication errors and is not recommended.

**To set up the NIC link speed and duplex**

The steps for setting the NIC link speed and duplex vary slightly for some of the Windows operating systems. See the sections that apply to the operating systems you are using.

**For Windows XP or Windows Server 2003**

1. Open the Windows Control Panel, and then double-click **Network Connections**.
2. Right-click **Local Area Connection**, and then click **Properties**.
3. In the General tab, beside the network device name, click **Configure**.
4. In the Properties dialog box for the device, click the Advanced tab, and then select **Speed & Duplex**.
5. In the Value list box, select the highest possible value for the connection—either **100 Mb Full**, or **1000 Mb without a duplex setting**.

**For Windows 7 Professional, Windows Vista or Windows Server 2008**

1. Open the Windows Control Panel, and then click **Network and Internet**.
2. In the list of categories, click **Network and Sharing Center**.
3. In the list of Tasks on the left, click **Manage network connections**.
4. In the list of network connections, right-click **Local Area Connection**, and then click **Properties**.
5. On the Networking tab, click **Configure**.
6. In the Properties dialog box for the device, click the **Advanced** tab.
7. In the list of properties for the device, click **Link Speed & Duplex**. In Windows Server 2008, click **Speed & Duplex**.
8. In the Value list, select the highest possible value for the connection, and then click **OK**.
To disable power saving for the NIC

The steps for disabling power saving for the NIC vary slightly for some of the Windows operating systems. See the sections that apply to the operating systems you are using.

To disable power saving in Windows XP or Windows Server 2003

1. Open the Windows Control Panel, and then double-click Network Connections.
2. Right-click Local Area Connection, and then click Properties.
3. In the General tab, beside the network device name, click Configure.
4. In the Properties dialog box for the device, click the Power Management tab.
5. Clear the Allow the computer to turn off this device to save power check box, and then click OK.

To disable power saving in Windows 7 Professional, Windows Vista or Windows Server 2008

1. Open the Windows Control Panel, and then click Network and Internet.
2. In the list of categories, click Network and Sharing Center.
3. In the list of Tasks on the left, click Manage network connections.
4. In the list of network connections, right-click Local Area Connection, and then click Properties.
5. On the Networking tab, click Configure.
6. In the Properties dialog box for the device, click the Power Management tab.
7. Clear the Allow the computer to turn off this device to save power check box, and then click OK.

Remove unnecessary DCOM networking protocols

If multiple DCOM protocols are installed and set up on the computer, to ensure that DCOM communications function correctly, remove all protocols other than TCP/IP.

To remove unnecessary DCOM protocols

1. On the desktop, click Start, and then click Run.
2. In the Run dialog box, type dcomcnfg, and then click OK.
3. In the Component Services tool, expand Component Services, open the Computers folder, right-click My Computer, and then click Properties.

4. Click the Default Protocols tab. If the DCOM Protocols list displays protocols in addition to TCP/IP, remove those unnecessary protocols. For example, remove the protocol Connection-oriented SPX.

Establish network connections

When you know which computers your network application will use, and you have provided names for them, confirm that the computers are connected to the network before you install any FactoryTalk View SE software.

A network connection is required to install FactoryTalk View SE, even if you plan to develop and run a local application.

To install the software on host computers in a network application, you must at least be able to contact the FactoryTalk Network Directory server computer.

To test the connection to the Network Directory computer

1. On the desktop click Start, and then click Run.

2. In the Open list box, type ping [ComputerName], where ComputerName is the name of the FactoryTalk Network Directory server computer, and then click OK.

If the computer you are pinging from is connected, you should receive a reply from the IP Address of the server computer, as shown in the next illustration.

![Ping output example](image)

Disable or uninstall third-party firewalls

FactoryTalk View SE is compatible only with the built-in Windows firewall and should not be used with third-party firewalls because this can cause unexpected results.

Before installing FactoryTalk View SE, disable or uninstall all third-party firewalls on the computer. For details, see the documentation supplied with your firewall product.
Install Microsoft Internet Information Services

When you install FactoryTalk View SE, the program detects whether Microsoft® Internet Information Services (IIS) is installed on the computer.

If IIS is not installed, you are notified and asked to install the software. However, you must cancel the FactoryTalk View SE Setup program and then restart it after you have installed IIS, otherwise you will need to repair the FactoryTalk View SE installation to make FactoryTalk View SE work with IIS. Failing to do so can prevent clients from being able to communicate with servers.

You must install IIS for FactoryTalk View SE network applications:

- on all computers that will run FactoryTalk View SE Servers (also called HMI servers).
- on engineering workstations that will run all the FactoryTalk View SE software components.

You can use Windows Vista only to run the FactoryTalk View SE Client, develop stand-alone or distributed applications on a single computer, or to run FactoryTalk View Studio and connect to remote HMI servers. You cannot use Windows Vista to host HMI servers that other clients connect to. To host HMI servers, use Windows 7 Professional, Windows XP, Windows Server 2003, or Windows Server 2008 instead.

You do not have to install IIS if you plan to develop and run only FactoryTalk View SE local applications.

If you plan to develop or run FactoryTalk View SE on computers running Windows Server 2003 earlier than Service Pack 2, it is recommended that you also install the Microsoft DCOM 108 patch. For more information, see Rockwell Automation Knowledgebase Answer ID 37039.

If necessary, you can install IIS from your Microsoft Windows operating system DVD.

To install IIS on Windows 7 Professional

1. Open the Windows Control Panel, click Programs.
2. Under Programs and Features, click Turn Windows features on or off. The Windows Features dialog box will open.
3. Click the checkbox to the left of Internet Information Services to enable settings.
4. Expand the Web Management Tools folders, and then expand the IIS 6 Management Compatibility folder.
5. Select the IIS Metabase and IIS 6 configuration compatibility check box.
6. Expand the **World Wide Web Services** folder and then expand the **Application Development Features** folder.

7. Select the **ASP** check box. The **ISAPI Extensions** check box should then be selected automatically.

8. Under the **World Wide Web Services** folder, expand the **Common HTTP Features** folder.

9. Select the **WebDAV Publishing** checkbox.

10. Under **World Wide Web Services** folder, expand the **Security** folder.

11. Select the **Windows Authentication and URL Authorization** checkboxes.

If IIS is installed correctly, you should be able to open the HMI server status page on localhost first, then from another computer. To test this, open Internet Explorer®, in the address field, type `http://localhost/rsviewse`, or `http://computername/rsviewse` then the Enter key.

**To install IIS on Windows Server 2008**

1. Click **Start**, point to **Administrative Tools** and then click **Server Manager**.

2. In the Server Manager window, under Roles Summary, click **Add Roles**.

3. Use the Add Roles Wizard to add the **Web Server (IIS)** role.

4. To install the Web Server, some additional Windows features might need to be installed. In each case, click **Add Required Features**.

5. In the Add Role Services dialog box, expand **Common HTTP Features**, and then click **WebDAV Publishing**.

If you are running on Windows Server 2008 Standard Edition with Service Pack 2, the steps to install WebDAV are different. See “Installing WebDAV on Windows Server 2008 Standard Edition with Service Pack 2” on page 32.

6. Click to expand **Application Development**, and then click **ASP**.
7. When prompted to install ISAPI Extensions, click **Add Required Role Services**.


9. Click to expand **Management Tools** and then expand **IIS 6 Management Compatibility**.
10. Under IIS 6 Management Compatibility, select **IIS 6 Metabase Compatibility**.

11. Click **Next**, and then accept the default selections at each remaining step of the wizard by clicking **Next** until all of the steps are complete.

12. At the end of the wizard, click **Install** to install the Web Server role.

13. After you have installed the Web Server role, install WebDAV, as described in the next section.

WebDAV allows remote clients to connect to HMI servers located on a computer running Windows Server 2008 Standard Edition with Service Pack 2.

With Windows Server 2008 Standard Edition with Service Pack 2, Microsoft no longer automatically distributes the IETF WebDAV extensions to HTTP (as defined in RFC 2518). For Windows Server 2008 Standard Edition with Service Pack 2, download and then install these extensions from Microsoft at:

Microsoft WebDAV Extension for IIS 7.0 (x86 or x64)

http://www.iis.net/download/webDAV

If IIS is installed correctly, you should be able to open the HMI server status page. To test this, on the desktop click Start, click Run, type http://localhost/rsviewse, and then press Enter.

To install IIS on Windows Vista

You can use Windows Vista only to run the FactoryTalk View SE Client, develop stand-alone or distributed applications on a single computer, or to run FactoryTalk View Studio and connect to remote HMI servers. You cannot use Windows Vista to host HMI servers that other clients connect to. To host HMI servers, use Windows XP, Windows 7 Professional, Windows Server 2003, or Windows Server 2008 instead.

1. Close all open Windows programs.
2. Open the Windows Control Panel, click Control Panel Home, and then click Programs.
3. Under Programs and Features, click Turn Windows features on or off.
4. In the Windows Features dialog box, select the Internet Information Services check box.
5. In the list of Windows Features, expand Web Management Tools and then expand IIS 6 Management Compatibility.
6. Select the IIS Metabase and IIS 6 configuration compatibility check box.
7. In the list of Windows Features, expand World Wide Web Services and then expand Application Development Features.
8. Select the ASP check box. The ISAPI Extensions check box should then be selected automatically.

![Windows Features](image)

9. When you are finished, click OK.

If IIS is installed correctly, you should be able to open the HMI server status page. To test this, on the desktop click Start, click Run, type `http://localhost/rsviewse`, and then press Enter.

**To install IIS on Windows Server 2003**

1. Close all open Windows programs.
2. Place your Windows DVD in the computer’s DVD drive.
3. Open the Windows Control Panel, and then double-click **Add or Remove Programs**.
4. On the left side of the Add or Remove Programs window, click **Add/Remove Windows Components**.
5. After the Windows Components Wizard starts, in the Components list, double-click Application Server.

6. In the Application Server dialog box, double-click Internet Information Services (IIS).

7. In the Internet Information Services (IIS) dialog box, select the check box World Wide Web Service. (The Internet Information Services Manager and Common Files check boxes should be selected already.)


9. In the World Wide Web Service dialog box, select the check boxes Active Server Pages and WebDAV Publishing. (The World Wide Web Service check box should be selected already.)

10. Click OK until you return to the Windows Components Wizard, and then click Next.

11. To finish installing IIS, follow the instructions in the wizard.

If IIS is installed correctly, you should be able to open the HMI server status page. To test this, on the desktop click Start, click Run, type http://localhost/rsviewse, and then press Enter.

To install IIS on Windows XP

1. Close all open Windows programs.

2. Place your Windows XP disc in the computer’s disc drive.

3. Open the Windows Control Panel, and then double-click Add or Remove Programs.

4. On the left side of the Add or Remove Programs window, click Add/Remove Windows Components.

5. After the Windows Components Wizard starts, select the check box Internet Information Services (IIS), and then click Details.

6. In the Internet Information Services (IIS) dialog box, select the check boxes Common Files, Internet Information Services Snap-In, and World Wide Web Server.

7. Click OK, and then click Next.

8. To finish installing IIS, follow the instructions in the wizard.

If IIS is installed correctly, you should be able to open the HMI server status page. To test this, on the desktop click Start, click Run, type http://localhost/rsviewse, and then press Enter.
About uninstalling IIS

If for some reason you need to uninstall and then reinstall Microsoft Internet Information Services, after reinstalling you need to re-create the virtual directories in IIS. To do this, run the RSViewWebManager program installed with FactoryTalk View SE.

To recreate the virtual directories in IIS

In Windows Explorer, open c:\Program files\Rockwell Software\RSView Enterprise, and then double-click RSViewWebManager.exe.

Set up Internet Explorer for optimal access to components

FactoryTalk View stores cached copies of graphic displays and other HMI server components in the Temporary Internet Files folder, so that the components load faster when application clients request them.

To optimize access to HMI server components, certain Internet Explorer settings are recommended for all application client and server computers.

Turn off the Work Offline setting

To ensure that Internet Explorer detects updates to cached HMI server components, and that FactoryTalk View SE Clients can load components that aren’t already in the cache, make sure the Work Offline setting is turned off.

To turn off Work Offline

In Internet Explorer, on the File menu, if there is a check mark beside Work Offline, clear the check mark by selecting Work Offline.

Check for newer versions with every visit to a page

To ensure that FactoryTalk View SE Clients can always download and use the latest versions of HMI server components, set Internet Explorer to check for newer versions of stored pages with every visit to a page.

The steps vary slightly for some of the Windows operating systems. See the sections that apply to the operating systems you are using.
To check for newer versions in Internet Explorer 6
1. In Internet Explorer, on the Tools menu, click Internet Options.
2. On the General tab, under Temporary Internet files, click Settings.
3. Under Check for newer versions of stored pages, click Every visit to the page.

To check for newer versions in Internet Explorer 7 or later
1. In Internet Explorer, on the Tools menu, click Internet Options.
2. In the General tab, under Browsing history, click Settings.
3. In the Temporary Internet Files and History Settings dialog box, select Every time I visit the webpage.

Specifying enough usable disk space
To ensure that FactoryTalk View Studio can open previous versions of HMI project, and that FactoryTalk View SE Clients can open HMI server components, set the amount of usable disk space to twice the size of the HMI project folder.

If the application contains multiple HMI servers, add up the size of all the corresponding HMI project folders, and multiply that number by two.

Where HMI project files are stored
HMI project files are stored in the following location, on computers hosting HMI servers in a network application:

- For Windows 7 Professional, Windows Vista and Windows Server 2008:
  . . .\Users\Public\Documents\RSView Enterprise\SE\HMI Projects
- For Windows XP and Windows Server 2003:
  . . .\Documents and Settings\All Users\Shared Documents\RSView Enterprise\SE\HMI Projects

The steps vary slightly for some of the Windows operating systems. See the sections that apply to the operating systems you are using.

To specify enough disk space with Internet Explorer 6
1. In Internet Explorer, on the Tools menu, click Internet Options.
2. In the General tab, under Temporary Internet files, click Settings.
3. Under Amount of disk space to use, move the slider or type a number that is at least twice the size, in MB, of the HMI project’s folder.
HMI project folders are located in ..\Documents and Settings\All Users\Shared Documents\RSView Enterprise\SE\HMI Projects\. The folders have the same name given the corresponding HMI servers in FactoryTalk View Studio.


**To specify enough disk space with Internet Explorer 7 or later**

1. In Internet Explorer, on the Tools menu, click **Internet Options**.

2. In the General tab, under Browsing history, click **Settings**.

3. In the Temporary Internet Files and History Settings dialog box, under Disk space to use, type a number that is at least twice the size, in MB, of the HMI project’s folder.

HMI project folders are located in ..\Users\Public\Documents\RSView Enterprise\SE\HMI Projects\. The folders have the same name given the corresponding HMI servers in FactoryTalk View Studio.

**Set up Data Execution Prevention (DEP)**

Data Execution Prevention (DEP) is a Microsoft Windows security feature in Windows XP (with Service Pack 2 or later), Windows Server 2003 (with Service Pack 1 or R2), Windows 7 Professional, Windows Vista, and Windows Server 2008. DEP is intended to protect programs and services from viruses and other security threats.

The DEP settings determine which programs and services are covered by DEP protection. On computers running FactoryTalk View SE components, it is recommended that DEP be turned on for essential Windows programs and services only.

The steps vary slightly for some of the Windows operating systems. See the sections that apply to the operating systems you are using.

**To set up DEP in Windows XP or Windows Server 2003**

1. Open the Windows Control Panel, and then double-click **System**.

2. In the Advanced tab, under Performance, click **Settings**.

3. In the Performance Options dialog box, click the **Data Execution Prevention** tab.

   Select the option, **Turn on DEP for essential Windows programs and services only**, and then click **Apply**.
To set up DEP in Windows 7 Professional, Windows Vista or Windows Server 2008

1. Open the Windows Control Panel, click Control Panel Home, and then click System and Maintenance.

2. Click System.

3. In the list of tasks on the left, click Advanced system settings.

4. In the System Properties dialog box, click the Advanced tab.

5. On the Advanced tab, under Performance, click Settings.

6. In the Performance Options dialog box, click the Data Execution Prevention tab.

7. Select the option, Turn on DEP for essential Windows programs and services only, and then click OK.

Additional settings for Windows Server 2003 and Windows Server 2008 computers

The settings recommended in this section apply only to application computers running Windows Server 2003 or Windows Server 2008.

Remove Internet Explorer Enhanced Security Configuration

Internet Explorer Enhanced Security Configuration (ESC) is a group of default security settings for Windows Server 2003 and Windows Server 2008, that protects servers by limiting the ways users can browse Internet and Intranet Web sites on the computer.

If installed on a computer with FactoryTalk View SE software components, the Internet Explorer Enhanced Security Configuration can interfere with the ability of FactoryTalk View SE Clients to connect to application servers.

To avoid unexpected behavior, it is recommended that you remove the Enhanced Security Configuration from Windows Server 2003 computers running FactoryTalk View SE.

To remove ESC in Windows Server 2003

1. Open the Windows Control Panel, and then double-click Add or Remove Programs.

2. On the left side of the Add or Remove Programs dialog box, click Add/Remove Windows Components.

3. In the list of Components, clear the check box beside Internet Explorer Enhanced Security Configuration, and then click Next.

4. Follow the instructions in the wizard to finish turning off Internet Explorer Enhanced Security Configuration.
To remove ESC in Windows Server 2008

1. Click **Start**, point to **Administrative Tools** and then click **Server Manager**.

2. In the Server Manager window, under **Security Information**, click **Configure IE ESC**.

3. In the Internet Explorer Enhanced Security Configuration dialog, click **Off** to turn off IE Enhanced Security for Administrators and for users, and then click **OK**.
Installing FactoryTalk View Site Edition

The FactoryTalk® View Site Edition DVD provides all the software you need to develop and run complex distributed systems involving multiple computers on a network, or local applications confined to a single computer.

This chapter describes how to install FactoryTalk View Site Edition and supporting software, such as the FactoryTalk Services Platform and RSLinx® Enterprise, on application computers for the first time.

To learn about upgrading an existing version of RSView Enterprise or FactoryTalk View SE, see Chapter 7, *Upgrading FactoryTalk View Site Edition*.

Deciding which FactoryTalk View SE components to install

The FactoryTalk View Site Edition setup program offers two options for installing the FactoryTalk View SE software. You can select:

- **Complete**, to install all FactoryTalk View SE components on the computer.
- **Selected components**, to select which FactoryTalk View SE components will be installed.

The option you choose depends on the type of FactoryTalk View application or software component you plan to run on the computer and on the design of your control system.

When to install all FactoryTalk View SE components

You *must* install all of the FactoryTalk View SE software on a computer where you plan to develop, test, and run a FactoryTalk View local application (also called SE Station).

OPC data servers are the only components that can run on separate computers in a local application.

You might also install all the software on a computer that will function as an engineering workstation for a network application. Later, when you deploy the application, you can select which components are appropriate to install on each production computer.

When to install selected FactoryTalk View SE components

Installing selected FactoryTalk View SE components is an efficient way to deploy a network application for production. You decide what’s necessary for client and server computers, and then install only that software.
For example, to deploy a simple network application consisting of one HMI server, one Rockwell Automation Device Server (RSLinx Enterprise), and one HMI run-time client, you only need to install the FactoryTalk View SE Client software on the client computer.

You must install the FactoryTalk Services Platform first, whether you install all or only some of the FactoryTalk View SE software on a computer. For details, see page 45.

**About FactoryTalk Alarms and Events**

FactoryTalk Alarms and Events provides system-wide alarm monitoring and control capability, centralized at the FactoryTalk Directory. The software installs automatically, behind the scenes, while FactoryTalk View SE is being installed.

If plan to use Alarms and Events services and log historical alarm data for a FactoryTalk View SE application, Microsoft® SQL Server must be installed on computers where alarm data will be stored.

You can use an existing SQL Server, or install SQL Server Express from the FactoryTalk View Site Edition DVD. For details, see the *FactoryTalk Alarms and Events System Configuration Guide*, available from the Start menu after you have installed FactoryTalk View SE. Click *Start > All Programs > Rockwell Software > FactoryTalk Tools > FactoryTalk Alarms and Events System Configuration Guide*.

Even if you don’t plan to use FactoryTalk Alarms and Events services, do not uninstall the software, or you will not be able to run FactoryTalk View SE.

**Overview of tasks: installing the FactoryTalk View SE software**

The checklist in this section summarizes the basic tasks involved in installing FactoryTalk View SE and supporting software. Use the checklist to guide you through the tasks you need to perform. Each task is described in detail, in the rest of this chapter.

Whether you are installing the software for the first time, if appropriate, add or remove details to create a customized procedure that reflects the role the computer will play in your FactoryTalk View application.

For example, on a computer that will run only the FactoryTalk View SE Client, you don’t need to install any data communications software. Or, on a computer where supporting .NET software is already installed, you will not be required to install it again.

Before installing FactoryTalk View SE or any supporting software, review Chapter 2, *Setting up the installation environment*, and ensure that you have performed the tasks that are appropriate to the role and configuration of each application host computer.
Task checklist for installing FactoryTalk View SE

- Ensure that the user installing the software has administrative rights in Windows.
- Ensure that there are no earlier product versions installed on the computer.
- Install the FactoryTalk Services Platform.
- Install the FactoryTalk View Site Edition software.
- Install RSLinx Enterprise or RSLinx Classic™ (optional).
- Install available product updates.

To run the FactoryTalk View Site Edition DVD
1. Close all open Windows programs.
2. Place the FactoryTalk View Site Edition DVD in the computer’s DVD drive.
   
   The DVD should start running automatically. If not, run D:\setup.exe, where D is the drive containing the DVD.

   When you point at an option on the FactoryTalk View Site Edition DVD, a description of the option is displayed on the right side of the page.

About the Installation Assistant

The Installation Assistant is a Help file that you can run together with the FactoryTalk View SE installation program, to get additional help with installing FactoryTalk View SE.

The Installation Assistant guides you through the installation process by asking questions about the type of application you plan to run, and whether you are installing the software for the first time.

Depending on how you answer the questions during the installation process, the Installation Assistant provides information about which software programs to install and in what order.

To open the Installation Assistant
1. If necessary, close all open Windows programs, and then place the FactoryTalk View Site Edition DVD in the computer’s DVD drive.
   
   If the DVD does not start automatically, run D:\setup.exe, where D is the drive containing the DVD.
2. Click Open Installation Instructions (the first option).
3. Click Open FactoryTalk View Installation Assistant.
Opening the online Installation Guide

This manual is available in PDF format, from the Installation Instructions page on the FactoryTalk View Site Edition DVD.

To open the online manual, first ensure that Adobe® Reader® is installed on the computer, and then open FactoryTalk View Installation Guide.

To install the Adobe Reader software

1. If necessary, close all open Windows programs, and then place the FactoryTalk View Site Edition DVD in the computer’s DVD drive.
   
   If the DVD does not start automatically, run D:\setup.exe, where D is the drive containing the DVD.

2. Click Open Installation Instructions (the first option).

3. Click Install Adobe Reader.

4. To finish installing the software, follow the instructions in the wizard.

Ensure that the logged-on user is a Windows administrator

As part of the installation process, FactoryTalk View SE creates program folders and modifies registry entries.

For this part of the process to succeed, the user installing the software must have administrative rights in Windows on the computer where the software is being installed.

For example, the Windows domain Administrator account has these rights and will be able to install FactoryTalk View SE.

You do not need administrative rights to run FactoryTalk View.

Check for earlier versions of FactoryTalk View Site Edition

Before you can install FactoryTalk View SE or any supporting software, you must remove earlier versions of the software that are installed on the computer.

Even if you are installing the software for the first time, check to make sure that there are no earlier versions of FactoryTalk View or any supporting software on the computer.

In the FactoryTalk View Site Edition DVD, when you select Uninstall FactoryTalk View Site Edition, the uninstall program automatically detects software that must be removed.

If your check reveals software that must be uninstalled, for complete instructions, see “How to uninstall FactoryTalk View SE and supporting software” on page 132.
Install the FactoryTalk Services Platform

The FactoryTalk Services Platform (formerly known as the FactoryTalk Automation Platform) provides essential services to all FactoryTalk products running on a computer.

You must install the FactoryTalk Services Platform first, before you can install FactoryTalk View SE or any other FactoryTalk product on the computer.

Even if you are using third-party data communications software (Kepware, for example), you must still install the FactoryTalk Services Platform on the computer running the data server. FactoryTalk View ME and FactoryTalk View SE support different versions of Kepware. For details, see the FactoryTalk View Release Notes.

To install the FactoryTalk Services Platform

1. If necessary, close all open Windows programs, and then place the FactoryTalk View Site Edition DVD in the computer’s DVD drive.

   If the DVD does not start automatically, run D:\setup.exe, where D is the drive containing the DVD.

2. Click Install FactoryTalk View Site Edition (the second option).

3. Click step 2, Install FactoryTalk Services Platform.

4. To finish installing the software, follow the instructions in the wizard.

Install SQL Server Express Prerequisites

To successfully install Microsoft® SQL Server® 2008 R2 Express, you must have Windows Installer 4.5 installed on your computer first. Click Install SQL Server Express Prerequisites to install Windows Instaler 4.5 on your computer.

Skip this step if you only plan to install FactoryTalk View Client on the computer, since Microsoft® SQL Server® 2008 R2 Express is installed only when you choose to install FactoryTalk View Studio or HMI server.

To install the SQL Server Express Prerequisites

1. If necessary, close all open Windows programs, and then place the FactoryTalk View Site Edition DVD in the computer’s DVD drive.

   If the DVD does not start automatically, run D:\setup.exe, where D is the drive containing the DVD.
2. Click **Install FactoryTalk View Site Edition** (the second option).

3. Click step 3, **Install SQL Server Express Prerequisites**.

4. To finish installing the software, follow the instructions in the wizard.

## Install FactoryTalk View Site Edition

The FactoryTalk View Site Edition setup program presents two options for installing FactoryTalk View SE the software components, including FactoryTalk View SE Client, FactoryTalk View SE Server, and FactoryTalk View Studio.

In the program’s Setup Type window, you can select:

- **Complete** (the default), to install all FactoryTalk View SE components on the computer.

- **Selected Components**, to install only the components you choose for the computer. For example, you might only install the FactoryTalk View SE Client software on an operator workstation.

You can use Windows Vista only to run the FactoryTalk View SE Client, develop stand-alone or distributed applications on a single computer, or to run FactoryTalk View Studio and connect to remote HMI servers. You **cannot** use Windows Vista to host HMI servers that other clients connect to. To host HMI servers, use Windows 7 Professional, Windows XP, Windows Server 2003, or Windows Server 2008 instead.

Most of the tasks involved in installing the two Setup Types are the same. Start with the steps in “To prepare to install the FactoryTalk View SE software,” next.

### To prepare to install the FactoryTalk View SE software

1. If necessary, close all open Windows programs, and then place the FactoryTalk View Site Edition DVD in the computer’s DVD drive.

   If the DVD does not start automatically, run D:\setup.exe, where D is the drive containing the DVD.

2. Click **Install FactoryTalk View Site Edition** (the second option).

3. Click step 4, **Install FactoryTalk View Site Edition**.

4. To continue installing FactoryTalk View SE, click **Yes** in the warning message about stopping Rockwell Automation software processes.

   The FactoryTalk View Site Edition installation wizard starts running.

5. In the Welcome window, click **Next**.
6. Accept the License Agreement, and then click **Next**

7. In the Customer Information window, type a user and organization name, type the product’s Serial Number, and then click **Next**.

   If you are installing FactoryTalk View for the first time, you will find the Serial Number on the Activation Certificate enclosed with the FactoryTalk View Site Edition DVD.

8. To install all the FactoryTalk View SE software automatically, follow the instructions under “To install all FactoryTalk View SE components on the computer,” next.

   If you want to choose which components to install, follow the instructions under “To install selected FactoryTalk View SE components.”

---

Starting from FactoryTalk View 6.1, FactoryTalk View uses Microsoft® SQL Server® 2008 R2 Express for the HMI tag database. Microsoft® SQL Server® 2008 R2 Express will be automatically installed on the computer, when you install FactoryTalk View Studio or HMI server on your computer. An instance named ‘FTVIEWx64TagDB’ is created for the HMI tag database. If for some reason the instance is deleted, you will need to recreate the instance manually, see “Recreate SQL Server 2008 Express instance ‘FTVIEWx64TagDB’” on page 51.

---

**To install all FactoryTalk View SE components on the computer**

1. In the Setup Type window, select **Complete**, and then click **Next**.

   If you want to install selected components, follow the steps in “To install selected FactoryTalk View SE components,” next.

2. In the Destination Drive window, accept the default destination drive or specify a different drive, and then click **Next**.

3. Click **Install**.

   After the software finishes installing, proceed with the steps in “To finish installing FactoryTalk View SE” on page 49.

**To install selected FactoryTalk View SE components**

1. In the Setup Type window, select **Selected Components**, and then click **Next**.

2. In the Destination Drive window, accept the default destination drive or specify a different drive, and then click **Next**.

3. In the Custom Setup window, click the down arrow beside each component name and select one of the following options, to include or exclude a component or subcomponent:

   - **This feature will be installed on local hard drive**—installs the component.
This feature, and all subfeatures, will be installed on local hard drive—installs the entire feature.

This feature will not be available—does not install the feature.

To install the components you have selected, in the Ready to Install the Program window, click **Install**.

To reveal subcomponents, click the + icon beside Samples.

You can use Windows Vista only to run the FactoryTalk View SE Client, develop stand-alone or distributed applications on a single computer, or to run FactoryTalk View Studio and connect to remote HMI servers. You **cannot** use Windows Vista to host HMI servers that other clients connect to. To host HMI servers, use Windows 7 Professional, Windows XP, Windows Server 2003, or Windows Server 2008 instead.
To finish installing FactoryTalk View SE

1. After the FactoryTalk View SE software finishes installing, the Wizard Completed window opens.

2. Aside from FactoryTalk Activation, select any or all of the following options, and then click **Finish**:
   - **Install FactoryTalk Activation**
     Starting from FactoryTalk View 6.1, FactoryTalk Activation is the only software that allows you to activate Rockwell Software. By default, FactoryTalk Activation is installed on your computer after installing FactoryTalk View.
- **Specify FactoryTalk Directory server location**
  Select this check box if you want to specify the location of FactoryTalk Network Directory on the computer.

  After you click Finish, the FactoryTalk Directory Server Location Utility will run. For information about using the utility, see “About specifying the FactoryTalk Network Directory server,” next.

  If you are installing FactoryTalk View to create or run a local application, you can clear the check box Specify FactoryTalk Directory server location. The FactoryTalk Local Directory is set up automatically on the computer.

- **Launch Release Notes**
  Select this check box if you want the FactoryTalk View Site Edition Release Notes to open after you click Finish.

3. Restart the computer.

   You can wait to restart the computer if you want to install RSLinx Enterprise or RSLinx Classic first; however, you must restart before running FactoryTalk View SE.

### About specifying the Network Directory server location

Use the FactoryTalk Directory Server Location Utility to specify the computer that will host the FactoryTalk Network Directory, and to indicate the location of the Network Directory server, on application client and server computers.

Using the FactoryTalk Directory Server Location utility could require more than one set of security credentials: to run the tool, you must be an administrator on the local computer; to select a remote Network Directory server, you must be an administrator on the remote computer.

### To set up the local computer as the Network Directory server

1. Open the FactoryTalk Directory Server Location Utility.

   You will have to log on as an administrator on the local computer.

2. If `localhost` is displayed in the field under **Computer hosting directory server**, the computer is already specified as the Network Directory host. You can close the utility.

   If `localhost` is not displayed, click the Browse button.

3. In the FactoryTalk Directory Server Configuration dialog box, click **This computer**, and then click **OK**.

4. Click **OK** again, to close the FactoryTalk Directory Server Location Utility.
To specify the Network Directory on client and server computers

1. Open the FactoryTalk Directory Server Location Utility.
   You will have to log on as an administrator on the local computer.

2. If a remote computer is hosting the Network Directory server, click the Browse button beside the field, Computer hosting directory server.

3. In the FactoryTalk Directory Server Configuration dialog box, click **Remote computer**.

4. Type the name of the Network Directory server computer, or click the Browse button to find and select the computer, and then click **OK**.
   You will have to log on as an administrator on the remote computer.

5. Click **OK** again, to close the FactoryTalk Directory Server Location Utility.

Repeat steps 1 to 6 on all client and server computers that will participate in the same network application.

FactoryTalk View SE program folders

To run FactoryTalk View SE and any supporting software you have installed, click Start &gt; Rockwell Software, and then double-click shortcuts in the following folders:

- The **FactoryTalk Activation** folder contains shortcuts for FactoryTalk Activation Manager.

- The **FactoryTalk Tools** folder contains shortcuts for the Diagnostics Viewer, Rockwell Software Data Client, and other FactoryTalk tools and utilities. It also contains shortcuts for FactoryTalk Help.

- The **FactoryTalk View** folder contains shortcuts for FactoryTalk View components, tools, and utilities.

Install RSLinx Enterprise or RSLinx Classic

The FactoryTalk View Site Edition DVD includes programs for installing RSLinx Enterprise and RSLinx Classic communications software.

RSLinx Enterprise is a FactoryTalk Live Data server that can run on multiple platforms, from PanelView™ Plus dedicated terminals to desktop computers.

For communications with Allen-Bradley local and remote devices—particularly with Logix5000 controllers—RSLinx Enterprise is the recommended data communications software for FactoryTalk View applications.
However, RSLinx Enterprise does not allow you to create alias topic shortcuts, or to perform online tasks such as uploading and downloading RSLogix® 5000 files. If you need these capabilities, use RSLinx Classic as your data communications server. For more information, see “When to use RSLinx Classic” on page 52.

To use an RSLinx Enterprise data server (also called a Rockwell Automation Device Server) in a local application, you must install and run the RSLinx Enterprise software on the same computer where FactoryTalk View SE is installed.

To use RSLinx Enterprise data servers in a network application, you must install and run the RSLinx Enterprise software on each computer that will run a data server, and on engineering workstations that will run FactoryTalk View Studio.

You must install RSLinx Enterprise on engineering workstations running FactoryTalk View Studio, even if the data servers in the application will run on remote computers.

**To install RSLinx Enterprise**

1. If necessary, close all open Windows programs, and then place the FactoryTalk View Site Edition DVD in the computer’s DVD drive.

   If the DVD does not start automatically, run D:\setup.exe, where D is the drive containing the DVD.

2. Click **Install FactoryTalk View Site Edition** (the second option).

3. Click step 6, **Install RSLinx Enterprise (optional)**.

4. In the RSLinx Enterprise Installation Wizard, follow the instructions in the Welcome, License Agreement, Customer Information, and Setup Type windows.

5. Click **Install**, to install RSLinx Enterprise.

   If you installed RSLinx Enterprise directly after installing FactoryTalk View SE, remember to restart the computer before running any FactoryTalk View SE software component.

**When to use RSLinx Classic**

RSLinx Classic provides some functionality that RSLinx Enterprise does not.

For example, install and use RSLinx Classic to serve data through DH+ (Data Highway +) networks, to support complex bridging and routing, and to support unsolicited messaging from a controller to RSLinx.

RSLinx Classic also allows you to create alias topic shortcuts, and to perform online tasks such as uploading and downloading RSLogix 5000 files.
To install RSLinx Classic

1. If necessary, close all open Windows programs, and then place the FactoryTalk View Site Edition DVD in the computer’s DVD drive.
   
   If the DVD does not start automatically, run D:\setup.exe, where D is the drive containing the DVD.

2. Click **Install FactoryTalk View Site Edition** (the second option).

3. Click step 7, **Install RSLinx Classic (optional)**.

4. To finish installing the software, follow the instructions in the setup program.

Recreate SQL Server 2008 Express instance

SQL Server 2008 Express instance ‘FTVIEWx64TagDB’ is created to store all the FactoryTalk View SE Tags and Alarms data, which HMI Server and View Studio will access. You need to recreate SQL Server 2008 Express instance ‘FTVIEWx64TagDB’ manually under the following cases:

- For some reason you need to uninstall SQL Server 2008 Express instance ‘FTVIEWx64TagDB’ and reinstall it.

- On a computer only have FactoryTalk View SE Client installed previously, and now you want to install FactoryTalk View Studio or SE Server by choosing **Modify** in the InstallShield Wizard.

A message shows up asking the user to recreate the SQL server instance if user has not done so.

To Recreate SQL Server 2008 Express instance

1. If necessary, close all open Windows programs, and then place the FactoryTalk View Site Edition DVD in the computer’s DVD drive.
   
   If the DVD does not start automatically, run D:\setup.exe, where D is the drive containing the DVD.

2. Click **Install FactoryTalk View Site Edition** (the second option).

3. Click step 8, **Recreate SQL Server 2008 Express instance (optional)**.

   If you have not installed Windows Installer 4.5 on your computer, go and install Windows Installer 4.5 first. See “To install the SQL Server Express Prerequisites” on page 43.

4. Input a password twice for the SA account in the SQLServerInstall window, and then click **OK**. Click **Guidelines** for quick reference of SQL SA User Strong Password Guidelines.
5. To finish installing the software, follow the instructions in the wizard.

**About installing product updates**

After installing FactoryTalk View SE, search for Answers in the Rockwell Automation Knowledgebase that contain information about Patch TOCs for software products on the FactoryTalk View Site Edition DVD.

A Patch TOC describes updates released for a particular product and version, and provides instructions for downloading and installing the updates on computers where the software is installed.

Each product you installed, including FactoryTalk View SE, FactoryTalk Services Platform, FactoryTalk Alarms and Events, RSLinx Enterprise, and RSLinx Classic, will have its own, version-specific Patch TOCs.

**To find Patch TOCs in the Rockwell Automation Knowledgebase**

1. In your Web browser’s Address bar, type www.rockwellautomation.com, and then press Enter.
2. On the right side of the Rockwell Automation home page, under Resources, click Knowledgebase.
3. Under Online Support tab, click Knowledgebase link.
4. In the Knowledgebase Home page, click Search Answers tab.
5. In the Search Answers page, from the list Refine by Product, select a product category. For example, to find Patch TOCs for FactoryTalk View, first select Software, then in the list All Subs, select Performance and Visualization (HMI).
6. From the list All Subs, select a product name. For example, select FactoryTalk View SE.
7. Click Advanced Search from the list Search type, select Phrases, if it is not the default.
8. In the text box above Refine by Product, type Patch TOC.
9. Click Search.

In the search results, look for Patch TOCs related to all the products you installed from the FactoryTalk View Site Edition DVD. If necessary, conduct a subsequent search for a specific product category and name.
Activating FactoryTalk View software

For continuous use of FactoryTalk® View Site Edition and other Rockwell Software products, computers running the software must have access to activation files.

To manage and provide activations for FactoryTalk View Site Edition software components, use the FactoryTalk Activation software installed with FactoryTalk View.

About FactoryTalk Activation

FactoryTalk Activation provides a secure, software-based system for activating Rockwell Software products and managing software activation files.

With FactoryTalk Activation, there is no need for a physical “master disk” or any physical media; instead, activation files are generated and distributed electronically.

FactoryTalk Activation types

FactoryTalk Activation provides these types of activations:

- **Local node-locked** activations are locked to a single computer.
- **Mobile node-locked** activations are locked to a hardware dongle.
- **Shared concurrent** activations are locked to an activation server computer and shared by client computers on the network.

There are two types of shared concurrent activation:

- **Floating** concurrent activations are checked out of an activation server located on the network, and require a continuous network connection.
- **Borrowed** concurrent activations are time-expiring activations checked out of an activation server on the network, and do not require a continuous network connection.

For standard installations of the product software, FactoryTalk View Site Edition (also called FactoryTalk View SE) supports only the use of both types of **shared concurrent** activations. Node-locked activations are not supported.

To learn about the types of activation other Rockwell Automation products can use, see the product documentation or contact your local Rockwell Automation Sales office.

How floating concurrent activations work

Concurrent activations are locked to a central activation server computer on the network. The activation server manages a pool of activation keys for connected clients to share.
Floating concurrent activations are assigned automatically to clients that need them, and returned automatically to the activation server pool when FactoryTalk View SE stops running on the client, or when the client computer shuts down.

Client computers must be set up to obtain floating activations from the activation server. For details, see “Set up client computers to obtain floating activations” on page 63.

A continuous network connection is also required for clients to use floating activations. After a client obtains a floating activation, if the activation server detects that the client has been disconnected, the activation is returned to the server pool.

As an alternative to centralizing activation, and to ensure that critical FactoryTalk View SE software components can obtain the necessary activations, you can set up the activation server on the same computer as the software. For details, see “Ensuring that network application components stay activated” on page 64.

**How borrowed concurrent activations work**

Like a floating activation, a borrowed activation is also retrieved from a pool of available activations managed by an activation server. A borrowed activation, however, expires after a specified amount of time.

While a floating activation requires a continuous network connection, once a borrowed activation is checked out to a particular computer, the computer can disconnect from the network.

When the time-limited activation expires, its associated software is no longer activated on the computer where the borrowed activation resides, and the activation automatically becomes available again from the server's activation pool. A borrowed activation can also be returned to the activation server manually, before the time limit expires. For details, see “Borrowing activations from a server” on page 67.

**Finding more information about FactoryTalk Activation**

If FactoryTalk Activation is installed, additional information about FactoryTalk Activation, including instructions for using the FactoryTalk Activation Tool, is available from FactoryTalk Activation Help, which can be opened by clicking on the Help link in the FactoryTalk Activation Manager.

If FactoryTalk Activation is not installed, you can install it from your FactoryTalk View SE DVD. For details, see “Install the activation software” on page 59.

**To open the FactoryTalk Activation Help**

- After installing the FactoryTalk Activation software, inside FactoryTalk Activation Manager, click Help or Learn More…to open FactoryTalk Activation Help
Activating software on Windows Vista

You can use Windows Vista only to run the FactoryTalk View SE Client, develop stand-alone or distributed applications on a single computer, or to run FactoryTalk View Studio and connect to remote HMI servers.

You cannot use Windows Vista to host HMI servers that other clients connect to. To host HMI servers, use Windows 7 Professional, Windows XP, Windows Server 2003, or Windows Server 2008 instead.

When choosing activation keys for Windows Vista, bear in mind that although you can install activation keys for Network applications, you cannot use them on Windows Vista. For details about specific activation keys, see “Activation keys for FactoryTalk View software components” on page 69.

What happens if FactoryTalk View SE is not activated

If the FactoryTalk View SE components you have installed cannot be activated, for example, because the activation server is unavailable or because borrowed activations have expired, then the software will continue to run for up to seven days.

The seven-day grace period allows time to correct the problem with acquiring activations, without disrupting critical applications. If activation is restored within seven days, normal operations will resume.

If activation is not restored, the grace period will expire. After the grace period expires, if you restart FactoryTalk View SE and activation remains unavailable, the software will run for two hours in demo mode.

With a FactoryTalk View SE network application running in demo mode, you can:

- create or load up to five HMI servers locally, in FactoryTalk View Studio.
- create or load up to five graphic displays per HMI server.
- run a local FactoryTalk View SE Client for up to two hours. In demo mode, remote SE Clients cannot connect to a FactoryTalk View SE application.
- import from Symbol Factory only the first graphic in each category.

Overview of tasks: activating the FactoryTalk View SE software

The checklist in this section summarizes the basic tasks involved in activating FactoryTalk View SE. Use the checklist to guide you through the tasks you need to perform. Each task is described in detail, in the rest of this chapter.

If appropriate, add or remove details to create a customized procedure that reflects the role the computer will play in your FactoryTalk View application.
Task checklist for activating FactoryTalk View SE

- Install the activation software.
- Get activation files to the activation server computer.
- Set up client computers to obtain floating activations.
  or
  Borrow activations for development computers

What you need to get started

To set up activation for your FactoryTalk View SE software, you need:

- a computer with an Internet connection (web browser or e-mail).

If you do not have an Internet connection, you can still get activation information by telephone or fax. For more information, see the FactoryTalk Activation Help.

- the FactoryTalk Activation Manager
  The FactoryTalk Activation Manager is the place for you to perform most of the activation related operations. For more information about FactoryTalk Activation Manager, see “Install the activation software” on page 59.

- the Host ID of the local computer, dongle, or activation server computer where the activation will be locked.
  You must specify a Host ID in the FactoryTalk Activation Manager The Host ID for a computer can be an ethernet address, a hard disk drive serial number.
If the computer has multiple network cards (or dongles), each card generates its own Host ID. In that case, you must select the Host ID you want activation files on the computer to be locked to. For more information, click Help.

- the Serial Number and Product Key for your FactoryTalk View SE software.

Your Serial Number and Product Key are printed on the Activation Certificate document enclosed with your FactoryTalk View Site Edition DVD.

**Install the activation software**

If for some reason you need to uninstall and then reinstall FactoryTalk Activation, you must install the software manually.

**To install FactoryTalk Activation manually**

1. Place the FactoryTalk View Site Edition DVD in the computer’s DVD drive. The DVD should start running automatically. If not, run D:\setup.exe, where D is the drive containing the DVD.

2. Click **Install FactoryTalk View Site Edition**.

3. Click Step 6, **Install FactoryTalk Activation**.

4. Follow the on-screen instructions to finish.

5. If Microsoft .NET Framework 3.5 SP1 is not installed on the computer, you are prompted to install it. This software is required by FactoryTalk Activation. Follow the on-screen instructions to install the Microsoft .NET Framework software.

6. When you are notified that the FactoryTalk Activation Manager setup completes successfully, click **OK**.

7. You will be notified that you need to restart the computer to make the installation take effect. Click Yes to restart now or No if you plan to restart later.

**Get activation files to the activation server computer**

To make concurrent floating activations available to activation clients, first you must download the activation files to the activation server computer through the Internet.

To get activation files

1. On the activation server computer, run the FactoryTalk Activation Manager.

   To do this, on the desktop click Start > All Programs > Rockwell Software > FactoryTalk Activation, and then click **FactoryTalk Activation Manager**.

2. In the **Manage Activations** tab, click **Get New Activations**, select **I have internet access from this computer**, then click **Enter Activation Information**.

   To provide the software’s Serial Number and Product Key, identify the activation server’s Host ID, and download activation files, follow the instructions in the manager.
3. Input the number of activations you want to download under # to Download. Click **Download Activations** to download the activation files.

The Activation files will be automatically downloaded to the following location:

- For Windows 7, Windows Vista and Windows Server 2008: . . .\Users\Public\Documents\Rockwell Automation\Activations
- For Windows XP and Windows Server 2003: . . .\Documents and Settings\All Users\Documents\Rockwell Automation\Activations

After getting activation files for the server computer, you must refresh the server to make the activations available to client computers.

**To refresh the server**

In the FactoryTalk Activation Manager, in **Advanced** tab, then **Manage This Server** tab, click **Refresh**.

**To get activation files through another computer's Internet**

1. On the activation server computer, run the FactoryTalk Activation Manager from the desktop. Click Start > All Programs > Rockwell Software > FactoryTalk Activation, and then click **FactoryTalk Activation Manager**.

2. In the Manage Activations tab, click **Get New Activations**, select **I have internet access from another computer from this site**, then click **Specify Data File**.

3. In the **Specify Data File** page, select the **File location** and type in the **File name**, then click **Get Host IDs**.

4. In **Get Host IDs** page, select a **Host ID**, then click **Create Data File**.

5. Find the created file in the specified location, and copy the file to the computer with Internet access.

6. Run the the FactoryTalk Activation Manager, In the **Manage Activations** tab, click **Get New Activations**, select **I have internet access from this computer**.

7. Click **Enter Activation Information**. Type in the software’s Serial Number and Product key,
8. Click **Browse** to identify the Host ID Information, click **Import Additional Host IDs...**, and import from the data file created at the server computer.

![Host ID Selection](image)

9. Input the number of activations you want to download under # to Download. Click **Download Activations** to download the activation files.

10. After downloading the activation files successfully, copy the files to the server computer, and put them in the activation files directory.

**Protecting activation files**

Activation files are simple text files that must have a .lic extension.

As long as the .lic extension is retained, you can copy or rename an activation file without harming it. However, tampering with text inside the activation file can disable your Rockwell Software products.

If an activation file is damaged or deleted, contact Rockwell Automation Technical Support.

For safekeeping, keep an original set of your activation files on backup media. Use descriptive names for the files, so that you can identify them later, and copy them back to the appropriate computers.

Activation files are locked to the Host IDs of the computers (or dongles) that need them. Activation will fail for Rockwell Software products on a computer where the specified Host ID is not recognized by the activation file.
Set up client computers to obtain floating activations

If you prefer to use borrowed activations for clients, skip to “Borrow activations for development computers” on page 65.

After you set up the activation server (or servers), you can specify which server each client computer will obtain activations from.

Once a client is connected to a server, all you have to do is to run the FactoryTalk View SE software (for example, the FactoryTalk View SE Client), and the server will issue available activations automatically.

A continuous network connection is required for an activation client to use floating activations. After a client obtains a floating activation, if the activation server detects that the client has been disconnected, the activation is returned to the server pool.

To ensure that critical software components (redundant HMI servers, for example) can always obtain the necessary activations, set up an activation server on the computer where the software is running. For more information, see page 64.

To specify the activation server on a client computer

1. On the client computer, on the desktop click Start > All Programs > Rockwell Software > FactoryTalk Activation, and then click FactoryTalk Activation Manager.

2. In the FactoryTalk Activation Manager, in Manage Activations tab, click Find Available Activations.

   The default location for activation files appears in the list.
3. Click the **Add Server** button. This inserts the text box shown in the following illustration.

4. Click the **Browse** button to find and select the activation server computer.

   The name of the computer is inserted automatically, using the syntax `@<host>`. If you use the name only, then the computer is using the default TCP/IP port.

   To specify a TCP/IP port, type `[port]@<host>`. For example, to specify a computer named RSL-server on port 27000, you would type:

   ```
   27000@RSL-server
   ```

   Use semi-colons (;) to separate multiple entries.

5. Click the check box in front of the location that will provide your activations, then click **Refresh Activations**.

**Ensuring that network application components stay activated**

To ensure that critical software components in a network application using floating activations can always obtain the necessary activations, even if the network is disrupted, set up a FactoryTalk Activation server on every computer where the FactoryTalk View SE software is running. This includes all clients and all servers, whether redundant or not.
For example, to ensure that a redundant FactoryTalk View SE Server remains activated, install the activation server on both computers hosting the redundant server pair, and then add the necessary activations to those computers.

**Borrow activations for development computers**

If it is not convenient for a development computer to remain connected to the network where the activation server resides, you can connect to the activation server temporarily, borrow a concurrent activation for a limited amount of time, and then disconnect. When the time-limited activation expires, its associated software is no longer activated, and the activation automatically becomes available again from the server's activation pool.

Only the FactoryTalk View Studio activation keys can be borrowed. While developing Network applications disconnected from the network, the FactoryTalk View Studio activation key is shared by any test clients and HMI servers in your application, allowing all necessary components to run for development purposes.

---

To use borrowed activations, you **must** upgrade to FactoryTalk Activation version 3.30 or later (included on any FactoryTalk CPR 9 SR 4 product's DVD) on all server and client computers where the borrowed activations will be used.

---

**Obtaining borrowable activations**

If you are upgrading from an earlier version of FactoryTalk View, the FactoryTalk View Studio activations you have already purchased cannot be borrowed. You can replace these older activations with newer ones free of charge.

If the computer where your FactoryTalk View Studio is located has no Internet connection, see “To get activation files through another computer's Internet” on page 61.

**To rehost FactoryTalk View Studio activations**

1. From the computer where the activation files reside, run the FactoryTalk Activation Tool from the Windows Start menu: **Start > All Programs > Rockwell Software > FactoryTalk Activation > FactoryTalk Activation Manager**.

   Because the rehosting process deletes activation files from the local computer, run this process on the physical computer where the activation files reside.

2. In the **Manage Activations** tab, click **Rehost Activations**.

3. In the Select Method page, click the check box in front of **Select I have internet access from this computer**, and then click **Select Activations**.
4. From the list of available activations, click the check box in front of the row containing the serial number associated with the activation you want to deactivate and reuse.

5. Click the **Complete Rehosting** button.

6. Ensure that the information presented in the Confirm Activation Removal dialog box is correct. If correct, click **Remove Activations**.

   The Confirm Activation Removal dialog box lists all of the activations associated with the selected serial number. If you click **Remove Activations**, all of the activations listed will be deleted from the local computer so that they can be reactivated on another computer or dongle.

7. If you are deactivating concurrent activations on a server computer, refresh the server. See “To refresh the server” on page 61.
8. In the computer you want to host the activation files, obtain the activation files, see “Get activation files to the activation server computer” on page 60.

If it is a different computer hosting the activation files, you need to go to the client computers, and update the server info, see “To specify the activation server on a client computer” on page 63.

**Borrowing activations from a server**

1. Connect your computer to the network where the activation server resides.

2. Run the FactoryTalk Activation Manager, click the **Manage Activations** tab, and then click **Borrow Activations** tab.

3. For a list of FactoryTalk View SE activations, see “Activation keys for FactoryTalk View software components” on page 69.

4. Do one of the following:
   - To borrow a single activation, click the check box that corresponds to the activation you want to borrow, and then click **Set Borrow Term**.
   - To borrow more than one activation at one time you can click the Check Boxes that correspond to the activations you want to borrow and then click **Borrow**. If you do not see the activations you want to borrow, click **I Don’t See My Activation Here**. The Activations in gray may not be selected as they are already borrowed by your computer.
5. In the **Set Borrow Term** window, set the time of the return by entering a calendar date, net number of days, or approximate hours (shift). The default Calendar date is the maximum borrow term for the activation or group of activations.

6. Click **Borrow Activations**. Then a list of successfully borrowed activations will be displayed.

7. The FactoryTalk Activation Manager can now be closed, the computer can be disconnected from the network.

**Tips:**

- When a borrowed activation expires, the software on your computer will no longer be activated. The software will continue to run for a grace period of 7 days, and then switch to demo mode for 2 hours before shutting down. For details, see “What happens if FactoryTalk View SE is not activated” on page 57. Once a borrowed activation has expired, it automatically becomes available again from the pool of activations held on the activation server.

- To return a borrowed activation before it expires, connect to the network and run the FactoryTalk Activation Manager. On the Manage Activations tab, click **Return Activations** and then click the **Return Activations** button.
Activation keys for FactoryTalk View software components

The activation files you download from the Rockwell Software Activation Website contain the activation keys you purchased, in encrypted form. The activation key is the software that activates FactoryTalk View SE components.

Different keys are required for different components. For example, FactoryTalk View SE Clients use SE Client activation keys. No matter how many keys you have purchased, do not exceed the limits described in Chapter 2, *Setting up the installation environment*.

Following is a list of activation keys used by the FactoryTalk View Site Edition and Machine Edition products. For information about how FactoryTalk View SE applications obtain activations, see “About FactoryTalk Activation” on page 55.

You can use Windows Vista only to run the FactoryTalk View SE Client, develop stand-alone or distributed applications on a single computer, or to run FactoryTalk View Studio and connect to remote HMI servers. You cannot use Windows Vista to host HMI servers that other clients connect to. To host HMI servers, use Windows 7 Professional, Windows XP, Windows Server 2003, or Windows Server 2008 instead.

When choosing activation keys for Windows Vista, bear these constraints in mind.

For information about the keys required to activate other Rockwell Automation products in your application, see the product documentation.

<table>
<thead>
<tr>
<th>To activate this software product or component</th>
<th>Use this key</th>
</tr>
</thead>
<tbody>
<tr>
<td>FactoryTalk View Studio*</td>
<td>RSV.STUDIO</td>
</tr>
<tr>
<td>*Includes software for developing and testing FactoryTalk View Site Edition and Machine Edition applications</td>
<td></td>
</tr>
<tr>
<td>FactoryTalk View SE Server (network applications), unlimited displays†</td>
<td>RSVSESRV.MAX†</td>
</tr>
<tr>
<td>FactoryTalk View SE Server (network applications), 250 displays†</td>
<td>RSVSESRV.250†</td>
</tr>
<tr>
<td>FactoryTalk View SE Server (network applications), 100 displays†</td>
<td>RSVSESRV.100†</td>
</tr>
<tr>
<td>FactoryTalk View SE Server (network applications), 25 displays†</td>
<td>RSVSESERV.25†</td>
</tr>
<tr>
<td>FactoryTalk View SE Client (network applications), read and write</td>
<td>RSVSECLI.RW</td>
</tr>
<tr>
<td>FactoryTalk View SE Client (network applications), view only</td>
<td>RSVSECLI.RO</td>
</tr>
<tr>
<td>FactoryTalk View SE Station (local applications), unlimited displays</td>
<td>RSVSE.MAX</td>
</tr>
<tr>
<td>FactoryTalk View SE Station (local applications), 250 displays</td>
<td>RSVSE.250</td>
</tr>
</tbody>
</table>

† Do not use to host HMI servers on Windows Vista that other clients connect to.
Sharing keys among multiple software components

Multiple FactoryTalk View SE software components can function using one activation key in the following cases:

- Multiple instances of FactoryTalk View Studio or the FactoryTalk View SE Client running on the same computer can use a single key ((RSV.STUDIO or RSVSECLI), as long as the components are not running in a Terminal Services session.

- In a network application, for development and testing purposes, one FactoryTalk View Studio key activates a FactoryTalk View SE Client and SE Server on the same computer. Remote clients and servers require component-specific activations.

- Local applications use a single key (RSVSE.*) to activate both the FactoryTalk View SE Client and the FactoryTalk View SE Server at run time. These components running together are also known as FactoryTalk View SE Station.

FactoryTalk View SE Server activations—known as “capacity” activations because they are based on the number of displays in an application—cannot be shared.

How FactoryTalk View SE Clients use floating activations

In a network application, FactoryTalk View SE Clients can use two types of activation:

- **Read-write** keys (RSVSECLI.RW) allow full read-write privileges.

- **View-only** keys (RSVSECLI.RO) allow view-only privileges.
Whether a FactoryTalk View SE Client runs in read-write or in view-only mode depends on the type of activation key available for the client to use, and whether the client itself is set up as read-write or view-only:

- If the activation server can only provide view-only licenses, and a read-write client obtains one of these licenses, then the activation overrides the client’s configuration, and the client runs in view-only mode.

- If the activation server can only provide read-write licenses, and a view-only client obtains one of these licenses, then the client’s configuration overrides the activation, and the client runs in view-only mode.

- Do not rely on available activation keys to determine whether the FactoryTalk View SE Client runs in read-write or view-only mode. Instead, to ensure that a client always runs in view-only mode, choose the view-only option when setting up the client’s configuration file. For details, click Help in the FactoryTalk View SE Client wizard.
Deploying network applications

After developing and testing a FactoryTalk® View Site Edition network application, you can deploy it to run in a live setting, such as the plant floor. Deploying a network application often involves installing FactoryTalk View SE software components on multiple client and server computers.

For details about installing the software, see Chapter 3, *Installing FactoryTalk View Site Edition*. For information about upgrading a network application that is already deployed, see Chapter 7, *Upgrading FactoryTalk View Site Edition*.

For details about the structure and content of network applications, see Chapter 6, “Working with network applications” in the *FactoryTalk View Site Edition User’s Guide*.

Overview of tasks: deploying network applications

The checklist in this section summarizes the basic tasks involved in deploying a FactoryTalk View SE network application. Each task is described in detail in the rest of this chapter. Add or remove steps as necessary to create a customized procedure that reflects the design and content of your FactoryTalk View application. For example, your application might include additional communications or database servers.

For details about deploying FactoryTalk Alarms and Events servers, see the *FactoryTalk Security System Configuration Guide*. On the Windows Start menu, click **Start > All Programs > Rockwell Software > FactoryTalk Tools > FactoryTalk Security System Configuration Guide**.

Task checklist for deploying a network application

- Back up the network application
- Ensure that the FactoryTalk Network Directory is set up
- Move the application’s HMI project files
- Restore the network application
- Specify the Network Directory location on application computers
- Move the application’s data server files
- Specify data server host computer names
- Renew data server shortcuts, topics, and device paths
- Specify HMI server host computer names
- Set up additional HMI server properties
- Set up the FactoryTalk View SE Clients
- Run the FactoryTalk View SE Clients to test the application

**Back up the network application**

Use the FactoryTalk Administration Console to back up a FactoryTalk View SE network application. The back-up operation creates an application archive that includes area names, server names, server properties, and application languages.

If you include System information in the back-up operation, user and computer accounts are also archived, along with other FactoryTalk system-level settings. For more information, see “About backing up System information with an application,” next.

Application files such as HMI project files, product activation, and logged historical data (trends, alarms, and diagnostic messages) must be backed up and restored separately.

For information about backing up and restoring files that belong to FactoryTalk Tag Alarm and Event Servers, see the FactoryTalk Alarms and Events Help.

**About backing up System information with an application**

The following illustration shows what a FactoryTalk View SE network application open in FactoryTalk View Studio.
The FactoryTalk Network Directory (also called the Network Directory) is represented at the top of application hierarchy. One level down, the System folder stores settings that are used by all the applications that belong to the same Network Directory.

For example, FactoryTalk user and computer accounts set up for each application are stored in the System folder.

When you back up a network application, System information for the application is not archived automatically. To save the System information, for example, in order to preserve user and computer accounts, you must select the check box, Backup System in archive.

If you back up System information with a network application, when you restore the application, you can also choose whether to restore the archived System information.

If you do, keep in mind that restored System information does not merge with existing FactoryTalk System settings held at the current FactoryTalk Network Directory.

For example, if you restore System information, and if the Network Directory on the local computer is active, you will replace user and computer accounts set up for any other application using the active directory.

RSLinx Enterprise device paths are also saved with System information, and might not be correct for the computer where the application will be restored. For information about checking device paths after restoring an application, see “Verify RSLinx Enterprise shortcuts”.

To back up a network application

Before backing up an application, record the user names and passwords of administrative users set up for the application, in case you need this information after restoring the application.

1. Click Start > All Programs > Rockwell Software, and then click **FactoryTalk Administration Console**.

2. In the Select FactoryTalk Directory dialog box, select **Network**, and then click **OK**.

To back up a network application, the logged on user must have FactoryTalk administrative rights. If you receive a prompt to log on, check with your System Administrator.

3. In the Explorer window, right-click the application you want to back up, and then click **Backup**.

4. Specify an archive name and location.

   To specify a location other than the default, type the path or click the Browse button to find and select a location.
5. Select or clear the check box, **Backup System in archive**, and then click **OK**.

The back-up operation saves an application archive file with a .bak extension to the specified location. The default locations are:

- For Windows XP, and Windows Server 2003, C:\Documents and Settings\All Users\Documents
- For Windows 7 Professional, Windows Vista and Windows Server 2008, C:\Users\Public\Documents

---

**Ensure that the FactoryTalk Network Directory is set up**

On the computer that will host the FactoryTalk Network Directory, ensure that the FactoryTalk Services Platform is installed, and that *localhost* is specified as the Network Directory location.

**To specify localhost as the Network Directory location**

1. On the Network Directory computer, click Start > All Programs > Rockwell Software > FactoryTalk Tools, and then click **Specify FactoryTalk Directory Location**.

   To use the utility, you have to log on as a local administrator.

2. If *localhost* is displayed in the field, Computer hosting directory server, the computer is already specified as the Network Directory host. You can close the utility.

   If localhost is not displayed, click the Browse button.

3. In the FactoryTalk Directory Server Configuration dialog box, click **This computer**, and then click **OK**.

4. Click **OK** again, to close the FactoryTalk Directory Server Location Utility.

**Move the application’s HMI project files**

Use the HMI Server Backup and Restore utility to back up HMI project files that belong to HMI servers in the application you are deploying.
To run the HMI Server Backup and Restore utility, click Start > All Programs > Rockwell Software > FactoryTalk View > Tools > HMI Backup and Restore. For details about using the utility, click the Help button.

After backing up the HMI project files, use Windows Explorer to move the backed-up files manually, if necessary, from the development computer (or computers) to the production computers that will run the HMI servers.

Then, use the HMI Server Backup and Restore utility again, to restore the HMI project files in their new location.

If you are deploying an application that includes redundant HMI servers, for each redundant pair, you must copy the HMI project files to both the primary and the secondary production computer.

Where HMI project files are stored

HMI project files are stored in the following location, on computers hosting HMI servers in a network application:

- For Windows 7 Professional, Windows Vista and Windows Server 2008:
  . . \Users\Public\Documents\RSView Enterprise\SE\HMI Projects

- For Windows XP and Windows Server 2003:
  . . \Documents and Settings\All Users\Shared Documents\RSView Enterprise\SE\HMI Projects

HMI project files are stored in folders that have the same names as their HMI servers. For example, the files belonging to an HMI server named Water would be stored in:

..\RSView Enterprise\SE\HMI Projects\Water

Restore the network application

After moving the application’s HMI project files to production computers on the Network Directory server computer, use the FactoryTalk Administration Console to restore the backed-up FactoryTalk View SE network application.
To restore a network application

1. On the Network Directory server computer, click Start > All Programs > Rockwell Software, and then click FactoryTalk Administration Console.

2. Select Network Directory, and then click OK.

   To restore a network application, the logged on user must have FactoryTalk administrative rights. If you receive a prompt to log on, check with your System Administrator.

3. In the Explorer window, right-click the Network icon at the top of the tree, and then click Restore.

4. Type the path to the application archive’s location, or click the Browse button to find and select the archive, and then click Next.

   Application archive files have a .bak extension.
   
   For Windows XP, and Windows Server 2003, the default location for application files is C:\Documents and Settings\All Users\Documents.
   
   For Windows 7 Professional, Windows Vista and Windows Server 2008, the default location is C:\Users\Public\Documents.

5. In the Restore dialog box, if the Archive Type is:
   
   - Application, then the archive contains application information only.
   
   - Application and System, then the archive contains application and FactoryTalk System information.

   To restore the application without archived System information, clear the Restore System check box. The restore operation will add the application to the FactoryTalk Network Directory on the computer.

   Restoring archived System information replaces existing FactoryTalk System settings on the computer. When deploying a FactoryTalk View SE network application, it is recommended that you do not restore System information with the application, as this will remove existing computer accounts and prevent users from logging on to the Network Directory.

6. To restore the application with its original name, clear the check box, Restore into a new application name, and then click Finish.

   To restore the application under a new name, for example, to create a copy of the original application that can be modified, select the check box, type the new name, and then click Finish.
Specify the Network Directory location on application computers

After restoring the network application, use the FactoryTalk Directory Server Location Utility to specify the location of the FactoryTalk Network Directory server, on all application client and server computers.

Performing this task might require more than one set of FactoryTalk security credentials:

- To use the FactoryTalk Directory Server Location Utility, you must have administrative rights on the local computer.
- To specify a remote location for the Network Directory, you must have administrative rights on the remote computer.

To specify the Network Directory on client and server computers

1. On the client or server computer, click Start > All Programs > Rockwell Software > FactoryTalk Tools, and then click *Specify FactoryTalk Directory Location*.

2. Click the Browse button beside the field, Computer hosting directory server.

3. In the FactoryTalk Directory Server Configuration dialog box, click *Remote computer*.

4. Type the name of the Network Directory server computer, or click the Browse button to find and select the computer, and then click *OK*.

5. Click *OK* again, to close the FactoryTalk Directory Server Location Utility.

Repeat steps 1 to 5 on all client and server computers that will participate in the deployed network application.

Move the application’s data server files

After specifying the FactoryTalk Network Directory location on application clients and servers, ensure that the required communications software (RSLinx® Enterprise, RSLinx Classic, or other OPC software) is installed on computers that will run data servers.

Then, if necessary for the data servers you are deploying, move configuration files to the production computers, and then specify the new host computer names.

For information about moving setup files for OPC data servers other than RSLinx Classic, see the product documentation for the OPC server.

Restoring RSLinx Enterprise configurations

When you back up a FactoryTalk View SE network application, the archive includes RSLinx Enterprise shortcut names, but does not include device path information.
After restoring the application, you must open the Communications Setup editor in FactoryTalk View Studio, and re-apply the device path for each configured shortcut. For details, see “Renew data server shortcuts, topics, and device paths”.

**Backing up and restoring RSLinx Classic configurations**

RSLinx Classic configuration files are not included when you back up a network application. You have to back up, move, and restore the files manually.

If RSLinx Classic is installed on the development and production computers, you can use the RSLinx Classic Backup/Restore tool to back up and restore configuration files.

You can also restore RSLinx Classic configuration files from the Wizard Completed window of the RSLinx Classic software setup program.

**To move RSLinx Classic configuration files**

1. On the development computer, click Start > All Programs > Rockwell Software > RSLinx, and then click **RSLinx Classic Backup Restore Utility**.

2. In the RSLinx Classic Backup/Restore tool, click **Backup**.

3. Select a folder for the backup file, type a file name, and then click **Save**.

4. In Windows Explorer, copy the backup file, and then paste it into a location on the data server production computer.

5. On the production computer, click Start > All Programs > Rockwell Software > RSLinx, and then click **RSLinx Classic Backup Restore Utility**.

6. In the RSLinx Backup/Restore tool, click **Restore**.

7. Find and select the backup file you just moved, and then click **Open**.
Specify data server host computer names

After moving data server configuration files to production computers, open the restored network application, and in the Properties dialog box for each data server, specify the name of the server’s host computer.

Then, renew RSLinx shortcuts, topics, and device paths, as needed. For details, see “Renew data server shortcuts, topics, and device paths”.

For information about setting up other data server properties, click Help in the server’s Properties dialog box, or see the product documentation.

The first time you open an application after relocating a data server, if the server does not load, you should still be able to open the Properties dialog box and change the host computer name. After the computer name is updated, the server should load as expected.

To change the RSLinx Enterprise server computer name

1. Click Start > All Programs > Rockwell Software, and then click **FactoryTalk Administration Console**.

2. In the Select FactoryTalk Directory dialog box, select **Network**, and then click **OK**.

3. In the Explorer window, expand the name of the restored application, right-click the RSLinx Enterprise server’s name, and then click **Properties**.

4. In the General tab, in the field, Computer hosting the RSLinx Enterprise server, type the name of the production computer, or click Browse to find and select the computer, and then click **OK**.

To change the RSLinx Classic server computer name

1. Open the restored application in the FactoryTalk Administration Console. To learn how to do this, see the previous task.

2. In the Explorer window, expand the name of the restored application, right-click the RSLinx Classic server’s name, and then click **Properties**.

3. In the General tab, in the field, Computer that will run the OPC server, type the name of the production computer, or click Browse to find and select the computer, and then click **OK**.

Renew data server shortcuts, topics, and device paths

After restoring RSLinx data servers in the application, and specifying the names of their new host computers, renew or verify the topics, shortcuts, and device paths associated with each data server, as needed.
If you are restoring redundant data servers, then the device paths must be confirmed and reapplied for both the primary and the secondary server.

To renew RSLinx Enterprise device paths

1. Open the restored application in the FactoryTalk Administration Console. To learn how to do this, see “To change the RSLinx Enterprise server computer name,” on the previous page.

2. In the Explorer window, expand the data server (RSLinx Enterprise), and then double-click Communications Setup.

3. In the Communications Setup editor, select each configured RSLinx Enterprise shortcut, point the shortcut at the correct device, and then click Apply.

4. Save the configuration, and then close the Communications Setup editor.

To verify RSLinx Classic topics

1. On the data server computer, click Start > All Programs > Rockwell Software > RSLinx, and then click RSLinx Classic.

2. On the DDE/OPC menu, click Topic Configuration.

3. In the Topic List, select each configured topic and confirm that the corresponding data source updates correctly.

4. Click the Advanced Communication tab, confirm that there is a device path specified for Remote Addressing, and then click Done.

Specify HMI server host computer names

After updating data server computer names, in the Properties dialog box for each HMI server, specify the name of the HMI server’s host computer.

To specify the server computer name, and to set up other HMI server properties, you can open the Properties dialog box from the SE Administration Console or from FactoryTalk View Studio. Use the tool that is available on the computer.

The first time you open an application after relocating an HMI server, if the server does not load, you should still be able to open the Properties dialog box and change the host computer name. After the computer name is updated, the server should load as expected.
To change the HMI server computer name

1. Open the restored application in the SE Administration Console.
   To learn how to do this, see “To open a network application in the SE Administration Console”.

2. In the Explorer window, right-click the HMI server’s name, and then click Properties.

3. In the General tab, in the field, Computer hosting the server, type the name of the production computer, and then click OK.
   You can also click Browse to find and select the production computer.

Set up additional HMI server properties

With the restored application open in the SE Administration Console or in FactoryTalk View Studio, in addition to specifying the names of the production computers that will host the HMI servers, you can set up the following HMI server properties:

- In the General tab, to determine when the HMI server will load, select a Startup Type.
  You can specify that the HMI server will load when the first client attempts to connect to it (On demand) or when the host computer starts up (Load and run startup components when operating system initializes). The second option is recommended for production HMI servers.

- In the Redundancy tab, to set up redundancy for the HMI server, first select the check box, Provide redundancy using a secondary server; then, specify the name the computer that will host the secondary server, and select a switchover option.

   Before you can specify the secondary server in a redundant pair, you must manually copy the HMI project files to the secondary server computer. To do this, follow the instructions for moving HMI project files to production HMI server computers, on page 76.

- In the Components tab, select the application components that will start automatically when the HMI server starts, and select the macro that will run when the server shuts down. You can also start or stop components manually.
   If the HMI server is redundant, you can also start and stop components for the primary and the secondary server, and select On active and On standby macros.

You must set up the HMI server properties separately, for each server in the FactoryTalk View SE network application you are deploying. You can do this on the computer running the HMI server, or from a remote computer.

For details about setting up HMI server properties, see Chapter 6, “Working with network applications” in the FactoryTalk View Site Edition User’s Guide. For details
about setting up redundant HMI servers, see Chapter 13, “Setting up FactoryTalk system availability”.

**Synchronizing redundant HMI servers and projects**

After setting up redundancy for an HMI server, to ensure that identical copies of the HMI server and project files are running on the primary and the secondary computers, replicate changes from the primary to the secondary server.

The replicate operation copies the primary server’s configuration files, including settings in the Components tab, to the secondary server.

For example, if an On Active and a Shutdown macro are selected for the primary server, the settings will be replicated to the secondary. This means that the same macros specified for the primary server will run when the secondary server becomes active or shuts down.

Information that is not included in the replicate operation includes datalog files generated at run time, the current value of HMI memory tags, retentive tags, and the HMI tag alarm suppressed list.

---

For the replicate operation to succeed, a copy of the HMI project files must already exist on the secondary server computer. In addition, the state of the primary server must be Active, and the state of the secondary server must be Standby, for the duration of the operation. If you need to copy the HMI project files, see “Move the application’s HMI project files”.

---

**To replicate changes from the primary to the secondary server**

1. Open the restored application in the SE Administration Console.
   
   To learn how to do this, see “To open a network application in the SE Administration Console”.

2. In the Explorer window, right-click the HMI server’s name, and then click **Properties**.

3. Click the Redundancy tab, and then click **Replicate Primary to Secondary**.
   
   If a secondary server is not specified, the Replicate Primary to Secondary button will not be available in the Redundancy tab.

   To finish replicating, follow the on-screen instructions. After the replicate operation is complete, the secondary server is restarted.
Set up the FactoryTalk View SE Clients

The FactoryTalk View SE Client provides a complete and secure run-time environment for a local application. For example, operators can use the client to:

- load, view, and interact with graphic displays from any HMI server in the application.
- monitor and control alarms (HMI tag alarms and FactoryTalk Alarms and Events).
- view and interact with trends
- adjust set points.
- start and stop server components.

In a network application, FactoryTalk View SE Clients, HMI servers, and data servers can run on multiple computers, connected over a network.

If you have already set up FactoryTalk View SE Client files for a network application, you can copy the files to the production computers. Otherwise, you can create new client files.

Creating a new FactoryTalk View SE Client file

FactoryTalk View SE Client configuration files specify the name of the application the client will connect to, the components that start when the connection is made, and how the client will behave at run time.

To create a new client file, use the FactoryTalk View SE Client Wizard. You can also use the wizard to modify or run an existing client file, or to remove a client from the list of available files.

You do not have to start the HMI server (or servers) the client will connect to, in order to use the FactoryTalk View SE Client Wizard.

To create a new FactoryTalk View SE Client file

1. On the desktop, click Start > All Programs > Rockwell Software > FactoryTalk View, and then click FactoryTalk View Site Edition Client.

2. In the FactoryTalk View SE Client Wizard, click New, and then follow the on-screen instructions. For details about options in the wizard, click Help.

The client file is created with a .cli extension, in the location you specified.

Copying existing FactoryTalk View SE Client files

When setting up the FactoryTalk View SE Clients for a network application, you can copy existing client files from the development computer to the client production computers.
**To copy a FactoryTalk View SE Client file**

Copy the .cli file from the development computer to the production run-time client computer.

You can run the client configuration from the desktop, or from any other location on the client computer.

By default, client configuration files are saved to these locations:

- For Windows 7 Professional, Windows Vista and Windows Server 2008:
  
  ```
  ...\Users\Public\Documents\RSView Enterprise\SE\Client
  ```

- For Windows XP and Windows Server 2003:
  
  ```
  ...\Documents and Settings\All Users\Shared Documents\RSView Enterprise\SE\Client
  ```

**Locking operators into the run-time environment**

To lock operators into the FactoryTalk View SE Client at run time, for example, to prevent access to other programs on the computer, try one or more of the following methods:

- **Limit the ability to manipulate graphic displays**, by removing the title bar or minimize and maximize buttons from selected displays.

  To do this, in the Display Settings dialog box, clear the check boxes Title Bar, Minimize Button, and Maximize Button. For details, see Chapter 15, “Creating graphic displays” in the *FactoryTalk View Site Edition User’s Guide*.

- **Limit the ability to manipulate the client window**, by removing the title bar or minimize and maximize buttons from the client.

  To do this, in the FactoryTalk View SE Client wizard, clear the check boxes, Show title bar, and Show system menu and close button. For details, click Help in the FactoryTalk View SE Client wizard.

- **Prevent switching to other applications**. To do this, in the FactoryTalk View SE Client wizard, select the check box, Disable switch to other applications.

  For details, click Help in the FactoryTalk View SE Client wizard.

- **Restrict access to the desktop**, using the DeskLock tool.

  To open Desklock, on the desktop click Start > All Programs > Rockwell Software > FactoryTalk View > Tools, and then click **DeskLock**.

  For details about using DeskLock, click Help within the tool.
Run the FactoryTalk View SE Clients

Once the network application is fully deployed, test it by running the FactoryTalk View SE Clients.

To connect a FactoryTalk View SE Client to a network application, all client and server computers in the application must point at the same FactoryTalk Network Directory server. For details, see “Specify the Network Directory location on application computers”.

For tips to help you get communications working between clients and servers, see the FactoryTalk View Site Edition Help.

To run an SE Client using the .cli file

Double-click the client setup file (.cli), in the following default folder:

- For Windows 7 Professional, Windows Vista and Windows Server 2008:
  . . \Users\Public\Documents\RSView Enterprise\SE\Client

- For Windows XP and Windows Server 2003:
  . . \Documents and Settings\All Users\Shared Documents\RSView Enterprise\SE\Client

To run an SE Client from FactoryTalk View Studio

1. In FactoryTalk View Studio, on the Tools menu, click Launch SE Client.

2. In the Launch FactoryTalk View SE Client dialog box, type the name of the .cli file, and then click OK. To find and select a file, click the Browse button.

To run an SE Client when Windows starts

1. Create a shortcut to the .cli file (on the desktop, for example).

2. Move the shortcut to the Windows Startup folder.

   For information about adding shortcuts to the Startup folder, see the Windows Help.
About logging on to the FactoryTalk View SE Client

To start the FactoryTalk View SE Client, or to change users while the client is running, the user logging on must have the necessary security permissions.

If not, the FactoryTalk View SE Client Login dialog box opens, to let another user log on.

To open a network application in the SE Administration Console

1. Click Start > All Programs > Rockwell Software > FactoryTalk View > Tools, and then click SE Administration Console.
2. Select Site Edition (Network), and then click Continue.
3. In the Existing tab, select the restored application’s name, and then click Open.

Administering deployed network applications

To make changes to an application after it is deployed, use either FactoryTalk View Studio or the FactoryTalk View SE Administration Console. The SE Administration Console contains the following subset of editors.

<table>
<thead>
<tr>
<th>To do this in the SE Administration Console</th>
<th>Use this editor</th>
</tr>
</thead>
<tbody>
<tr>
<td>Change the properties of an HMI server.</td>
<td>HMI Server Properties</td>
</tr>
<tr>
<td>Change the properties of a data server.</td>
<td>Data Server Properties</td>
</tr>
<tr>
<td>Add FactoryTalk users to an application.</td>
<td>Runtime Security</td>
</tr>
<tr>
<td>Set up security for commands and macros.</td>
<td>Secured Commands</td>
</tr>
<tr>
<td>Run FactoryTalk View commands.</td>
<td>Command Line</td>
</tr>
<tr>
<td>Change how HMI tag alarms are logged.</td>
<td>Alarm Setup</td>
</tr>
<tr>
<td>Change the paths of data log models.</td>
<td>Data Log Paths</td>
</tr>
<tr>
<td>Manage HMI tag alarm log files.</td>
<td>Alarm Log Setup</td>
</tr>
<tr>
<td>Import and export HMI tags.</td>
<td>Tag Import and Export Wizard</td>
</tr>
</tbody>
</table>

For details about options in these editors, click Help.
6 Deploying local applications

After you finish developing and testing a FactoryTalk® View Site Edition local application, you can deploy it to run in a live setting, such as the plant floor. Deploying a local application involves installing all FactoryTalk View SE software components on the application’s host computer.

For details about installing the software, see Chapter 3, *Installing FactoryTalk View Site Edition*.

For details about the structure and content of local applications, see Chapter 7, “Working with local applications” in the *FactoryTalk View Site Edition User’s Guide*.

**Overview of tasks: deploying local applications**

The checklist in this section summarizes the basic tasks involved in deploying a FactoryTalk View SE local application. Use the checklist to guide you through the tasks you need to perform. Each task is described in detail, in the rest of this chapter.

If appropriate, add or remove details to create a customized procedure that reflects the design and content of your FactoryTalk View application. For example, your application might include additional communications or database servers.

If your application includes Tag Alarm and Event Servers, for information about deploying these servers, see the FactoryTalk Alarms and Events Help.

**Task checklist for deploying a local application**

- Move the local application
- Move data servers and change their properties
- Specify OPC data server host computer names
- Specify when HMI server components start or stop
- Set up the FactoryTalk View SE Client
- Run the FactoryTalk View SE Client to test the application
Move the local application

There are two steps involved in moving a local application: on the development computer, back up the application; then, on the production computer, restore the application archive.

You can perform both of these steps in the Application Manager tool. For details about options in the Application Manager, click Help in the tool.

Before backing up an application, record the user names and passwords of administrative users set up for the application, in case you need this information after restoring the application.

To back up a local application

1. Restart the development computer.
   
   You cannot back up a local application while it is in use

2. On the desktop, click Start > All Programs > Rockwell Software > FactoryTalk View > Tools, and then click Application Manager.

3. In the Application Manager, select Site Edition (Local), and then click Next.

   To back up a local application, the logged on user must have FactoryTalk administrative rights. If you receive a prompt to log on, check with your System Administrator.

4. Select the back up operation, and then follow the instructions in the Application Manager to complete the operation.

To restore a local application

If you are restoring a local application on a computer that contains a copy of the original application, restart the computer, and then delete (or rename) the original application, before you begin the restore operation.

1. On the production computer, on the desktop, click Start > All Programs > Rockwell Software > FactoryTalk View > Tools, and then click Application Manager.

2. Select Site Edition (Local), and then click Next.

   To restore a local application, the logged on user must have FactoryTalk administrative rights. If you receive a prompt to log on, check with your System Administrator.

3. Select the restore operation, and then follow the instructions in the Application Manager to complete the operation.
About restoring System information with the application

In FactoryTalk View Studio, in a local application, the top-level System folder contains FactoryTalk Security information, including user accounts set up for all applications using the same FactoryTalk Local Directory (also called the Local Directory).

When you back up a local application, this FactoryTalk system information is saved to the archive automatically. When you restore a local application, you can choose whether to restore the system information with the application.

To restore FactoryTalk system information with a local application

In the Application Manager tool, after specifying the archive to restore, select the option, Restore the FactoryTalk View SE (local) application and FactoryTalk Local Directory.

To complete the operation, the user logged on to the Application Manager must have FactoryTalk administrative rights at the Local Directory being restored.

Move data servers and change their properties

A FactoryTalk View SE local application can contain one RSLinx® Enterprise data server, which must be located on the same computer as the application.

In addition, the local application can contain one or more OPC data servers (RSLinx Classic, or some other OPC server), which can be located on remote computers.

After ensuring that the required communications software is installed on production computers, for each remote OPC data server you are deploying, move the configuration files to the production computer and specify the new host computer name.

For information about moving setup files for OPC data servers other than RSLinx Classic, see the product documentation for the OPC server.

After installing RSLinx® Enterprise, RSLinx Classic, or some other OPC server software on the production computer, if necessary, you can move the data server’s setup files to the computer.

For information about moving setup files for OPC data servers other than RSLinx Classic, see the documentation provided with the OPC server.

Backing up and restoring RSLinx Enterprise files

When you back up a FactoryTalk View SE local application, the archive includes RSLinx Enterprise shortcut names, but does not include device path information.
After restoring the application, you must open the Communications Setup editor in FactoryTalk View Studio, and re-apply the device path for each configured shortcut. For details, see “To renew RSLinx Enterprise device paths”.

**Moving RSLinx Classic files**

RSLinx Classic configuration files are not included when you back up a local application. You have to back up, move, and restore the files manually.

If RSLinx Classic is installed on the development and production computers, you can use the RSLinx Classic Backup/Restore tool to back up and restore configuration files.

You can also restore RSLinx Classic configuration files from the Wizard Completed window of the RSLinx Classic software setup program.

**To move RSLinx Classic configuration files**

1. On the development computer, click Start > All Programs > Rockwell Software > RSLinx, and then click **RSLinx Classic Backup Restore Utility**.

2. In the RSLinx Classic Backup/Restore tool, click **Backup**.

3. Select a folder for the backup file, type a file name, and then click **Save**.

4. In Windows Explorer, copy the backup file, and then paste it into a location on the data server production computer.

5. On the production computer, click Start > All Programs > Rockwell Software > RSLinx, and then click **RSLinx Classic Backup Restore Utility**.

6. In the RSLinx Classic Backup/Restore tool, click **Restore**.

7. Find and select the backup file you just moved, and then click **Open**.
Specify OPC data server host computer names

After moving RSLinx Classic configuration files to production computers, open the restored local application, and in the Properties dialog box for each data server, specify the name of the server’s host computer.

For information about setting up other data server properties, click Help in the server’s Properties dialog box, or see the product documentation.

Unlike RSLinx Classic data servers, you do not have to change the computer names of RSLinx Enterprise data servers. The RSLinx Enterprise data server in a local application must be located on the same computer as the application, and is always named localhost.

The first time you open an application after relocating a data server, if the server does not load, you should still be able to open the Properties dialog box and change the host computer name. After the computer name is updated, the server should load as expected.

To change the RSLinx Classic server computer name

1. Click Start > All Programs > Rockwell Software, and then click FactoryTalk View Studio.

2. Select Site Edition (Local), and then click Continue.

3. Click the Existing tab, select the local application’s name, and then click Open.

4. In the Explorer window, right-click the RSLinx Classic server’s name, and then click Properties.

5. In the General tab, in the field, Computer that will run the OPC server, type the name of the production computer, or click Browse to find and select the computer, and then click OK.

Specify when HMI server components start or stop

In FactoryTalk View Studio, open the Properties dialog box for the HMI server in the application, to view the location of the HMI project files, the current number of displays in the application, and the maximum number of displays allowed.

You can add a description for the HMI server and, in the Components tab, select components that will start when the HMI server starts running.

In a local application, the HMI server and the application have the same name. The name cannot be modified in the HMI server’s Properties dialog box.
To open the HMI Server Properties dialog box

1. Click Start > All Programs > Rockwell Software, and then click FactoryTalk View Studio.
2. Select Site Edition (Local), and then click Continue.
3. Click the Existing tab, select the local application’s name, and then click Open.
4. In the Explorer window, right-click the HMI server’s name, and then click Properties.

How HMI server components start and stop

Use the HMI Server Properties dialog box to specify which components in a local application will start automatically, when the HMI server starts running.

In a local application, the HMI server loads and the specified components start running when the FactoryTalk View SE Client connects to the application. When the client stops running, the HMI server is unloaded, and the specified shutdown macro is run.

You can also start or stop the HMI server components manually. To do this, in the Components tab, click Run Startup Components and Stop All Running Components, respectively.

To select HMI server startup and shutdown components

1. In the HMI Server Properties dialog box, click the Components tab.
2. To specify startup components, select the component check boxes, and then select the components you want to start automatically, when the HMI server starts running.
3. To specify a shutdown macro, select the check box On shutdown macro, and then select the macro you want to run when the HMI server stops running.

Set up the FactoryTalk View SE Client

The FactoryTalk View SE Client provides a complete and secure run-time environment for a local application. For example, operators can use the client to:

- load, view, and interact with multiple graphic displays from the HMI server.
- manage alarm information.
- view trends.
- adjust set points.
- start and stop server components.
To run a local application, the FactoryTalk View SE Client must run on the same computer as the HMI server.

If you have already set up a FactoryTalk View SE Client file for the application, you can copy the file to the production computer. Otherwise, you can create a new client file.

Creating a new FactoryTalk View SE Client file

FactoryTalk View SE Client configuration files specify the name of the application the client will connect to, the components that start when the connection is made, and how the client will behave at run time.

To create a new client file, use the FactoryTalk View SE Client Wizard. You can also use the wizard to modify or run an existing client file, or to remove a client from the list of available files.

You do not have to start the HMI server the client will connect to, in order to use the FactoryTalk View SE Client Wizard.

To create a new FactoryTalk View SE Client file

1. On the desktop click Start > All Programs > Rockwell Software > FactoryTalk View, and then click FactoryTalk View Site Edition Client.

2. In the FactoryTalk View SE Client Wizard, click New, and then follow the on-screen instructions. For details about options in the wizard, click Help.

The client file is created with a .cli extension, in the location you specified.

Locking operators into the run-time environment

To lock operators into the FactoryTalk View SE Client at run time, for example, to prevent access to other programs on the computer, try one or more of the following methods:

- **Limit the ability to manipulate graphic displays**, by removing the title bar or minimize and maximize buttons from selected displays.

  To do this, in the Display Settings dialog box, clear the check boxes Title Bar, Minimize Button, and Maximize Button. For details, see Chapter 15, “Creating graphic displays” in the FactoryTalk View Site Edition User’s Guide.

- **Limit the ability to manipulate the client window**, by removing the title bar or minimize and maximize buttons from the client.

  To do this, in the FactoryTalk View SE Client wizard, clear the check boxes, Show title bar, and Show system menu and close button. For details, click Help in the FactoryTalk View SE Client wizard.
Prevent switching to other applications. To do this, in the FactoryTalk View SE Client wizard, select the check box, Disable switch to other applications. For details, click Help in the FactoryTalk View SE Client wizard.

Restrict access to the desktop, using the DeskLock tool.

To open Desklock, on the desktop click Start > All Programs > Rockwell Software > FactoryTalk View > Tools, and then click DeskLock. For details about using DeskLock, click Help within the tool.

Run the FactoryTalk View SE Client

Once the local application is deployed, test it by running the FactoryTalk View SE Client.

To run an SE Client using the .cli file

Double-click the client setup file (.cli), in the following default folders:

- For Windows 7 Professional, Windows Vista and Windows Server 2008:
  . . . \Users\Public\Documents\RSView Enterprise\SE\Client

- For Windows XP and Windows Server 2003:
  . . . \Documents and Settings\All Users\Shared Documents\RSView Enterprise\SE\Client

To run an SE Client from FactoryTalk View Studio

1. In FactoryTalk View Studio, on the Tools menu, click Launch SE Client.

2. In the Launch FactoryTalk View SE Client dialog box, type the name of the .cli file, and then click OK. To find and select the file, click the Browse button.

To run an SE Client when Windows starts

1. Create a shortcut to the .cli file (on the desktop, for example).

2. Move the shortcut to the Windows Startup folder.

   For information about adding shortcuts to the Startup folder, see the Windows Help.

Logging users on to the FactoryTalk View SE Client

To start the FactoryTalk View SE Client, or to change users while the client is running, the user logging on to the client must have the necessary security permissions.

If the user doesn’t have the necessary permissions, the FactoryTalk View SE Client Login dialog box opens, to let another user log on.
Administering deployed local applications

To make minor changes to an application after it is deployed, use either FactoryTalk View Studio or the FactoryTalk View SE Administration Console. The SE Administration Console contains the following subset of editors.

<table>
<thead>
<tr>
<th>To do this in the SE Administration Console</th>
<th>Use this editor</th>
</tr>
</thead>
<tbody>
<tr>
<td>Change the properties of an HMI server.</td>
<td>HMI Server Properties</td>
</tr>
<tr>
<td>Change the properties of a data server.</td>
<td>Data Server Properties</td>
</tr>
<tr>
<td>Add FactoryTalk users to an application.</td>
<td>Runtime Security</td>
</tr>
<tr>
<td>Set up security for commands and macros.</td>
<td>Secured Commands</td>
</tr>
<tr>
<td>Run FactoryTalk View commands.</td>
<td>Command Line</td>
</tr>
<tr>
<td>Change how HMI tag alarms are logged.</td>
<td>Alarm Setup</td>
</tr>
<tr>
<td>Change the paths of data log models.</td>
<td>Data Log Paths</td>
</tr>
<tr>
<td>Manage HMI tag alarm log files.</td>
<td>Alarm Log Setup</td>
</tr>
<tr>
<td>Import and export HMI tags.</td>
<td>Tag Import and Export Wizard</td>
</tr>
</tbody>
</table>

For details about options in these editors, click Help.

To open a local application in the SE Administration Console

1. Click **Start > All Programs > Rockwell Software > FactoryTalk View > Tools**, and then click **SE Administration Console**.
2. Select **Site Edition (Local)**, and then click **Continue**.
3. In the Existing tab, select the restored application’s name, and then click **Open**.
Upgrading the FactoryTalk® View Site Edition software in an automation and control application involves two core tasks: uninstalling the existing software, and then installing the new version.

After installing the new software version, you should be able to open a FactoryTalk View SE application in FactoryTalk View Studio, and then run the application in a FactoryTalk View SE Client, without any further intervention.

However, depending on the design, content, and complexity of your control system, you might have to perform additional tasks to support the upgrade, especially if you are upgrading FactoryTalk View SE in a production environment. If that’s the case, the goal of the information provided in this chapter is to help you safeguard the live application, while ensuring that the upgrade process is efficient and successful.

To illustrate an upgrade path that includes such supporting tasks, this chapter describes how to upgrade a deployed network application that consists of the following computers:

**Example: a FactoryTalk View SE network application with redundant servers**

<table>
<thead>
<tr>
<th>Run-time clients</th>
</tr>
</thead>
<tbody>
<tr>
<td>FactoryTalk Services Platform</td>
</tr>
<tr>
<td>FactoryTalk View SE Client</td>
</tr>
</tbody>
</table>

---

**Server #1 (Primary)**
- FactoryTalk Network Directory
- FactoryTalk Services Platform
- FactoryTalk View SE Server
- RSLinx Enterprise

**Workstation #1**
- FactoryTalk Services Platform
- FactoryTalk View Studio
- RSLinx Enterprise

**Server #2 (Secondary)**
- FactoryTalk Services Platform
- FactoryTalk View SE Server
- RSLinx Enterprise
In this example, **Server #1** is the name of the primary server computer, **Server #2** is the name of the secondary server computer, and **Workstation #1** is the name of the engineering workstation.

As there are many possible variations for this type of application, parts of the documented process might not apply directly to the application you are upgrading.

If you have questions about architectural elements not covered in this chapter, for example, because your application is more or less complex than the example provided, contact your local Rockwell Automation Sales office for assistance.

**Information to help you upgrade**

You can also look for answers in other Rockwell Automation product documentation, and on the Rockwell Automation Web site. See:

- “About the FactoryTalk View SE documentation” on page 2.
- “Supporting documentation and resources” on page 16.
- “Finding information on the Rockwell Automation Web site” on page 16.

RSView® Enterprise is the former name of the FactoryTalk View family of software products. If you are upgrading from a version of RSView, the information in this chapter still applies, even though it refers to FactoryTalk View as the previous product version. For a full list of new FactoryTalk product names, see Chapter 1, *Introducing FactoryTalk View Site Edition*.

**Overview: Upgrading of a redundant network application**

Use the following multi-step checklist as a guideline for upgrading your redundant network application. Details about each step are provided in this chapter.

If you are upgrading a non-redundant application, see the simplified overview in “About upgrading a non-redundant network application,” next.

- Step 1 – Prepare for the upgrade
- Step 2 – Back up the deployed application

**Part 1: Set up a separate, partially upgraded system**

- Step 3 – Set up a temporary upgrade system
- Step 4 – Upgrade software components on Server #2
- Step 5 – Upgrade software components on Workstation #1
- Step 6 – Migrate the FactoryTalk View SE application
Step 7 – Upgrade software on selected run-time clients

Step 8 – Test the migrated FactoryTalk View SE application

**Part 2: Upgrade remaining computers and restore redundancy**

- Step 9 – Upgrade remaining client computers
- Step 10 – Upgrade software components on Server #1
- Step 11 – Restore Server #1 as the primary application server
- Step 12 – Set up redundancy for the upgraded system
- Step 13 – Restart the entire upgraded application

Steps that involve uninstalling and installing FactoryTalk View SE and supporting software are documented in Appendix A, *Common upgrade procedures*. For quick reference, keep a separate copy of the Appendix on hand during the upgrade.

**About upgrading a non-redundant network application**

If your deployed network application is non-redundant, some of the supporting tasks documented in this chapter might be irrelevant or unnecessary.

For example, there would be no need to set up a temporary system, with the secondary server as the primary server, or to disable and then restore redundancy.

To upgrade a non-redundant network application, use the following steps as a guideline, keeping the noted exceptions in mind:

- **Prepare for the upgrade.** (See “Step 1 – Prepare for the upgrade” on page 102. Ignore the subsection about ensuring that the most recent application files are on the primary server computer.)

- **Back up the deployed application.** (See “Step 2 – Back up the deployed application” on page 104. Ignore the tip about ensuring that the most recent application files are on the primary server computer.)

- **Upgrade the engineering workstation.** (See “Step 5 – Upgrade software components on Workstation #1” on page 113. Ignore the last subsection, about specifying Server #2 as the Network Directory location.)

- **Migrate the deployed application.** (See “Step 6 – Migrate the FactoryTalk View SE application” on page 115.)

- **Upgrade the application server.** (See “Step 10 – Upgrade software components on Server #1” on page 121. For the non-redundant case, assume that the application server computer hosts the FactoryTalk Network Directory, an HMI server, and an RSLogix Enterprise data server.)
• Upgrade run-time clients. (See “Step 7 – Upgrade software on selected run-time clients” on page 116. For the non-redundant case, upgrade all run-time clients before restarting the application.)

• Restart the application. (See “Step 13 – Restart the entire upgraded application” on page 129. For the non-redundant case, you would only restart one server and the run-time clients.)

Finding out about features in the new product version

After upgrading all the software components in your deployed application, to find out about features in the new product version, see the product Release Notes.

Release Notes for FactoryTalk View SE, RSLinx Enterprise, and RSLinx Classic are available from the FactoryTalk View Site Edition DVD.

Release Notes for the FactoryTalk Services Platform (and other FactoryTalk products) are available from the Contents page in the FactoryTalk Help. Click Start > All Programs > Rockwell Software > FactoryTalk Tools, and then click FactoryTalk Help.

Step 1 – Prepare for the upgrade

Before getting started with the upgrade:

☐ Schedule down time for the upgrade

☐ Ensure that the user performing the upgrade has administrative rights

☐ Record the names and passwords of administrative users

☐ Perform set-up tasks on application computers

☐ Ensure that the latest application files are on the primary server

☐ Have the FactoryTalk View Site Edition DVD on hand

Schedule down time for the upgrade

During the upgrade process described in this chapter, the deployed FactoryTalk View SE application needs to be shut down twice:

■ During step 3, the application is shut down so that Server #2 can be set up as the temporary primary server.

■ During steps 9 to 11 (or 12), the application is shut down so that the remaining application computers can be upgraded, and so that application servers can be restored to their original roles.
In your upgrade process, be sure to schedule downtime, and notify affected personnel about times when the application needs to be shut down.

**Ensure that the user performing the upgrade has administrative rights**

To perform certain tasks, the user performing the upgrade must have administrative rights in Windows and at the FactoryTalk Network Directory.

Windows administrative rights are required to install FactoryTalk View SE and supporting software, because the setup program creates program folders and modifies registry entries.

FactoryTalk administrative rights are required to log on to the FactoryTalk Network Directory, for example, when you use the FactoryTalk Directory Server Location Utility.

To open the utility, you must log on as a FactoryTalk administrator on the local computer. To specify a remote Network Directory location, you must also have administrative rights on the remote computer.

FactoryTalk administrative rights are also required to back up and restore FactoryTalk View SE applications.

**Record the names and passwords of administrative users**

Before backing up the deployed application, ensure that you have recorded the user names and passwords of users that belong to the FactoryTalk administrators group.

Only members of the FactoryTalk administrators group can add, remove, or modify FactoryTalk user accounts, if this is necessary after restoring a backed-up application.

**Perform set-up tasks on application computers**

Before upgrading FactoryTalk View SE, review Chapter 2, *Setting up the installation environment*.

The chapter contains information about tasks you can perform on application computers, to ensure that FactoryTalk View SE runs smoothly after it is installed. It also contains information about hardware and software requirements, and application limits.

**Ensure that the latest application files are on the primary server**

During the upgrade described in this chapter, the application and HMI project files backed up on the primary server (Server #1) are restored on the secondary server (Server #2), and then migrated in FactoryTalk View Studio on the upgraded engineering workstation (Workstation #1).

To ensure that you migrate and re-deploy the most recent application, ensure that the application and HMI project files you back up initially, on the primary server, are the most recent application files.
Have the FactoryTalk View Site Edition DVD on hand

The FactoryTalk View Site Edition DVD provides setup programs for installing the FactoryTalk View SE software components, the FactoryTalk Services Platform, and RSLinx Enterprise.

Information about uninstalling and installing FactoryTalk View SE and supporting software is documented in Appendix A, *Common upgrade procedures*. For quick reference, keep a separate copy of the Appendix on hand during the upgrade.

Step 2 – Back up the deployed application

To ensure that the most recent application data is available for the upgrade, to back up the deployed application on Server #1, perform these tasks:

- Back up the HMI project
- Back up the application

In this upgrade example, the Initial back-up operations are performed on Server #1, assuming that the most recent application files are on the primary server. However, to guarantee that the most recent files are saved, it is recommended that you also back up files on the secondary server computer.

Back up the HMI project

On Server #1, use the HMI Server Backup and Restore utility to back up the primary server’s HMI project. Click Start > All Programs > Rockwell Software > FactoryTalk View > Tools > HMI Server Backup and Restore. For details about using the utility, click the Help button.

For the upgrade process described in this chapter, the HMI Server Backup and Restore utility needs to be installed on Server #1 and on Server #2.

Back up the application

On Server #1, use the FactoryTalk Administration Console to back up the deployed FactoryTalk View SE network application.

The back-up operation creates an application archive that includes area names, server names, server properties, and application languages.

If the back-up operation includes System information, user and computer accounts, as well as other FactoryTalk system-level settings, are also archived. For more information, see “About backing up System information with an application,” next.
Other application files, such as HMI project files, product activation, and logged historical data (trends, alarms, and diagnostic messages) must be backed up and restored separately.

For information about backing up and restoring files that belong to FactoryTalk Tag Alarm and Event Servers, see the FactoryTalk Alarms and Events Help.

**About backing up System information with an application**

The following illustration shows what a FactoryTalk View SE network application looks like, in the Explorer window in FactoryTalk View Studio.

The FactoryTalk Network Directory is represented at the top of application hierarchy. One level down, the System folder stores settings that are used by all the applications that belong to the same Network Directory.

For example, FactoryTalk user and computer accounts set up for each application are stored in the System folder.

When you back up a network application, System information for the application is not archived automatically.

To save the System information, for example, in order to preserve user and computer accounts, you must select the check box, Backup System in archive.

If you do back up System information with a network application, when you restore the application, you can choose whether to restore the archived System information. Keep in
mind that the restored System information will not merge with existing FactoryTalk System settings held at the current FactoryTalk Network Directory.

Instead, if the Network Directory on the local computer is active, you will replace user and computer accounts set up for any other application using the directory.

**To back up a network application**

> Before backing up an application, record the user names and passwords of administrative users set up for the application, in case this information is required for the restore operation.

1. On Server #1, click Start > All Programs > Rockwell Software, and then click **FactoryTalk Administration Console**.

2. In the Select FactoryTalk Directory dialog box, select **Network**, and then click **OK**.

3. In the Explorer window, right-click the application you want to back up, and then click **Backup**.

4. Specify an archive name and location.
   
   To specify a location other than the default, type the path or click the Browse button to find and select a location.

5. Select the check box, **Backup System in archive**, and then click **OK**.

   The back-up operation saves an application archive file with a .bak extension to the specified location. The default locations are:

   - For Windows XP, and Windows Server 2003, `C:\Documents and Settings\All Users\Documents`
   - For Windows 7 Professional, Windows Vista and Windows Server 2008, `C:\Users\Public\Documents`
Part 1: Set up a temporary system and perform a partial upgrade

During Part 1 of the upgrade, a temporary system is set up to test a partial upgrade that involves Server #2 (the secondary server), Workstation #1, and selected run-time clients. For the test, Server #2 is set up to function as the primary server.

Part 1: Server #2, Workstation #1, run-time clients

- **Run-time clients**
  - Finally, upgrade the software components on some run-time clients only, and then test the partial upgrade.

- **Workstation #1**
  - Next, upgrade the software components on Workstation #1, and then, migrate the restored application.

- **Server #2**
  - First, set up Server #2 as the Network Directory and primary HMI and data server (without redundancy). Then, upgrade the software on Server #2.
Step 3 – Set up a temporary upgrade system

To set up a temporary system so that you can test a partial upgrade, perform these tasks:

- Shut down all client computers
- Disable HMI and data server redundancy
- Set up Server #2 as the temporary primary server
- Restart Server #1 and all client computers

For this part of the upgrade, the FactoryTalk View SE application is shut down until the temporary FactoryTalk Network Directory can be set up. In your upgrade process, be sure to schedule down time, and notify affected personnel about times when the application needs to be shut down.

Shut down all client computers

To prevent communication with application servers while the temporary system is being set up, shut down all run-time client computers and Workstation #1.

To shut down a client computer

Stop all software programs running on the computer, and then shut down the computer.

Disable HMI and data server redundancy

To ensure that Server #2 can be detached from the application for upgrading, open the application in the FactoryTalk View Administration Console, and disable redundancy for the HMI server and data server.

To disable HMI and data server redundancy

1. On Server #2, click Start > All Programs > Rockwell Software > FactoryTalk View > Tools, and then click SE Administration Console.
2. In the Administration Console, select Site Edition (Network), and then click Continue.
3. In the New/Open Site Edition (Network) Application dialog box, select the deployed application, and then click Open.
4. Right-click the HMI server, and then click Properties.
5. In the Redundancy tab, clear the check box, Provide redundancy using a secondary server, and then click OK.
6. In the Explorer window, right-click the data server (RSLinx Enterprise), and then click **Properties**.

7. In the Redundancy tab, clear the check box, **Provide redundancy using a secondary server**, and then click **OK**.

**Set up Server #2 as the temporary primary server**

Several tasks are involved in setting up Server #2 as the temporary primary server and FactoryTalk Network Directory.

As part of the process, the original HMI project and application files that were backed up on Server #1 are restored on Server #2. The restored application will be migrated later, after Workstation #1 is upgraded.

To avoid introducing incompatible software component versions into a deployed production system, be sure to restore the HMI project and application files before upgrading any software.

- Copy backed-up files to Server #2
- Specify Server #2 as the Network Directory location
- Restore the HMI project files
- Restore the application files
- Disable redundancy and make Server #2 the primary server

For details, see the procedures that follow.

**Copy backed-up files to Server #2**

1. On Server #2, open Windows Explorer, browse to where the backed-up HMI project and application files are saved on Server #1, and then copy the files.

2. Open another instance of Windows Explorer, and then paste the backed-up HMI project and application files into the same location on Server #2.

**Specify Server #2 as the Network Directory location**

1. On Server #2, click Start > All Programs > Rockwell Software > FactoryTalk Tools, and then click **Specify FactoryTalk Directory Location**.

   To use the FactoryTalk Directory Server Location Utility, you have to log on as an administrator on the local computer.

2. **Server #1** should be displayed in the field, Computer hosting directory server. Click the Browse button.
3. In the FactoryTalk Directory Server Configuration dialog box, click *This computer*, and then click **OK**.

To change the Network Directory location, you have to log on as an administrator on the new Network Directory computer (local or remote).

4. Click **OK**, and then restart Server #2.

**Restore the HMI project files**

1. On Server #2, open the HMI Server Backup and Restore utility. Click **Start > All Programs > Rockwell Software > FactoryTalk View > Tools > HMI Backup and Restore**. For details about using the utility, click the **Help** button.

2. To restore the HMI project files copied from Server #1, follow the instructions in the wizard.

---

You can use Windows Vista only to run the FactoryTalk View SE Client, develop stand-alone or distributed applications on a single computer, or to run FactoryTalk View Studio and connect to remote HMI servers. You **cannot** use Windows Vista to host HMI servers that other clients connect to. To host HMI servers, use Windows 7 Professional, Windows XP, Windows Server 2003, or Windows Server 2008 instead.

---

**Restore the application files**

1. On Server #2, click **Start > All Programs > Rockwell Software**, and then click **FactoryTalk Administration Console**.

2. Select **Network**, and then click **OK**.

3. In the Explorer window, right-click **Network (THIS COMPUTER)**, and then click **Restore**.

4. Type the path to the application archive’s location, or click the Browse button to find and select the archive, and then click **Next**.

**Application archive files have a .bak extension.**

For Windows XP, and Windows Server 2003, the default location for application files is C:\Documents and Settings\All Users\Documents.

For Windows 7 Professional, Windows Vista and Windows Server 2008, the default location is C:\Users\Public\Documents.
5. In this upgrade example, because System information was included when the
application was backed up (see page 104), Application and System should be
displayed in the field, Archive type.

Select the check box, Restore System, and then click OK.

Keep in mind that restoring System information replaces user and computer accounts, and
RSLinx Enterprise device paths, set up in the FactoryTalk Directory on the local computer.

Disable redundancy and make Server #2 the primary server

1. On Server #2, open the restored application in the SE Administration Console.

   To open the Administration Console, click Start > All Programs > Rockwell Software
   > FactoryTalk View > Tools, and then click SE Administration Console.

2. After the application opens, right-click the HMI server, and then click Properties.

3. In the Redundancy tab, clear the check box, Provide redundancy using a secondary
   server, and then click Apply.

4. In the General tab, in the field, Computer hosting the server, type Server #2, and then
   click OK.

5. In the Explorer window, right-click the data server (RSLinx Enterprise), and then
   click Properties.

6. In the Redundancy tab, clear the check box, Provide redundancy using a secondary
   server, and then click Apply.

7. In the General tab, in the field Computer hosting the RSLinx Enterprise server, type
   Server #2, and then click OK.

Restart Server #1 and all client computers

To restart the deployed application, restart Server #1, wait for Server #1 to finish starting,
and then restart application client computers (Workstation #1 and all run-time clients).

The deployed application will run without redundancy, until the software on all computers is
upgraded. After the software is upgraded, Server #1 and Server #2 can be restored to their
original roles as primary and secondary servers, and the upgraded application can be started.
To confirm that Server #1 has finished starting

1. Click Start > All Programs > Rockwell Software > FactoryTalk Tools, and then click Diagnostics Viewer.

2. In the FactoryTalk Diagnostics Viewer, check for the following Diagnostics message:

   The HMI Server <ApplicationName>//Server#1 is the active server.

   To find a message faster in the Diagnostics Viewer, on the View menu, click Options. Then, in the Filter tab, create a Message filter with one or more keywords from the message.

Step 4 – Upgrade software components on Server #2

To upgrade FactoryTalk View SE and supporting software on Server #2, perform these tasks:

- Uninstall FactoryTalk View SE
- Install the FactoryTalk Services Platform
- Install SQL Server Express Prerequisites
- Install FactoryTalk View SE
- Install RSLinx Enterprise
- Install any necessary product updates

Information about uninstalling and installing FactoryTalk View SE and supporting software is documented in Appendix A, Common upgrade procedures. For quick reference, keep a separate copy of the Appendix on hand during the upgrade.

Uninstall FactoryTalk View SE

For instructions, see “How to uninstall FactoryTalk View SE and supporting software” on page 132 in Appendix A.

Install the FactoryTalk Services Platform

For instructions, see “How to install the FactoryTalk Services Platform” on page 133 in Appendix A.

Install SQL Server Express Prerequisites

For instructions, see “Install SQL Server Express Prerequisites” on page 134 in Appendix A.
Install FactoryTalk View SE
On Server #2, install the FactoryTalk View SE Server software and the FactoryTalk View SE Administration Console, at least.

For instructions about installing selected FactoryTalk View SE software components, see “How to install FactoryTalk View SE” on page 134 in Appendix A.

Install RSLinx Enterprise
For instructions, see “How to install RSLinx Enterprise” on page 138 in Appendix A.

Install any necessary product updates
For instructions, see “How to install any necessary product updates” on page 139 in Appendix A.

Step 5 – Upgrade software components on Workstation #1
To upgrade FactoryTalk View SE and supporting software on Workstation #1, perform these tasks:

- Shut down software running on Workstation #1
- Set up Workstation #1 as the Network Directory location
- Uninstall FactoryTalk View SE
- Install the FactoryTalk Services Platform
- Install SQL Server Express Prerequisites
- Install FactoryTalk View SE
- Install RSLinx Enterprise
- Install any necessary product updates
- Specify Server #2 as the Network Directory location

Information about uninstalling and installing FactoryTalk View SE and supporting software is documented in Appendix A, Common upgrade procedures. For quick reference, keep a separate copy of the Appendix on hand during the upgrade.

Shut down software running on Workstation #1
Shut down all software programs that are currently running on Workstation #1.
Set up Workstation #1 as the Network Directory location

To prepare to upgrade the software on Workstation #1, specify Workstation #1 as the Network Directory location.

To specify Workstation #1 as the Network Directory

1. On Workstation #1, click Start > All Programs > Rockwell Software > FactoryTalk Tools, and then click Specify FactoryTalk Directory Location.

   To use the FactoryTalk Directory Server Location Utility, you have to log on as an administrator on the local computer.

2. Server #1 should be displayed in the field, Computer hosting the directory server. Click the Browse button.

3. In the FactoryTalk Directory Server Configuration dialog box, click This computer, and then click OK.

   To change the Network Directory location, you have to log on as an administrator on the new Network Directory computer (local or remote).

4. Click OK, and then restart Workstation #1.

Uninstall FactoryTalk View SE

For instructions, see “How to uninstall FactoryTalk View SE and supporting software” on page 132 in Appendix A.

Install the FactoryTalk Services Platform

For instructions, see “How to install the FactoryTalk Services Platform” on page 133 in Appendix A.

Install SQL Server Express Prerequisites

For instructions, see “Install SQL Server Express Prerequisites” on page 134 in Appendix A.

Install FactoryTalk View SE

On Workstation #1, install the FactoryTalk View Studio software at least.

For instructions about installing selected FactoryTalk View SE components, see “How to install FactoryTalk View SE” on page 134 in Appendix A.

Install RSLinx Enterprise

For instructions, see “How to install RSLinx Enterprise” on page 138 in Appendix A.
Install any necessary product updates
For instructions, see “How to install any necessary product updates” on page 139 in Appendix A.

Specify Server #2 as the Network Directory location
After upgrading the software on Workstation #1, specify Server #2 as the Network Directory location.

To specify Server #2 as the Network Directory
1. On Workstation #1, click Start > All Programs > Rockwell Software > FactoryTalk Tools, and then click Specify FactoryTalk Directory Location.
   To use the FactoryTalk Directory Server Location Utility, you have to log on as an administrator on the local computer.
2. **Localhost** should be displayed in the field, Computer hosting directory server. Click the Browse button.
3. In the FactoryTalk Directory Server Configuration dialog box, type **Server #2**, and then click OK.
   To change the Network Directory location, you have to log on as an administrator on the new Network Directory computer (local or remote).
4. Click OK, and then restart Workstation #1.

Step 6 – Migrate the FactoryTalk View SE application
To migrate the FactoryTalk View SE application that was restored on Server #2, perform these tasks:

- Open the application in FactoryTalk View Studio
- Verify RSLinx Enterprise shortcuts
- Test the migrated application

For details, see the procedures that follow.

Open the application in FactoryTalk View Studio
To migrate the application, open it in the new version of FactoryTalk View Studio installed on upgraded Workstation #1.
To open the application
1. On Workstation #1, click Start > All Programs > Rockwell Software > FactoryTalk View, and then click FactoryTalk View Studio.
2. Click Site Edition (Network), and then click Continue.
3. In the Existing tab, click the application name, select an application language, and then click Open.
   Wait until the HMI server and all project components in the application are loaded, and then leave the application open in FactoryTalk View Studio.

Verify RSLinx Enterprise shortcuts
To confirm that data communications are set up correctly in the migrated application, verify that RSLinx Enterprise shortcuts point at the correct devices.

To check RSLinx Enterprise shortcuts
1. In FactoryTalk View Studio, expand the data server (RSLinx Enterprise), and then double-click Communications Setup.
2. In the Communications Setup editor, select each configured RSLinx Enterprise shortcut, and ensure that it points at the correct device.
3. Save the configuration and close the Communications Setup editor.

Test the migrated application
To test the migrated application, run the application on Workstation #1.

To run the migrated application
- Start a FactoryTalk View SE Client configuration on Workstation #1, and ensure that data communications are functioning as expected.

Step 7 – Upgrade software on selected run-time clients
To upgrade FactoryTalk View SE and supporting software on selected run-time clients, perform these tasks on each client computer:

- Shut down software running on the client

  It is recommended that you upgrade the software on some application clients, confirm that the upgraded application is running as expected, and then upgrade the software on the remaining clients. The number of clients to upgrade initially is left to your discretion.
Set up the client as the Network Directory location

Uninstall FactoryTalk View SE

Install the FactoryTalk Services Platform

Install SQL Server Express Prerequisites

Install FactoryTalk View SE

Install any necessary product updates

Specify Server #2 as the Network Directory location

Information about uninstalling and installing FactoryTalk View SE and supporting software is documented in Appendix A, *Common upgrade procedures*. For quick reference, keep a separate copy of the Appendix on hand during the upgrade.

**Shut down software running on the client**

Shut down all software programs that are currently running on the client computer.

**Set up the client as the Network Directory location**

To prepare to upgrade the software on the client computer, specify the client as the Network Directory location.

**To specify the client computer as the Network Directory**

1. On the client computer, click Start > All Programs > Rockwell Software > FactoryTalk Tools, and then click *Specify FactoryTalk Directory Location*.

   To use the FactoryTalk Directory Server Location Utility, you have to log on as an administrator on the local computer.

2. **Server #1** should be displayed in the field, Computer hosting directory server. Click the Browse button.

3. In the FactoryTalk Directory Server Configuration dialog box, click **This computer**, and then click **OK**.

   To change the Network Directory location, you have to log on as an administrator on the new Network Directory computer (local or remote).

4. Click **OK**, and then restart the client computer.

**Uninstall FactoryTalk View SE**

For instructions, see “How to uninstall FactoryTalk View SE and supporting software” on page 132 in Appendix A.
Install the FactoryTalk Services Platform

For instructions, see “How to install the FactoryTalk Services Platform” on page 133 in Appendix A.

Install SQL Server Express Prerequisites

For instructions, see “Install SQL Server Express Prerequisites” on page 134 in Appendix A.

Install FactoryTalk View SE

On run-time clients, install the FactoryTalk View SE Client software at least.

For instructions about installing selected FactoryTalk View SE components, see “How to install FactoryTalk View SE” on page 134 in Appendix A.

Install any necessary product updates

For instructions, see “How to install any necessary product updates” on page 139 in Appendix A.

Specify Server #2 as the Network Directory location

After upgrading the software on the client computer, specify Server #2 as the Network Directory location.

1. On the client computer, click Start > All Programs > Rockwell Software > FactoryTalk Tools, and then click Specify FactoryTalk Directory Location.

   To use the FactoryTalk Directory Server Location Utility, you have to log on as an administrator on the local computer.

2. Localhost should be displayed in the field, Computer hosting directory server. Click the Browse button.

3. In the FactoryTalk Directory Server Configuration dialog box, type Server #2, and then click OK.

   To change the Network Directory location, you have to log on as an administrator on the new Network Directory computer (local or remote).

4. Click OK, and then restart the client computer.
Step 8 – Test the migrated FactoryTalk View SE application

To test the migrated application before upgrading remaining application computers, perform these tasks:

- Start Server #2 and wait for it to finish starting
- Run the migrated application on upgraded clients
- Verify that the system is functioning as expected

Start Server #2 and wait for it to finish starting

Start Server #2 and wait for the server to finish starting. To confirm that Server #2 has finished starting

1. Click Start > All Programs > Rockwell Software > FactoryTalk Tools, and then click Diagnostics Viewer.
2. In the FactoryTalk Diagnostics Viewer, check for the following Diagnostics message:

   The HMI Server <ApplicationName>//Server #2 is the active server.

To find a message faster in the Diagnostics Viewer, on the View menu, click Options. Then, in the Filter tab, create a Message filter with one or more keywords from the message.

Run the migrated application on upgraded clients

On each of the upgraded run-time client computers, run the existing FactoryTalk View SE Client configuration file (.cli).

Verify that the system is functioning as expected

After the application starts running on the upgraded client computers, verify that display navigation, object animation, communications, alarming (if configured), and other applications features are functioning as expected.
**Part 2: Upgrade Server #1 and remaining clients**

Part 2 of the upgrade, illustrated next, involves upgrading Server #1 and remaining run-time clients, and restoring Server #1 to its intended role as the primary application server.

**Part 2: Server #1, remaining run-time clients**

Run-time clients

First, upgrade the software components on run-time clients that weren’t upgraded during Part 1.

Server #1

Next, upgrade the software on Server #1 and make it the Network Directory and primary HMI and data server. Finally, restore redundancy and restart the upgraded application.

During Part 1, software components were upgraded on Server #2, Workstation #1, and selected run-time clients, and the application was migrated in FactoryTalk View Studio.

For steps 9 to 11 (or 12) of the upgrade, the FactoryTalk View SE application is shut down until the remaining application computers can be upgraded and restored to their original roles in the application.

In your upgrade process, be sure to schedule down time, and notify affected personnel about times when the application needs to be shut down.

---

**Step 9 – Upgrade remaining client computers**

After testing the partially upgraded system, to upgrade the FactoryTalk View SE software on remaining run-time clients, follow steps 1 to 7 in “Step 7 – Upgrade software on selected run-time clients” on page 116.
Step 10 – Upgrade software components on Server #1

To upgrade FactoryTalk View SE and supporting software on Server #1, perform these tasks.

- Uninstall FactoryTalk View SE
- Install the FactoryTalk Services Platform
- Install SQL Server Express Prerequisites
- Install FactoryTalk View SE
- Install RSLinx Enterprise
- Install any necessary product updates

Information about uninstalling and installing FactoryTalk View SE and supporting software is documented in Appendix A, *Common upgrade procedures*. For quick reference, keep a separate copy of the Appendix on hand during the upgrade.

Uninstall FactoryTalk View SE

For instructions, see “How to uninstall FactoryTalk View SE and supporting software” on page 132 in Appendix A.

Install the FactoryTalk Services Platform

For instructions, see “How to install the FactoryTalk Services Platform” on page 133 in Appendix A.

Install SQL Server Express Prerequisites

For instructions, see “Install SQL Server Express Prerequisites” on page 134 in Appendix A.

Install FactoryTalk View SE

On Server #1, install the FactoryTalk View SE Server software and the FactoryTalk View SE Administration Console, at least.

For instructions about installing selected FactoryTalk View SE components, see “How to install FactoryTalk View SE” on page 134 in Appendix A.

Install RSLinx Enterprise

For instructions, see “How to install RSLinx Enterprise” on page 138 in Appendix A.
Install any necessary product updates

For instructions, see “How to install any necessary product updates” on page 139 in Appendix A.

---

**Step 11 – Restore Server #1 as the primary application server**

To restore Server #1 as the FactoryTalk Network Directory and the primary server, perform these tasks:

- On Server #2, back up the migrated application
- Copy backed-up application files to Server #1
- On Server #1, restore the HMI project and application
- Specify Server #1 as the primary HMI and data server
- Specify Server #1 as the Network Directory for clients
- Test run the application from all upgraded clients

**On Server #2, back up the migrated application**

To prepare to move migrated application data to Server #1, back up the migrated HMI project and application files on Server #2.

For more information about the backup and restore operations, see “Step 2 – Back up the deployed application” on page 104.

**To back up the HMI project**

On Server #2, use the HMI Server Backup and Restore utility to back up the primary server’s HMI project. Click **Start > All Programs > Rockwell Software > FactoryTalk View > Tools > HMI Server Backup and Restore**. For details about using the utility, click the **Help** button.

**To back up the application**

Before backing up an application, record the user names and passwords of FactoryTalk users with administrative rights, in case this information is required for the restore operation.

1. On Server #2, click Start > All Programs, Rockwell Software, and then click **FactoryTalk Administration Console**.
2. Select **Network**, and then click **OK**.

3. In the Explorer window, right-click the application you want to back up, and then click **Backup**.

   To back up a network application, the logged on user must have FactoryTalk administrative rights. If you receive a prompt to log on, check with your System Administrator.

4. Specify an archive name and location.

   To specify a location other than the default, type the path or click the Browse button to find and select a location.

5. Select the check box, **Backup System in archive**, and then click **OK**.

   Application archive files have a .bak extension.

   For Windows XP, and Windows Server 2003, the default location for application files is C:s Documents and Settings\All Users\Documents.

   For Windows 7 Professional, Windows Vista and Windows Server 2008, the default location is C:s Users\Public\Documents.

---

**Copy backed-up application files to Server #1**

After backing up the migrated application and HMI project files on Server #2, copy the files to the same location on Server #1.

---

You can use Windows Vista only to run the FactoryTalk View SE Client, develop stand-alone or distributed applications on a single computer, or to run FactoryTalk View Studio and connect to remote HMI servers. You **cannot** use Windows Vista to host HMI servers that other clients connect to. To host HMI servers, use Windows 7 Professional, Windows XP, Windows Server 2003, or Windows Server 2008 instead.

---

**To copy backup files to Server #1**

1. On Server #1, open Windows Explorer, browse to where the backed-up HMI project and application files are saved on Server #2, and then copy the files.

2. Open another instance of Windows Explorer, and then paste the backed-up HMI project and application files into the same location on Server #1.

**On Server #1, restore the HMI project and application**

Before restoring Server #1 to its original role as the FactoryTalk Network Directory and primary server, restore the migrated HMI project and application files on Server #1.
To restore the HMI project files

1. On Server #2, open the HMI Server Backup and Restore utility. Click Start > All Programs > Rockwell Software > FactoryTalk View > Tools > HMI Backup and Restore. For details about using the utility, click the Help button.

2. To restore the HMI project files copied from Server #1, follow the instructions in the wizard.

You can use Windows Vista only to run the FactoryTalk View SE Client, develop stand-alone or distributed applications on a single computer, or to run FactoryTalk View Studio and connect to remote HMI servers. You cannot use Windows Vista to host HMI servers that other clients connect to. To host HMI servers, use Windows 7 Professional, Windows XP, Windows Server 2003, or Windows Server 2008 instead.

To restore the application files

1. On Server #2, click Start > All Programs > Rockwell Software, and then click FactoryTalk Administration Console.

2. Select Network, and then click OK.

3. In the Explorer window, right-click Network (THIS COMPUTER), and then click Restore.

4. Type the path to the application archive’s location, or click the Browse button to find and select the archive, and then click Next.

Application archive files have a .bak extension.
For Windows XP, and Windows Server 2003, the default location for application files is C:\Documents and Settings\All Users\Documents.
For Windows 7 Professional, Windows Vista and Windows Server 2008, the default location is C:\Users\Public\Documents.

5. In this upgrade example, because System information was included when the application was backed up (see page 122), Application and System should be displayed in the field, Archive Type.

For this example, select the check box Restore System, and then click OK.

When restoring your application, keep in mind that if you select the check box Restore System, and there are applications using the FactoryTalk Network Directory on the computer, the restore operation will replace user and computer accounts set up for the applications.
Specify Server #1 as the primary HMI and data server

To restore Server #1 to its original role as the primary server, specify Server #1 as the computer hosting the HMI and the data server.

To set up Server #1 as the primary server

1. Close the FactoryTalk Administration Console, and then open the restored application in the FactoryTalk View SE Administration Console.
2. Right-click the HMI server, and then click **Properties**.
3. In the box, Computer hosting the server, type **Server #1**, and then click **OK**.
4. In the Explorer window, right-click the data server (RSLinx Enterprise), and then click **Properties**.
5. In the field, Computer hosting the RSLinx Enterprise server, type **Server #1**, and then click **OK**.

Specify Server #1 as the Network Directory for clients

To restore Server #1 to its original role as the FactoryTalk Network Directory server, on run-time client computers and on Workstation #1, specify Server #1 as the Network Directory location.

To specify Server #1 as the Network Directory

1. On the client computer, click Start > All Programs > Rockwell Software > FactoryTalk Tools, and then click **Specify FactoryTalk Directory Location**.

   To use the FactoryTalk Directory Server Location Utility, you have to log on as an administrator on the local computer.

2. Click the Browse button beside the field, Computer hosting directory server.
3. In the FactoryTalk Directory Server Configuration dialog box, click **Remote computer**.
4. Type **Server #1**, and then click **OK**.

   To change the Network Directory location, you have to log on as an administrator on the new Network Directory computer. In this case, the new location is remote.

5. Click **OK**, and then restart the client computer.
6. Repeat steps 1 to 5 on all application run-time clients and on Workstation #1.
Test run the application from all upgraded clients

To ensure that Server #1 and the upgraded run-time clients are functioning as expected, run the existing FactoryTalk View SE Client configuration file on each client computer.

Step 12 – Set up redundancy for the upgraded system

To restore redundancy for application servers, perform these tasks:

- Specify Server #1 as the Network Directory for Server #2
- Shut down all client computers
- Set up HMI server redundancy
- Set up data server redundancy
- Replicate primary server files to the secondary server

Specify Server #1 as the Network Directory for Server #2

Now that Server #1 is restored as the FactoryTalk Network Directory, set up Server #2 to point at that directory server location.

To specify Server #1 as the Network Directory

1. On Server #2, click Start > All Programs > Rockwell Software > FactoryTalk Tools, and then click Specify FactoryTalk Directory Location.

   To use the FactoryTalk Directory Server Location Utility, you have to log on as an administrator on the local computer.

2. **Localhost** should be displayed in the field, Computer hosting directory server. Click the Browse button.


4. Type **Server #1**, and then click **OK**.

   To change the Network Directory location, you have to log on as an administrator on the new Network Directory computer. In this case, the new location is remote.

5. Click **OK** again, and then restart Server #2.
Shut down all client computers

To disconnect client and server computers, shut down all application clients, including Workstation #1.

To do this, shut down any applications that are currently running on the clients, and then shut down the computers.

Set up HMI server redundancy

To restore Server #2 to its original role as the secondary HMI server, set up HMI server redundancy for Server #1.

To set up redundancy for the HMI server

1. On Server #1, in the FactoryTalk View SE Administration Console, open the restored, migrated application.

2. In the Explorer window, right-click the HMI server, and then click Properties.

3. In the General tab, ensure that the option, Load and run startup components when operating system initializes, is selected.

Servers set up to start On demand cannot be made redundant.

4. Ensure that Server #1 is displayed in the field, Computer hosting the server.

5. In the Redundancy tab, select the check box, Provide redundancy using a secondary server.

6. In the field, Computer hosting the server, type Server #2.

You can use Windows Vista only to run the FactoryTalk View SE Client, develop stand-alone or distributed applications on a single computer, or to run FactoryTalk View Studio and connect to remote HMI servers. You cannot use Windows Vista to host HMI servers that other clients connect to. To host HMI servers, use Windows 7 Professional, Windows XP, Windows Server 2003, or Windows Server 2008 instead.

7. Select a switchover option for the redundant HMI server pair, and then click OK.

Set up data server redundancy

To restore Server #2 to its original role as the secondary data server, set up data server redundancy for Server #1.
To set up redundancy for the data server

1. On Server #1, in the FactoryTalk View SE Administration Console, right-click the data server (RSLinx Enterprise), and then click Properties.

2. In the General tab, ensure that Server #1 is displayed in the field, Computer hosting the RSLinx Enterprise server.

3. In the Redundancy tab, select the check box, Provide redundancy using a secondary server.

4. In the field, Computer running secondary server, type Server #2.

5. Select a switchover option for the redundant data server pair, and then click OK.

Replicate primary server files to the secondary server

Before restarting the entire application, synchronize server settings and content on Server #1 and Server #2, by replicating files from the primary to the secondary server.

The replicate operation copies the primary server’s configuration files, including settings in the Components tab, to the secondary server.

For example, if an On Active and a Shutdown macro are selected for the primary server, the settings will be replicated to the secondary. This means that the same macros specified for the primary server will run when the secondary server becomes active or shuts down.

Information that is not included in the replicate operation includes datalog files generated at run time, the current value of HMI memory tags, retentive tags, and the HMI tag alarm suppressed list.

For replication to succeed, the primary server must remain active and the secondary server must remain on standby, for the duration of the replicate operation.

To confirm the status of the primary and secondary servers

On Server #1, in the FactoryTalk View SE Administration Console, right-click the HMI server, and then click Server Status. In the Server Status dialog box:

- The computer name and status of the primary server are displayed in the fields, Primary server and Primary status, respectively.

- The computer name and status of the secondary server are displayed in the fields, Secondary server and Secondary status, respectively.
To replicate primary server files to the secondary

1. On Server #1, in the FactoryTalk View SE Administration Console, right-click the HMI server, and then click Properties.
2. In the Redundancy tab, click Replicate Primary to Secondary.

   The Replicate Primary to Secondary button is available only if the primary server is active when the Redundancy tab is selected.

   Follow the instructions on screen. After the replicate operation is complete, the secondary server is restarted automatically.

---

Step 13 – Restart the entire upgraded application

The final step in the upgrade process is to restart the entire system. Perform these tasks:

- Start Server #1 and Server #2
- Start all run-time clients

Start Server #1 and Server #2

To prepare to restart the entire system, first restart Server #1, and then start Server #2.

Wait for both servers to finish starting, and also confirm that they are functioning in their primary and secondary roles.

To confirm that Servers #1 and 2 have finished starting

1. Click Start > All Programs > Rockwell Software > FactoryTalk Tools, and then click Diagnostics Viewer.
2. In the FactoryTalk Diagnostics Viewer, check for the following Diagnostics messages:

   The HMI Server <ApplicationName>://Server#1 is the active server.
   In service. the server RNA://$Global/<ApplicationName>:
   <HMIServerName> on computer Server #2 (secondary) is now on standby.

   To find a message faster in the Diagnostics Viewer, on the View menu, click Options. Then, in the Filter tab, create a Message filter with one or more keywords from the message.

Start all run-time clients

To ensure that the entire, upgraded application is functioning as expected, run the existing FactoryTalk View SE Client configuration file on each run-time client computer.
Common upgrade procedures

Chapter 7, *Upgrading FactoryTalk View Site Edition*, describes what’s involved in upgrading a FactoryTalk View SE network application that contains redundant HMI servers and data servers. The application consists of the following computers:

- **Server #1** is an application server that hosts the FactoryTalk Network Directory (also called the Network Directory), the primary HMI server, and the primary data server, which is a Rockwell Automation Device Server (RSLinx Enterprise).

You can use Windows Vista only to run the FactoryTalk View SE Client, develop stand-alone or distributed applications on a single computer, or to run FactoryTalk View Studio and connect to remote HMI servers. You cannot use Windows Vista to host HMI servers that other clients connect to. To host HMI servers, use Windows 7 Professional, Windows XP, Windows Server 2003, or Windows Server 2008 instead.

- **Server #2** is an application server that hosts the secondary HMI server and the secondary data server, which is a Rockwell Automation Device Server (RSLinx Enterprise).

- **Workstation #1** is an engineering workstation that hosts FactoryTalk View Studio.

- **Client #1 – client #n** are operator workstations that host run-time clients (FactoryTalk View SE Clients).

At some point during the upgrade process, you need to perform the following tasks on each computer:

- Uninstall the existing version of FactoryTalk View SE and supporting software.

- Install the new version of the FactoryTalk Services Platform.

- Install the new version of FactoryTalk View SE.

- Install the new version of RSLinx Enterprise.

- Install necessary product updates.
Because these procedures are repeated throughout the upgrade process, rather than duplicating the steps, they are documented here in this Appendix. For quick reference, print a separate copy of the Appendix and keep it on hand during the upgrade process.

Before installing FactoryTalk View SE or any supporting software, review Chapter 2, Setting up the installation environment, to ensure that you performed the appropriate tasks for the role and configuration of each application host computer.

How to uninstall FactoryTalk View SE and supporting software

The first step in upgrading FactoryTalk View SE and supporting software on any computer is uninstalling the existing version of the software.

On the FactoryTalk View Site Edition DVD, select the option, Uninstall FactoryTalk View Site Edition, and the program automatically detects software that needs to be be uninstalled.

Some dependent products are uninstalled automatically; others must be uninstalled manually, using the Windows Add or Remove programs tool.

Using Add or Remove Programs to uninstall all of FactoryTalk View SE and supporting software can result in unexpected behavior. Follow the instructions in the Uninstall program carefully.

To uninstall FactoryTalk View SE

1. If necessary, close all open Windows programs, and then place the FactoryTalk View Site Edition DVD in the computer’s DVD drive.

   If the DVD does not start automatically, run D:\setup.exe, where D is the drive containing the DVD.

2. Click Install FactoryTalk View Site Edition (the second option).

3. Click step 1, Uninstall FactoryTalk View Site Edition.

   You are reminded to disconnect any remote clients before running the uninstall program. You must also stop any HMI servers that are running on the computer.

   If you need to stop an HMI Server, right-click the HMI server and then click Properties on the context menu. In the Components tab, click Stop All Running Components.
4. Accept the reminder to disconnect remote clients.

5. Click **OK** to uninstall all the FactoryTalk View Dependencies.

**How to install the FactoryTalk Services Platform**

The FactoryTalk Services Platform (formerly known as the FactoryTalk Automation Platform) provides essential services to all FactoryTalk products running on a computer.

You must install the FactoryTalk Services Platform first, before you can install FactoryTalk View SE or any other FactoryTalk product on the computer.

**To install the FactoryTalk Services Platform**

1. If necessary, close all open Windows programs, and then place the FactoryTalk View Site Edition DVD in the computer’s DVD drive.

   If the DVD does not start automatically, run D:\setup.exe, where D is the drive containing the DVD.

2. Click **Install FactoryTalk View Site Edition** (the second option).

3. Click step 2, **Install FactoryTalk Services Platform**.

   **Tip:** If Windows .NET 3.5 SP1 is not installed on the computer, .NET setup program will be installed automatically before FactoryTalk Services Platform.

4. Accept the license agreement, and then click **Next**.
5. Ensure that the check box, Install the FactoryTalk Administration Console, is selected, and then click Next.

6. Click Install.

Install SQL Server Express Prerequisites

To successfully install SQL Server, you must have Windows Installer 4.5 installed on your computer first. Click Install SQL Server Express Prerequisites to install Windows Installer 4.5 on your computer.

Skip this step if you only install FactoryTalk View Client on the computer, since SQL Server is installed only when you choose to install FactoryTalk View Studio or HMI server.

To install the SQL Server Express Prerequisites

1. If necessary, close all open Windows programs, and then place the FactoryTalk View Site Edition DVD in the computer’s DVD drive.

   If the DVD does not start automatically, run D:\setup.exe, where D is the drive containing the DVD.

2. Click Install FactoryTalk View Site Edition (the second option).

3. Click step 3, Install SQL Server Express Prerequisites.

4. To finish installing the software, follow the instructions in the wizard.

How to install FactoryTalk View SE

The FactoryTalk View Site Edition setup program offers two options for installing the FactoryTalk View SE software. You can select:

- **Complete**, to install all FactoryTalk View SE components on the computer.

- **Selected components**, to select which FactoryTalk View SE components will be installed.

You can use Windows Vista only to run the FactoryTalk View SE Client, develop stand-alone or distributed applications on a single computer, or to run FactoryTalk View Studio and connect to remote HMI servers. You **cannot** use Windows Vista to host HMI servers that other clients connect to. To host HMI servers, use Windows 7 Professional, Windows XP, Windows Server 2003, or Windows Server 2008 instead.
For the sample application described in Chapter 7, *Upgrading FactoryTalk View Site Edition*, selected FactoryTalk View SE components are installed on the engineering and operator workstations, and on computers running the primary and secondary HMI servers.

To learn how to install all the FactoryTalk View SE software on a given computer, see “To install all FactoryTalk View SE components on the computer” on page 47.

**To install selected FactoryTalk View SE components**

1. If necessary, close all open Windows programs, and then place the FactoryTalk View Site Edition DVD in the computer’s DVD drive.

   If the DVD does not start automatically, run D:\setup.exe, where D is the drive containing the DVD.

2. Click **Install FactoryTalk View Site Edition** (the second option).

3. Click step 4, **Install FactoryTalk View Site Edition**.

4. To continue installing FactoryTalk View SE, click **Yes** in the warning message box that tells about stopping Rockwell Automation software processes.

   The FactoryTalk View Site Edition installation wizard starts running.

5. In the Welcome window, click **Next**.

6. Accept the License Agreement, and then click **Next**

7. In the Customer Information window, type a user and organization name, type the product’s Serial Number, and then click **Next**.

8. In the Setup Type window, select **Selected Components**, and then click **Next**.

9. In the Destination Drive window, accept the default destination drive or specify a different drive, and then click **Next**.
10. In the Custom Setup window, click the down arrow beside each component name and select one of the following options, to include or exclude a component or subcomponent:

- **This feature will be installed on local hard drive**—installs the component.
- **This feature, and all subfeatures, will be installed on local hard drive**—installs the entire feature.
- **This feature will not be available**—does not install the feature.

11. To install the components you have selected, in the Ready to Install the Program window, click **Install**.

---

**Warning:** You can use Windows Vista only to run the FactoryTalk View SE Client, develop stand-alone or distributed applications on a single computer, or to run FactoryTalk View Studio and connect to remote HMI servers. You **cannot** use Windows Vista to host HMI servers that other clients connect to. To host HMI servers, use Windows 7 Professional, Windows XP, Windows Server 2003, or Windows Server 2008 instead.

- **This feature will be installed on local hard drive**—installs the component.
- **This feature, and all subfeatures, will be installed on local hard drive**—installs the entire feature.
- **This feature will not be available**—does not install the feature.

Starting from FactoryTalk View 6.1, FactoryTalk View uses SQL Server for the HMI tag database. Microsoft® SQL Server® 2008 R2 will be automatically installed on the computer, when you install FactoryTalk View Studio or HMI server on your computer. An instance named ‘FTVIEWx64TagDB’ is created to store all the FactoryTalk View SE HMI tag database records. If for some reason the instance is deleted, you need to recreate the instance manually, see **“”on page.
To finish installing FactoryTalk View SE

1. After the FactoryTalk View SE software finishes installing, the Wizard Completed window opens.

2. Aside from FactoryTalk Activation, select any or all of the following options, and then click Finish:

   - **Install FactoryTalk Activation**
     Starting from FactoryTalk View 6.1, FactoryTalk Activation is the only software that allows you to activate Rockwell Software. By default, FactoryTalk Activation will be installed on your computer after installing FactoryTalk View.

   - **Launch Release Notes**
     Select this check box if you want the FactoryTalk View Site Edition Release Notes to open after you click Finish.

   - **Specify FactoryTalk Directory server location**
     Select this check box if you want to specify the location of FactoryTalk Network Directory on the computer. After you click Finish, the FactoryTalk Directory Server Location Utility will run.

     If the computer will host the FactoryTalk Directory, select the location **This computer**; if the computer is remote from the FactoryTalk Directory, click the Browse button to find and select the directory location.

     All client and server computers participating in the same FactoryTalk View SE network application must point at the same FactoryTalk Network Directory.
3. Restart the computer.

You can wait to restart the computer, if you want to install RSLinx Enterprise or RSLinx Classic first; however, you must restart before running FactoryTalk View SE.

How to install or upgrade FactoryTalk Activation


You can also install FactoryTalk Activation manually, after FactoryTalk View Site Edition has been installed. See “To install FactoryTalk Activation manually” on page 60.

Upgrading FactoryTalk Activation

To use borrowed activations, you must upgrade to FactoryTalk Activation version 3.02 or later (included on any FactoryTalk CPR 9 SR 2 product’s DVD) on all server and client computers where the borrowed activations will be used.

1. Click Start > Control Panel.
2. In Control Panel, do one of the following:
   - For Windows XP, or Windows Server 2003, click Add or remove Programs.
   - For Windows 7 Professional, Windows Vista or Windows Server 2008, under Programs, click Uninstall a program.
3. In the list of installed programs, right-click FactoryTalk Activation Server or FactoryTalk Activation Client, and then click Uninstall on the context menu.
4. Follow the steps in the wizard to uninstall the software.
5. Install the new version manually. See “To install FactoryTalk Activation manually” on page 60.

How to install RSLinx Enterprise

The FactoryTalk View Site Edition DVD includes programs for installing RSLinx Enterprise and RSLinx Classic communications software.

For the sample application described in Chapter 7, Upgrading FactoryTalk View Site Edition, RSLinx Enterprise is installed on computers running the primary and secondary data servers.
For information about choosing to install RSLinx Classic, see “When to use RSLinx Classic” on page 52.

You must install RSLinx Enterprise on engineering workstations running FactoryTalk View Studio, even if the data servers in the application will run on remote computers.

To install RSLinx Enterprise

1. If necessary, close all open Windows programs, and then place the FactoryTalk View Site Edition DVD in the computer’s DVD drive.

   If the DVD does not start automatically, run D:\setup.exe, where D is the drive containing the DVD.

2. Click **Install FactoryTalk View Site Edition** (the second option).

3. Click step 5, **Install RSLinx Enterprise (optional)**.

4. Follow the instructions in the Welcome, License Agreement, Customer Information, and Setup Type windows.

5. Click Install, to install **RSLinx Enterprise**.

How to install any necessary product updates

After installing FactoryTalk View SE, search the Rockwell Automation Knowledgebase for Patch TOCs for software products on the FactoryTalk View Site Edition DVD.

A Patch TOC describes updates released for a particular product and version, and provides instructions for downloading and installing the updates on computers where the software is installed

Each product you installed, including FactoryTalk View SE, FactoryTalk Services Platform, FactoryTalk Alarms and Events, RSLinx Enterprise, and RSLinx Classic, will have its own, version-specific Patch TOCs.

To find Patch TOCs in the Rockwell Automation Knowledgebase

1. In your Web browser’s Address bar, type [www.rockwellautomation.com](http://www.rockwellautomation.com), and then press Enter.

2. On the right side of the Rockwell Automation home page, under Resources, click **Knowledgebase**.

3. Under **Online Support** tab, click **Knowledgebase** link.

4. In the Knowledgebase Home page, click **Search Answers** tab.
5. In the Search Answers page, from the list **Refine by Product**, select a product category. For example, to find Patch TOCs for FactoryTalk View, first select **Software**, then in the list **All Subs**, select **Performance and Visualization (HMI)**.

6. From the list **All Subs**, select a product name. For example, select FactoryTalk View SE.

7. Click **Advanced Search** from the list **Search Type**, select **Phrases**, if it is not the default.

8. In the text box above the Refine by Product, type **Patch TOC**.

9. Click **Search**.

In the search results, look for Patch TOCs related to all the products you installed from the FactoryTalk View Site Edition DVD. If necessary, conduct a subsequent search for a specific product category and name.
Index

Symbols
.cli files 85, 87, 95, 96
.NET software
installing 133

A
about
activation keys 69
Application Documenter 8
Application Manager 8
DeskLock 8
Diagnostics Viewer 9
FactoryTalk Activation 5, 55
FactoryTalk Administration Console 7
FactoryTalk Alarms and Events 5, 42
FactoryTalk Diagnostics 7
FactoryTalk Directory 6
FactoryTalk Directory Configuration Wizard 9
FactoryTalk Live Data 7
FactoryTalk Security 7
FactoryTalk Services Platform 3, 6
FactoryTalk View SE Client 4
FactoryTalk View SE Secure Web Site Setup 8
FactoryTalk View SE Server 4
FactoryTalk View Site Edition 1, 3
FactoryTalk View Studio 3
HMI Server Backup and Restore utility 8
HMI servers 4, 94
Host ID 58
Import RSSecurity Configuration 9
Installation Assistant 43
Log On to FactoryTalk 9
ME Firmware Upgrade Wizard 8
Rockwell Automation Knowledgebase 12
Rockwell Software Data Client 9
RSLinx Classic 5
RSLinx Enterprise 5
RSSecurity Emulator Install 9
RSView Enterprise 1
SE Administration Console 8
SE HMI Tag Alarm Log Setup 9
SE HMI Tag Alarm Log Viewer 9
SE Service Manager 9
Specify FactoryTalk Directory Location 9
Tag Import and Export Wizard 9
tools and utilities 7, 9
Transfer Tool 8
user’s guides 11
Windows Firewall Configuration Utility 9

Adobe Reader. See Acrobat
activating 55
See also FactoryTalk Activation
about keys 69
activation types 55
adding activation files 60
borrowed activation files 65, 67, 138
floating activation files 63, 70
grace period 57
Host ID 58
locating Activation Certificate 47
moving activation files 61
protecting activations 62
read-write keys 70
sharing keys 70
specifying activation server 63
troubleshooting 57, 64
view-only keys 70

activation files
See also activation keys
See also activation types
adding 60
borrowed 67
borrowing as System user 67
floating 63, 70
moving 61
protecting 62
read-write 70
specifying server 63
hosting on Windows Vista 18, 20, 28, 32, 46, 48, 57, 69, 77, 110, 123, 124, 127, 131, 134, 136
redundancy 125, 126
restoring 110
restoring local 90
restoring network 77
run-time clients 85, 94
testing 119
troubleshooting 87, 109
upgrading 100, 101, 125, 126, 127
upgrading non-redundant 101
upgrading redundant 100
upgrading run-time clients 116, 120
upgrading run-time servers 120, 121
architectures
applications 15
redundancy 18
archive files
names and extensions 78, 110, 123, 124
automatic updates
stopping in Windows 22
auto-negotiation
of NIC for unmanaged switches 25

B

backing up and restoring
archive files 78, 110, 123, 124
data servers 79, 91
local applications 90
Local Directory 91
naming computers 81, 82, 93
network applications 74, 77
renewing shortcuts, topics, and device paths 81, 116
RSLinx Classic Backup Restore Utility 80, 92
RSLinx Enterprise 75, 79, 91
servers 109, 111, 112, 122, 123
System folder 74, 78, 91, 105, 124
troubleshooting 111
upgrading 104
Borrow as System user for services check box 67
borrowed concurrent activations 56

C

caching
  in Internet Explorer 35
checklists
  activating FactoryTalk View SE 58
  deploying local applications 89
  deploying network applications 73
  installing FactoryTalk View SE 43
  setting up application computers 17
  upgrading redundant applications 100
clients
  See also FactoryTalk View SE Client
  See also FactoryTalk View Studio
  copying files 85, 86
  logging off 88, 96
  logging on 88, 96
  run-time 85, 94
  shutting down for upgrade 108
  starting at run-time 87, 96
  troubleshooting 87
  upgrading 116, 120
  using floating activations 70
clocks
  synchronizing time 23
compatibility
  Windows 22
components
  choosing which ones to install 41
  installing 41
computer names 23
  data servers 81, 93
  HMI servers 82
  troubleshooting 23
computers
  naming 23, 81, 82, 93
  synchronizing time 23
  troubleshooting naming 23
concurrent activations 55, 56

D

Data Execution Prevention (DEP)
  setting up 37
data servers
  backing up and restoring RSLinx Classic 80, 92
  installing 45, 52
  moving files 79, 91
  redundancy 127
  renewing shortcuts, topics, and device paths 81, 116
  RSLinx Enterprise 79, 91
  troubleshooting loading 93
DCOM protocols
  removing unnecessary 26
  troubleshooting 28
DEP. See Data Execution Prevention
deploying local applications 89
  backing up 90
  backing up the Local Directory 91
  creating new client files 95
  moving RSLinx Classic files 92
  moving RSLinx Enterprise files 91
  restoring 90
  restoring the Local Directory 91
  starting or stopping HMI servers 93
  updating data server names 81
deploying network applications 73
  backing up 74
  changing HMI server properties 83
  copying client files 85, 86
  creating new client files 85
  moving RSLinx Enterprise files 79
  restoring 77
  synchronizing HMI servers with projects 84
  updating data server names 82
DeskLock 8, 86, 96
device paths
  backing up and restoring RSLinx Enterprise 75
  renewing after backup and restore 81, 116
Diagnostics Viewer 9
  disk space
    ensuring sufficient 36
  documentation 2, 11
    See also finding information
  FactoryTalk 7
  FactoryTalk Alarms and Events 5
  FactoryTalk Security 73
  FactoryTalk View SE 2, 11
  opening online 44
  domains
    controller requirements 22
    design considerations 22
    setting up 22
  downtime
    using scheduled for upgrades 108
  duplex
    setting up for NIC 25

E
  engineering workstations
    hardware requirements 19
    upgrading 113

F
  FactoryTalk Activation 5, 55
    about activation keys 69
    activation types 55
    adding activation files 60
    borrowed activation files 67
    borrowed concurrent activations 56
    file locations 51
    floating activation files 63, 70
    floating concurrent activations 55
    grace period 57
    Host ID 58
    local node-locked activations 55
    locating Activation Certificate 47
    mobile node-locked activations 55
    moving activation files 61
    online Help 56
    protecting activation files 62
    read-write keys 70
    shared concurrent activations 55
    sharing activation keys 70
    specifying activation server 63
    tools and utilities 9
    troubleshooting 57, 64
    upgrading for borrowed activation files 65, 138
    view-only keys 70
  FactoryTalk Administration Console 7
    See also SE Administration Console
  FactoryTalk Alarms and Events 5, 42
    hardware requirements 19
    release notes 5
    System Configuration Guide 5
    uninstalling 5, 42
  FactoryTalk Diagnostics 7
  FactoryTalk Diagnostics Viewer 112, 119, 129
  FactoryTalk Directory 4, 6
  FactoryTalk Directory Configuration Wizard 9
  FactoryTalk Live Data 7
  FactoryTalk Security 7
    See also security
    System Configuration Guide 73
  FactoryTalk Services Platform 3, 6
    FactoryTalk Administration Console 7
    FactoryTalk Diagnostics 7
    FactoryTalk Directory 6
    FactoryTalk Help 7, 102
    FactoryTalk Live Data 7
    FactoryTalk Security 7
    installing 45, 133, 134
  FactoryTalk tools and utilities 9
    See also tools and utilities
  FactoryTalk View Machine Edition
    using FactoryTalk View Studio 3
  FactoryTalk View SE Client 4
    copying client files 86
    creating new client files 85, 95
    file locations 86, 96
    logging off 88, 96
    logging on 88, 96
    setting up security 86, 95
starting 87, 96
starting from View Studio 87, 96
starting when Windows starts 87, 96
using .cli file 87
FactoryTalk View SE Secure Web Site Setup 8
FactoryTalk View SE Server 4
See also HMI servers
See also servers
FactoryTalk View Site Edition 1, 3
documentation set 2
file locations 51
installing 41, 46
release notes 2
tools and utilities 7
uninstalling 132
upgrading 99, 131
See also finding information
FactoryTalk View Studio 3
fast user switching
turning off 23
file locations 51
See also folders
FactoryTalk Activation 51
FactoryTalk View SE 51
HMI project files 36, 77
SE Client files 86, 96
tools and utilities 51
finding information 10
about FactoryTalk 7, 102
about FactoryTalk View SE 2
on the Internet 12
technical support 12
firewalls
third-party incompatible 27
floating concurrent activations 55
folders
See also file locations
FactoryTalk Activation 51
FactoryTalk Tools 51
FactoryTalk View 51
FactoryTalk View SE program files 51
HMI project files 36, 77
SE Client files 86, 96
G
grace period
activating FactoryTalk View SE 57
H
hardware requirements 18
application servers 19
engineering workstations 19
FactoryTalk Alarms and Events 19
operator workstations 19
Help. See online Help
HMI Server Backup and Restore utility 8, 76, 104, 110, 122, 124
archive file names 78, 110, 123, 124
HMI servers 4, 94
backing up 76
hosting on Windows Vista 18, 20, 28, 32, 46, 48, 57, 69, 77, 110, 123, 124, 127, 131, 134, 136
restoring 110
setting up properties 83
starting or stopping 83, 94, 132
synchronizing with projects 84
troubleshooting loading 82
Host ID 58
for FactoryTalk Activation 58
I
IIS. See Internet Information Services
Import RSSecurity Configuration 9
incompatible firewalls 27
Installation Assistant 43
installation guide
See also finding information
opening online 44
installing
See also upgrading
.NET software 133
about Installation Assistant 43
FACTORYTALK VIEW SITE EDITION INSTALLATION GUIDE

Adobe Reader 44
choosing components 41
complete 46
components 41
data servers 45, 52
FactoryTalk Services Platform 45, 133, 134
FactoryTalk View SE 41
FactoryTalk View Site Edition 46
logging on as administrator 44
overview 42
planning 132
product updates 54, 139
RSLinx Classic 51
RSLinx Enterprise 51, 138
selected components 46
troubleshooting 5, 42, 44, 52
uninstalling 132
upgrading 99, 131
where to install software 22

Internet Explorer
caching 35
removing enhanced security configuration 38
setting up 35
turning off Work Offline 35

Internet Information Services (IIS)
configuring 28
uninstalling 35

Internet technical support 12
See also finding information 12

K
Kepware
installing FactoryTalk Services Platform with 45
supported versions 12, 45
technical support 12

keys
FactoryTalk Activation 69
sharing for FactoryTalk Activation 70
knowledgebase 12, 16, 21, 22, 28, 54, 139
See also finding information

L
loading
data servers 93
HMI servers 82
local applications
See also applications
See also deploying local applications
administering at run time 97
run-time clients 94
security 95
Local Directory
restoring 91
local node-locked activations 55
localhost
specifying as Network Directory 76
Log On to FactoryTalk 9
logging off
at run time 88, 96
logging on
at run time 88, 96

M
manuals. See online manuals
ME Firmware Upgrade Wizard 8
mobile node-locked activations 55
moving files
See also deploying local applications
See also deploying network applications
data servers 79, 81, 91, 93

N
naming
backup archives 78, 110, 123, 124
customers 23, 81, 82, 93
data server computers 81, 93
HMI server computers 82
troubleshooting computer names 23
network applications
administering at run time 88
hosting on Windows Vista 18, 20, 28, 32, 46, 48, 57, 69, 77, 110, 123, 124, 127, 131, 134, 136
run-time clients 85
security 86
troubleshooting 87
network connections
establishing 27
testing to Network Directory 27
Network Directory
setting up on clients and servers 51
setting up server on local computer 50
specifying location 50, 79, 109, 117, 118
testing connection to 27
using localhost 76
network interface cards (NIC)
disabling power saving 26
duplex 25
troubleshooting 24
network switches
troubleshooting 24
networks
establishing connections 27
removing unnecessary DCOM protocols 26
NIC. See network interface cards
node-locked activations 55

O
OLE for Process Control (OPC)
renaming data servers 93
using for communications 6
online Help 2, 10
See also finding information
FactoryTalk Activation 56
FactoryTalk Services Platform 7, 102
FactoryTalk View SE 2
index 10
release notes 2, 102
online manuals 11
See also finding information
FactoryTalk View SE 2
OPC. See OLE for Process Control
operating systems
requirements 20
upgrading 21
operator workstations
hardware requirements 19
upgrading 116, 120
overview
activating FactoryTalk View SE 57
deploying local applications 89
deploying network applications 73
installing 42
upgrading redundant applications 100

P
Patch TOCs. See product updates
ports
troubleshooting on network switches 24
power saving
disabling for NIC 26
product updates
installing 54, 139
program files
locations of FactoryTalk View SE folders 51
project files
backing up and restoring 76, 110
folder locations 36, 77, 86, 96

R
redundancy
architectural assistance 18
disabling for upgrade 108
operating system requirements 21
replicating changes 84, 128
servers 109, 111, 112, 122, 123
synchronizing servers and projects 84
troubleshooting 83, 84
upgrading 125, 126, 127
release notes 2, 102
See also finding information
FactoryTalk Alarms and Events 5
FactoryTalk View SE 2
replication
of redundant servers 84, 128
restoring network applications 77
Rockwell Automation Knowledgebase 12, 16, 21, 22,
FACTORYTALK VIEW SITE EDITION INSTALLATION GUIDE

28, 54, 139
  See also finding information
Rockwell Automation Literature Library 2, 16
  See also finding information
Rockwell Software
  See also finding information
contacting 12
Rockwell Software Data Client 9
RSLinx Classic 5
  Backup Restore Utility 80, 92
  installing 51
  when to use 52
RSLinx Enterprise 5
  backing up and restoring device paths 75
  installing 51, 138
  troubleshooting installing 52
  upgrading 138
RSSecurity Emulator Install 9
RSView. See FactoryTalk View Site Edition
RSView Administration Console. See SE Administration Console
RSView Enterprise 1
  See also FactoryTalk View Site Edition
  uninstalling 132
  upgrading to FactoryTalk View Site Edition 100
RSView SE Client 4
RSView SE Server 4
run time
  locations of SE Client files 86, 96
  setting up FactoryTalk View SE Clients 85

S
scheduled downtime
  using for upgrades 108
SE Administration Console 8
  See also FactoryTalk Administration Console
SE HMI Tag Alarm Log Setup 9
SE HMI Tag Alarm Log Viewer 9
SE Service Manager 9
security
  See also FactoryTalk Security
DeskLock tool 86, 96
locking users into FactoryTalk View 86, 95
logging off 88, 96
logging off at run time 88, 96
logging on 88, 96
logging on at run time 88, 96
removing enhanced in Internet Explorer 38
serial number
  locating 47
servers
  backing up and restoring 109, 111, 112, 122, 123
  checking status 128
  disabling redundancy for upgrade 108
  FactoryTalk Activation 63
  hardware requirements for applications 19
  loading 82, 93
  operating system requirements for applications 21
  redundancy 109, 111, 112, 122, 123, 128
  replication 84, 128
  synchronizing redundant 84
  upgrading 109, 111, 112, 120, 121, 122, 123
  verifying running 112, 119, 129
service packs
  Windows compatibility 21, 22
setting up. See installing
shared concurrent activations 55
sharing activation keys 70
shortcuts
  renewing after backup and restore 81, 116
simple file sharing
  turning off 23
Specify FactoryTalk Directory Location 9, 50, 76, 79, 109, 117, 118
status
  checking redundant servers 128
support. See technical support
switches
  using unmanaged 25
synchronizing
  redundant servers 84
  time on computers 23
  troubleshooting redundancy 84
System Configuration Guide
for FactoryTalk Alarms and Events 5
for FactoryTalk Security 73
System folder
backing up 74, 105
restoring 78, 91, 124
System requirements
application servers 19, 21
domain controllers 22
engineering workstations 19
hardware 18
operating systems 20
operator workstations 19
redundancy 21
workgroups 22
System user
borrowing activations 67
Tag Import and Export Wizard 9
testing
upgraded applications 119
third-party firewalls
incompatible 27
time
synchronizing on computers 23
using scheduled downtime for upgrades 108
tools and utilities 7, 9
Alarm Log Setup 9
Alarm Log Viewer 9
Application Documenter 8
Application Manager 8, 90
DeskLock 8, 86, 96
Diagnostics Viewer 9
FactoryTalk 9
FactoryTalk Activation 9
FactoryTalk Directory Configuration Wizard 9
FactoryTalk View SE 7
FactoryTalk View SE Secure Web Site Setup 8
file locations 51
HMI Server Backup and Restore 8, 76, 110
Import RSSecurity Configuration 9
Log On to FactoryTalk 9
ME Firmware Upgrade Wizard 8
Rockwell Software Data Client 9
RSSecurity Emulator Install 9
SE Administration Console 8
SE HMI Tag Alarm Log Setup 9
SE HMI Tag Alarm Log Viewer 9
SE Service Manager 9
Specify FactoryTalk Directory Location 9, 50, 76,
79, 109, 117, 118
Tag Import and Export Wizard 9
Transfer Tool 8
Windows Firewall Configuration Utility 9
Topics
renewing after backup and restore 81, 116
topology
where to install software 22
transfer tool
FactoryTalk Activation 8
troubleshooting
Add or Remove Programs 132
applications 87, 109
backing up and restoring 111
clients 87
data servers 93
DCOM 28
FactoryTalk Activation 57
HMI servers 82
installing 5, 42, 44, 52
network applications 87
network interface cards (NIC) 24
network switches 24
redundancy 83, 84
uninstalling 132
upgrading 109
uninstalling
  dependencies 133
  FactoryTalk View SE 132
  older versions of RSView 132
  RSView Enterprise 132
  troubleshooting 132
unmanaged switches
  auto-negotiation 25
  using 25
updates
  See also product updates
  stopping automatic in Windows 22
upgrading 99, 131
  backing up and restoring 104
  disabling redundancy 108
  from RSView Enterprise to FactoryTalk View 100
  information to help with 100
  installing product updates 139
  non-redundant applications 101
  operating systems 21
  planning 102, 132
  RSLinx Enterprise 138
  run-time clients 116, 120
  servers 109, 111, 112, 120, 121, 122, 123
  shutting down all clients 108
  testing applications 119
  troubleshooting 109
  using scheduled downtime 108
  workstations 113, 116, 120
user switching
  turning off in Windows 23
user’s guides 2, 11
  See also finding information
  FactoryTalk View SE 2
virtual directories
  recreating in IIS 35
WebDAV
  installing for Windows Server 2008 32
Windows
  compatibility 22
  file locations 36, 77, 96
  firewall 27
  installing WebDAV for Windows Server 2008 32
  service pack compatibility 21
  service packs 22
  settings for Windows Server 2003 and Windows Server 2008 38
  starting SE Client with Windows 87, 96
  stopping automatic updates 22
  turning off fast user switching 23
  turning off simple file sharing 23
  using early versions of 28
Windows Firewall Configuration Utility 9
Windows Vista
  cautions for using 18, 20, 28, 32, 46, 48, 57, 69, 77, 110, 123, 124, 127, 131, 134, 136
Work Offline
  turning off in Internet Explorer 35
workgroups
  design considerations 22
  setting up 22
  system requirements 22
workstations
  See also engineering workstations
  See also operator workstations
  upgrading 113, 116, 120