Contents

Introduction 1

Purpose of the document ................................................................. 1
Intended audience .............................................................................. 1
How does the getting results guide fit in with other Rockwell Software product documentation? .............................................. 1
Online help ......................................................................................... 1
Document conventions ....................................................................... 2
Feedback ............................................................................................ 2

1 • Welcome to RSLinx Classic 3

What is RSLinx Classic? ................................................................. 3
Differences between RSLinx Classic types ........................................ 3
RSLinx Classic Lite .......................................................................... 3
RSLinx Classic Single Node ........................................................... 4
RSLinx Classic OEM ......................................................................... 4
RSLinx Classic Professional ........................................................... 5
RSLinx Classic Gateway ................................................................... 5
RSLinx Classic SDK ......................................................................... 6
RSLinx Classic for RSView ............................................................... 6
Quick start ......................................................................................... 7
Step 1 – Configure a driver .............................................................. 7
Step 2 – Configure a topic ............................................................... 8
Step 3 – Copy a link to the clipboard ............................................... 9
Step 4 – Paste a link from the clipboard ......................................... 10
Exploring RSLinx Classic .............................................................. 10
Title bar ............................................................................................ 10
Menu bar ........................................................................................... 11
Toolbar .............................................................................................. 12
Application workspace ...................................................................... 13
Status bar ........................................................................................ 13

2 • Installing and Starting RSLinx Classic 15

Before you begin .............................................................................. 15
System requirements ....................................................................... 15
Hardware requirements ................................................................... 15
Software requirements ................................................................... 16
<table>
<thead>
<tr>
<th>Section</th>
<th>Title</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Installing RSLinx Classic software</td>
<td>16</td>
</tr>
<tr>
<td>1</td>
<td>Updating an existing installation</td>
<td>17</td>
</tr>
<tr>
<td>1</td>
<td>Starting RSLinx Classic software</td>
<td>18</td>
</tr>
<tr>
<td>1</td>
<td>Troubleshooting installation</td>
<td>18</td>
</tr>
<tr>
<td>3</td>
<td>Using RSWho</td>
<td>19</td>
</tr>
<tr>
<td>3</td>
<td>RSWho browsing</td>
<td>20</td>
</tr>
<tr>
<td>4</td>
<td>OLE for Process Control (OPC)</td>
<td>21</td>
</tr>
<tr>
<td>4</td>
<td>Dynamic Data Exchange (DDE)</td>
<td>22</td>
</tr>
<tr>
<td>4</td>
<td>DDE/OPC client connectivity</td>
<td>23</td>
</tr>
<tr>
<td>5</td>
<td>Accessing help for a control or field</td>
<td>26</td>
</tr>
<tr>
<td>5</td>
<td>Finding step-by-step procedures</td>
<td>27</td>
</tr>
<tr>
<td>5</td>
<td>Finding definitions</td>
<td>28</td>
</tr>
<tr>
<td>5</td>
<td>Using RSLinx Classic Assistance Central</td>
<td>29</td>
</tr>
<tr>
<td>5</td>
<td>Accessing online guides</td>
<td>29</td>
</tr>
<tr>
<td>5</td>
<td>Training</td>
<td>29</td>
</tr>
<tr>
<td>5</td>
<td>Technical support</td>
<td>29</td>
</tr>
<tr>
<td>5</td>
<td>When you call</td>
<td>30</td>
</tr>
<tr>
<td>A</td>
<td>Activate RSLinx Classic with FactoryTalk Activation</td>
<td>31</td>
</tr>
<tr>
<td>A</td>
<td>How to activate RSLinx Classic</td>
<td>31</td>
</tr>
<tr>
<td>A</td>
<td>Some common questions</td>
<td>32</td>
</tr>
<tr>
<td>A</td>
<td>What is an “activation file?”</td>
<td>32</td>
</tr>
<tr>
<td>A</td>
<td>What is a &quot;Host ID&quot;?</td>
<td>32</td>
</tr>
<tr>
<td>A</td>
<td>What is a &quot;node-locked&quot; activation?</td>
<td>32</td>
</tr>
<tr>
<td>A</td>
<td>How do I get a local, node-locked activation file and activate my software?</td>
<td>32</td>
</tr>
<tr>
<td>A</td>
<td>How do I get a mobile node-locked activation file and activate my software?</td>
<td>32</td>
</tr>
<tr>
<td>A</td>
<td>What if I don't have Internet access on my computer?</td>
<td>33</td>
</tr>
<tr>
<td>A</td>
<td>What if I don’t have Internet access on many computers? Do I have to get activations for them one at a time?</td>
<td>34</td>
</tr>
</tbody>
</table>
CONTENTS

Finding more information about activation ........................................ 35
Activate RSLinx Classic with EVRSI ................................................. 36
How to activate RSLinx Classic .......................................................... 36
Protecting your activation files .......................................................... 37
Running the activation utilities ........................................................... 38
Some common questions ................................................................. 38
  My activation files were damaged. What should I do? ...................... 38
  I accidentally deleted the software directory on my hard drive. Do I
  need to call Rockwell Software for replacement activation files? ....... 38
  Why can’t I move activation to a new floppy disk
  on a Windows NT system? ......................................................... 39
Finding more information about activation ........................................ 39

B • Secure RSLinx Classic with RSAssetSecurity 41

  How do I set up security in RSLinx Classic? .................................. 41
  What can I secure in RSLinx Classic? ........................................... 47
  Considerations when using RSLinx Classic with RSAssetSecurity ...... 48
    Network/Local Directory ......................................................... 48
    Reset Network Tree .................................................................. 49
    Miscellaneous ......................................................................... 49

Glossary 51
Index 53
Introduction

Purpose of the document

The *Getting Results with RSLinx Classic™* guide provides you with information on how to install and navigate the RSLinx Classic software. It explains how to access and navigate the online help, and how to effectively use the RSLinx Classic software.

Intended audience

We assume that you are familiar with:
- IBM-compliant personal computers
- Microsoft® Windows® operating systems
- OLE for Process Control® (OPC) communication
- Microsoft dynamic data exchange (DDE) messaging
- Allen-Bradley programmable logic controllers (PLC™)
- Rockwell Software’s PLC programming tools

How does the getting results guide fit in with other Rockwell Software product documentation?

This getting results guide can be considered the entry point into Rockwell Software’s documentation set for this product. The documentation set contains pertinent, easily accessible product information and ships with the software product. This set ships with the software product, and is designed to free you from tedious paper shuffling and reduce information overload.

Other components of the documentation set include electronic release notes and online help.

Online help

The online help includes all overview, procedural, screen, and reference information for the product. The help contains these basic components: overview topics, quick start topics, step-by-step procedures, and screen element descriptions (for example, text boxes, drop-down lists, and option buttons). All of the help is context-sensitive with the application and provides you with immediate access to application tasks and screen element descriptions. Refer to the “Finding the information you need” chapter in this guide for a more detailed description of the online help.

*Note: This getting results guide, as well as any reference guides, are included in a portable document format (PDF) on your RSLinx Classic CD. These files must be viewed using the Adobe*
Acrobat Reader software, which you can download for free from the Adobe website (www.adobe.com).

Document conventions

The conventions used throughout this document for the user interface comply with those recommended by Microsoft. If you are not familiar with the Microsoft Windows user interface, we recommend that you read the documentation supplied with the operating system you are using before attempting to use this software.

Feedback

Please use the feedback form packaged with your software to report errors or let us know what information you would like to see added in future editions of this document. You can also send an email message to info@software.rockwell.com with any comments about Rockwell’s products and services.
Welcome to RSLinx Classic

This chapter includes the following information:

- What is RSLinx Classic?
- Differences between RSLinx Classic types
- Quick start
- Exploring RSLinx Classic

What is RSLinx Classic?

RSLinx Classic for Rockwell Automation Networks and Devices is a comprehensive factory communications solution for the Microsoft Windows XP™, Windows 2000™, Windows Me™, Windows 98™, Windows NT™, and Windows 2003™ operating systems. It provides Allen-Bradley programmable controller access to a wide variety of Rockwell Software and Allen-Bradley applications. These range from device programming and configuration applications such as RSLogix and RSNetWorx, to HMI (Human-Machine Interface) applications such as RSView32, to your own data acquisition applications using Microsoft Office, web pages, or Visual Basic®. RSLinx Classic also incorporates advanced data optimization techniques and contains a set of diagnostics. Its Application Programming Interface (API) supports custom applications developed with the RSLinx Classic SDK. RSLinx Classic is an OPC Data Access Compliant Server and a DDE server.

Differences between RSLinx Classic types

RSLinx Classic is available in seven versions to meet the demand for a variety of cost and functionality requirements. Depending on the version you are running, some functionality may or may not be operational. Refer to the following sections for specific version functionality.

The RSLinx Classic version you are running appears in the title bar at the top of the main window. If a version of RSLinx Classic is installed without the proper activation files, your installation reverts to RSLinx Classic Lite.

RSLinx Classic Lite

RSLinx Classic Lite provides the minimum functionality required to support RSLogix and RSNetWorx. This version is not commercially available, but is bundled with products that require only direct access to the RSLinx Classic network drivers. This version does not support OPC, DDE, or the published RSLinx Classic C Application Programming Interface (API).
RSLinx Classic Lite is used for the following:

- Ladder logic programming using RSLogix products.
- Network and device configuration and diagnostics using RSNetWorx.
- Configuring 1756-ENET, 1756-DHRIO, and 1757-SRM modules.
- Upgrading firmware using ControlFlash.
- Browsing networks and getting device information such as firmware revision.

**RSLinx Classic Single Node**

RSLinx Classic Single Node includes the required functionality to supply communications services for all Rockwell Software products. OPC and DDE interfaces are supported, but to only one device. It does not support applications developed for the RSLinx Classic C Application Programming Interface (API) or direct drivers in HMI applications. RSLinx Classic OEM or higher is required for these application types.

RSLinx Classic Single Node is used for the following:

- Data acquisition using OPC or DDE to only one device. This includes clients such as RSView32, Microsoft Office, Visual Basic, and web pages.
- Ladder logic programming using RSLogix products.
- Network and device configuration and diagnostics using RSNetWorx.
- Configuring 1756-ENET, 1756-DHRIO, and 1757-SRM modules.
- Upgrading firmware using ControlFlash.
- Browsing networks and getting device information such as firmware revision.

**RSLinx Classic OEM**

RSLinx Classic OEM includes the required functionality to supply communications services for all Rockwell Software products. OPC and DDE clients are supported for any number of devices. It also supports applications developed for the RSLinx Classic C Application Programming Interface (API).

RSLinx OEM Versions 2.2 and previous versions only supported AdvancedDDE. RSLinx Version 2.3 and subsequent versions support all DDE types except FastDDE.

RSLinx Classic OEM is used for the following:

- Data acquisition using OPC or DDE to any number of devices. This includes clients such as RSView32, Microsoft Office, Visual Basic, and web pages.
- Ladder logic programming using RSLogix products.
- Network and device configuration and diagnostics using RSNetWorx.
- Configuring 1756-ENET, 1756-DHRIO, and 1757-SRM modules.
- Upgrading firmware using ControlFlash.
- Browsing networks and getting device information such as firmware revision.
RSLinx Classic Professional

RSLinx Classic Professional includes the required functionality to supply communications services for all Rockwell Software products. OPC and DDE clients are supported for any number of devices. It also supports applications developed for the RSLinx Classic C Application Programming Interface (API). Additionally, RSLinx Classic Professional contains a data monitor for PLC, SLC, and ControlLogix-based controllers and a ladder logic viewer for PLC and SLC based controllers. RSLinx Classic Professional is great for maintenance and diagnostics -- you can access your data and ladder logic within RSLinx Classic.

RSLinx Classic Professional is used for the following:

- Monitoring PLC, SLC, or ControlLogix data directly in RSLinx Classic.
- Monitoring ladder logic of PLC or SLC family processors directly in RSLinx Classic.
- Data acquisition using local OPC or DDE to any number of devices. This includes clients such as RSView32, Microsoft Office, Visual Basic, and Web pages.
- Communicating with applications via RSLinx Classic’s C-API.
- Ladder logic programming using RSLogix products.
- Network and device configuration and diagnostics using RSNetWorx.
- Configuring 1756-ENET, 1756-DHRIO, and 1757-SRM modules.
- Upgrading firmware using ControlFlash.

RSLinx Classic Gateway

RSLinx Classic Gateway extends RSLinx Classic-based communications throughout the enterprise by connecting clients over TCP/IP networks. Programming and configuration products such as RSLogix and RSNetWorx use a local RSLinx Classic Lite or better with a Remote Devices via Linx Gateway driver configured to communicate to the RSLinx Classic Gateway. Remote HMIs and VB/VBA applications including Microsoft Office can use remote OPC to communicate to RSLinx Classic Gateway for data collection. This allows you to have multiple distributed computers performing data collection without having RSLinx Classic installed on each machine!

In addition to the capabilities provided in the RSLinx Classic Professional version, RSLinx Classic Gateway offers remote connectivity to:

- Multiple RSView32 clients accessing data through one RSLinx Classic Gateway (remote OPC).
- Remote PC running RSLogix connecting to a plant network over a modem for online program changes.
- Remote Microsoft Office applications displaying plant floor data such as Excel.
- A web page displaying plant floor data when the web server and RSLinx Classic are on separate computers.
**RSLinx Classic SDK**

RSLinx Classic Software Development Kit (SDK) includes documentation and technical support for developing OPC or C-API clients to RSLinx Classic. OPC clients are developed for data acquisition, while C-API clients are typically used for device configuration. A copy of RSLinx Classic OEM is also supplied with RSLinx Classic SDK.

When developing OPC clients to RSLinx Classic, you can use the automation interface or the custom interface supplied with the SDK. The OPC Automation Interface is used for creating OPC clients out of Microsoft Office, Visual Basic, and web pages. The OPC Custom Interface is for use with developing C++ applications.

RSLinx Classic SDK is used to:

- Develop a VB/VBA client using the OPC Automation Interface. With the SDK, you receive documentation on how to use Automation Interface, development support, and samples.
- Develop a C/C++ client using the OPC Custom Interface.
- Develop a client using RSLinx Classic’s C-API by providing access to libraries and documentation.
- Build solutions using RSLinx Classic, which makes it a great resource for OEMs.
- Develop .NET OPC client application using the .NET OPC interface. (Note: OPC Browse is not supported for .NET OPC applications.)

**RSLinx Classic for RSView**

If RSLinx Classic Lite (no activation present) is installed on a machine that has RSView SE or ME, it uses RSView's license to start as RSLinx Classic for RSView. However, please keep in mind that RSLinx Classic for RSView:

- In addition to supporting RSView SE/ME as OPC clients, supports RSLadder 5/500 and Data Monitor.
- Does not support RSView 32, RSSql, RSTrend, WinView, RSLogix 5/500/5000 and third-party OPC clients.
Quick start

This section outlines the main tasks you will need to perform to use the RSLinx Classic software. The quick start information included in this guide is intended to be a high-level, conceptual overview. When you are ready to use RSLinx Classic software, follow the detailed procedures found in the Quick Start, which is located in the RSLinx Classic online help. To access the online Quick Start, select Help > Quick Start from within RSLinx Classic. For information about specific controls on RSLinx Classic windows and dialog boxes, right-click on any control.

Step 1 – Configure a driver

A driver is the software interface to the hardware device that will be used to communicate between RSLinx Classic and your processor. To configure a driver in RSLinx Classic, select Communications > Configure Drivers. The Configure Drivers dialog box, which is used for adding, editing, or deleting drivers, displays. Select a driver to configure from the Available Driver Types list, click Add New, and complete the information required in the driver configuration dialog box that displays. The driver configuration dialog box varies depending on which driver you select.

After you complete the driver configuration, the driver name will appear in the Configured Drivers list.
Step 2 – Configure a topic

In RSLinx Classic, a project is a storage container for one or more topics, and a topic represents a specific path to a processor. By grouping topics together in a project, you can make multiple topics available at the same time. Projects are created and edited in RSLinx Classic via the Open Project window, and topics are created and edited via the DDE/OPC Topic Configuration window. If you attempt to create a topic without creating a project, a default project is created for you.

If you selected Configure New DDE/OPC Topic by right-clicking on a station in RSWho, the Topic Name field is pre-filled for you. RSLinx Classic starts with the name of the program running in the processor, and if this topic exists, it adds a number to the end until it finds one that does not exist. If there are any spaces, it converts them to _’s. You can change the topic name RSLinx Classic selected for you.

From the Data Source tab, select the device with which you wish to set up communication. To add a new topic to a project that already has at least one topic configured, click New. To edit an existing topic, select the topic from the list. Use the Data Collection tab to include more detailed information about specific topics.
Step 3 – Copy a link to the clipboard

RSLinx Classic provides a mechanism for easily establishing a link from RSLinx Classic to a compatible program. It takes the information needed to create a link and places it on the Windows clipboard. Some packages support the ability to paste links from the clipboard. The Copy to Clipboard function can be used with these applications only.

The Copy to Clipboard function only establishes hot links from RSLinx Classic, the DDE server, to a Windows DDE client application. The Data Table Address, Block Size, Columns per Row, and selected topic are maintained from the last time that you used this function. Changing these values will have no effect on the last established link.

To use the Copy to Clipboard function, you must choose an RSLinx Classic project, and the selected project must contain topics.
Step 4 – Paste a link from the clipboard

Most Windows applications support a Paste Link operation, and this feature is generally located in the Edit menu.

Go to your application program that supports the Paste Link function. For example, in Microsoft Excel, click on an open cell in a spreadsheet where you would like to place the data, select Edit > Paste Special, select Paste Link, and click OK. The hot link is pasted into the spreadsheet at the location you selected and begins to update. Note that if you select Paste, instead of Paste Link, the item string will get copied.

Exploring RSLinx Classic

When you start RSLinx Classic, the Rockwell Software RSLinx Classic application window appears. The application window contains a title bar, a menu bar, a tool bar, the application workspace where opened child windows (RSWho, diagnostics, etc.) are displayed, and a status bar.

Title bar

The title bar shows the RSLinx Classic icon, the name of the software product, i.e., Rockwell Software RSLinx Classic Gateway, the RSWho instance number (RSWho - 1 opens by default when you open RSLinx Classic), and the Minimize, Maximize, and Close button.

To view the Control Menu, click the RSLinx Classic icon on the title bar. The following items appear on the Control Menu.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Restore</td>
<td>Restores the window to its former size after you enlarged it by using the Maximize command or shrunk it by using the Minimize command.</td>
</tr>
<tr>
<td>Move</td>
<td>Allows you to reposition the window on the desktop using the arrow keys on the keyboard.</td>
</tr>
<tr>
<td>Size</td>
<td>Allows you to resize the window by using the arrow keys on the keyboard.</td>
</tr>
<tr>
<td>Minimize</td>
<td>Shrinks the window to an icon, which is located on the task bar. This performs the same function as if you clicked the Minimize button on the title bar.</td>
</tr>
</tbody>
</table>
Menu bar

The RSLinx Classic menu bar contains the following menus:

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Maximize</td>
<td>Enlarges the window to occupy the entire screen. This performs the same function as if you clicked the Maximize button on the title bar.</td>
</tr>
<tr>
<td>Close</td>
<td>Exits the RSLinx Classic application. This performs the same function as if you clicked the Close button on the title bar.</td>
</tr>
</tbody>
</table>

Each menu contains options for performing the following tasks:

<table>
<thead>
<tr>
<th>Menu</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>File</td>
<td>Create and open RSLinx Classic projects.</td>
</tr>
<tr>
<td>Edit</td>
<td>Copy DDE and OPC links to the clipboard.</td>
</tr>
<tr>
<td>View</td>
<td>Set and change RSLinx Classic interface displays, open the Event Viewer, and select the RSWho view.</td>
</tr>
<tr>
<td>Communications</td>
<td>Configure drivers, topics, and other RSLinx Classic options, and view driver, DDE, other client application diagnostics.</td>
</tr>
<tr>
<td>Station</td>
<td>Perform actions on diagnostic counters and view the Data Monitor.</td>
</tr>
<tr>
<td>DDE/OPC</td>
<td>Configure DDE/OPC topics and view event and diagnostic information.</td>
</tr>
<tr>
<td>Security</td>
<td>Set security user and access rights.</td>
</tr>
<tr>
<td>Window</td>
<td>Arrange RSLinx Classic windows.</td>
</tr>
<tr>
<td>Help</td>
<td>View help options for RSLinx Classic and other Rockwell Software products and services.</td>
</tr>
</tbody>
</table>
Toolbar

The toolbar contains shortcuts to several commonly used RSLinx Classic functions. Each toolbar button is a graphical representation of a command that is also available from the RSLinx Classic menu bar. The following items appear on the RSLinx Classic toolbar.

<table>
<thead>
<tr>
<th>Icon</th>
<th>Menu Selection</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>File &gt; Open Project</td>
<td>Displays the currently defined projects and allows you to open a DDE/OPC project.</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>Communications &gt; RSWho</td>
<td>Opens an additional instance of RSWho (one instance is opened by default each time you open RSLinx Classic).</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>Communications &gt; Configure Drivers</td>
<td>Displays the currently configured RSLinx Classic software drivers and allows you to add additional drivers for use with your hardware devices.</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>Communications &gt; Driver Diagnostics</td>
<td>Displays a list of currently configured drivers and provides the option to view diagnostic information for each driver.</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>Edit &gt; Copy DDE/OPC Link</td>
<td>Provides the ability to create a DDE/OPC link between RSLinx Classic and a client application such as Microsoft Excel.</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>DDE/OPC &gt; Topic Configuration</td>
<td>Allows you to create and modify a DDE/OPC topic, which is a specific path to a processor.</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>Help &gt; What’s This?</td>
<td>Changes the cursor to an arrow and a question mark to indicate you are in What’s This? help mode. Click any screen item to display help text for that item and to exit What’s This? help mode.</td>
</tr>
</tbody>
</table>
Application workspace

The application workspace displays open child windows, such as the RSWho and RSLinx Classic dialog boxes.

Status bar

The status bar at the bottom of the RSLinx Classic screen provides information about the current status of your system.

The left area of the status bar is used to pass messages to the user. For example, when you scroll through the items on the menus, a brief description of the function of that menu item appears in this area of the status bar.

The right area of the status bar displays:

- CAP, which is highlighted if the Caps Lock key on your keyboard is toggled for all caps.
- NUM, which is highlighted if the Num Lock key on your keyboard is set to enable the numeric keypad on your keyboard.
- SCRL, which is highlighted if the Scroll Lock key on your keyboard is set.
- The current date from your computer’s system clock/calendar.
- The current time from your computer’s system clock/calendar.
Installing and Starting RSLinx Classic

This chapter explains how to install and start RSLinx Classic software. This chapter includes information on the following:

- system requirements
- installation procedure
- updating an existing installation
- starting procedure
- troubleshooting installation

After installing the software, we recommend that you read the release notes located in the online help. The release notes may contain more up-to-date information than was available when this document was published. To view the release notes, start RSLinx Classic, and then choose Help > Release Notes from the main menu.

Note: If you are running the Windows NT operating system and performing tasks that you will read about in this chapter, you must have Windows NT system administrator privileges and your user account must be a member of the local administrator user group. For more information, contact your system administrator.

Before you begin

Rockwell Software uses a software key to implement copy protection for Windows-based software products. Every software product has a unique key. Although, you can install the software on any number of computers, you are only licensed to run the software on one computer at a time. After you install the RSLinx Classic software, the Setup program will prompt you to activate your software. For more information about moving software keys, copy protection, and software activation, refer to Appendix A in this guide.

System requirements

To effectively use RSLinx Classic, your personal computer must meet the following minimum hardware and software requirements:

**Hardware requirements**

To install RSLinx Classic software, you will need the following hardware:

- a Pentium 100MHz processor with at least 32 Megabytes (MB) of RAM. This version of RSLinx Classic will not run on Alpha, MIPS, or Power PC processors. The versions of Windows NT for different processors are not binary-compatible.
- at least 35 MB of available hard drive space; more hard disk space may be required for specific application features.
a 16-color, SVGA display with 800 by 600 or greater resolution.
- a mouse or other Windows-compatible pointing device.
- an Ethernet card and/or Allen-Bradley communications device or cable.

Software requirements

To run RSLinx Classic, you require Microsoft Internet Explorer 6.0 (or later), and one of the following operating systems:
- Microsoft Windows XP, XP SP1, and XP SP2.
- Microsoft Windows 2003 SP1.
- Microsoft Windows 98 (version 4.10.2222A).
- Microsoft Windows NT Version 4.0 (Service Pack 3 or later recommended). Because RSLinx Classic takes advantage of features not available in Windows NT prior to Version 4.0, RSLinx Classic is only supported on Windows NT Version 4.0 or later.

Installing RSLinx Classic software

You can install one or more Rockwell Software products to a single personal computer.

Note: While installing RSLinx Classic software, you will have the opportunity to specify a directory. The suggested default directory is x:\Program Files\Rockwell Software\RSLinx where x is the letter of the drive to which you are installing RSLinx Classic. We recommend that you use the default directory whenever possible.

In procedures that appear throughout this document, it is assumed that you used the default name. If you did not use the default name, substitute the actual name you specified for the default name shown.

To install RSLinx Classic software, perform the following steps:

1. Start your Windows operating system if it does not start automatically.
2. Insert the RSLinx Classic CD-ROM into the CD-ROM drive.

If autorun is: | Then:
---|---
enabled | The Setup program starts automatically and the RSLinx Classic opening screen appears. Proceed to step 3.
disabled | Perform the following steps:
1. Click Start, and then click Run. The Run dialog box appears.
2. In the Open control, type x:\setup, where x is the letter of the drive containing the RSLinx Classic CD-ROM, and click OK. The RSLinx Classic opening screen appears.
3. Follow the instructions that appear on the screen.

- **On the RSLinx Classic installation dialog box** Click Release Notes to ensure your system meets the minimum requirements and to learn about new features included with this version of RSLinx Classic. After you have read the Release Notes, click Install RSLinx Classic.

- **On the Welcome dialog box** Read the RSLinx Classic introductory information, and then click Next.

- On the Software License Agreement dialog box Read the entire Software License Agreement. Enable I accept the terms in the license agreement and click Next to accept and continue installation, or enable I do not accept the terms in the license agreement and click Next to decline and exit the installation.

- **On the Customer Registration Information dialog box** Type your user name, the name of your organization, and the serial number of your RSLinx Classic software, and then click Next.

  *Note: You can find the serial number on the product box label or the CD-ROM case.*

- **On the Standard Setup dialog box** Select the RSLinx Classic options you wish to install. You have options such as selecting a destination directory other than the default location, and selecting specific EDS files. Click Next.

- **On the Ready to Install the Program dialog box** Click Install to start the RSLinx Classic installation process.

- **On the InstallShield Wizard Complete dialog box** Specify if you wish to install activation and click Finish. (For information on activation, refer to Appendix A in this guide). RSLinx Classic reverts to the Lite version if the proper activation is not installed. You must restart your computer before using RSLinx Classic. The RSLinx Classic installation is complete.

4. When you are finished installing the software, remove the RSLinx Classic CD-ROM from the CD-ROM drive and the Master disk from the disk drive. Store them in a safe place.

**Updating an existing installation**

Perform the following steps to update an existing RSLinx Classic installation:

1. Insert the RSLinx Classic CD-ROM into the CD-ROM drive and click Next on the Welcome dialog box.

2. On the Program Maintenance dialog box, enable Remove to remove RSLinx Classic from your computer.
3. Click Yes, and then Backup to backup your drivers and topics. Click Close to close the Backup/Restore dialog box.

4. Click Yes to remove EDS files from your computer.

5. At the Remove the Program dialog box, click Remove to confirm the uninstall procedure.

6. After the uninstall procedure is complete, click Finish.

7. Refer to the “Installing RSLinx Classic Software” section to install the updated version of RSLinx Classic. To restore the drivers and topics you backed up in step 3, click Start, and then select Programs > Rockwell Software > RSLinx > RSLinx Classic Backup Restore Utility.

Note: If activation was previously installed, it is not necessary to move the activation. If activation was not previously installed, insert the Master disk into the 3.5-inch disk drive and follow the instructions that appear on the screen. For more information on activation, refer to Appendix A in this guide.

Starting RSLinx Classic software

To start RSLinx Classic software, click Start, and then select Programs > Rockwell Software > RSLinx > RSLinx Classic.

Note: We assume that you used the default names for the directory and program group. If you did not use the default names, substitute the actual names that you specified for the default names shown.

Troubleshooting installation

If RSLinx Classic does not start or run properly, consider the following:

- Does your computer have enough memory? Running RSLinx Classic requires a minimum of 32 MB of RAM.
- Does your computer have enough disk space? Running RSLinx Classic requires a minimum of 35 MB of available hard disk space.
- Do you have the correct version of RSLinx Classic installed? If your RSLinx Classic installation displays as RSLinx Classic Lite, RSLinx Classic Single Node, or RSLinx Classic OEM, the proper activation files were not installed. From within RSLinx Classic, select Help > Copy Protection to view information about activation files.
- Have you reinstalled an earlier Service Pack or removed a component, such as DCOM, that RSLinx Classic requires?
This chapter describes features of the RSWho network browser interface. RSWho allows you to view all the active network connections from a single screen.

Using RSWho

RSWho is RSLinx Classic’s main window that displays networks and devices in a style similar to Windows Explorer. A variety of integrated configuration and monitoring tools are accessible from the right mouse button in RSWho. Some of the available tools are the ControlLogix Gateway Configuration Tool for 1756-DHRIO, 1756-ENET, and 1756-CNB modules, a Ladder Viewer for PLC-5, SLC, or MicroLogix family processors, and a Data Monitor for monitoring live data out of any ControlLogix, PLC-5, SLC, or MicroLogix family controllers.

The left pane of RSWho is the tree control, which shows networks and devices. The right pane is the list control, which shows all members of a collection. A collection is a network, or a device that is a bridge. Right-click in the list control and choose a view option of Large Icons or Details.

Note: A device that appears with a red X indicates that RSWho previously recognized this device, but now it can not. The red X indicates a communication status error, such as unplugging a recognized device. These devices can be removed from the RSWho display by right-clicking on the device and selecting Remove.
RSWho browsing

The RSWho icon indicates a network. If this icon is animated, the network is being browsed. Click a network or device to start browsing.

When the network or device is collapsed (indicated by the + sign), click + or double-click the network or device icon next to the + to expand the view and begin browsing. When the network or device is expanded (indicated by the – sign), click – or double-click the network or device icon next to the – to collapse the view.

If the Autobrowse checkbox is enabled, RSWho continuously browses the selected device or network (regardless of whether or not the selection is expanded or collapsed). If Autobrowse is cleared, the Refresh button is active. Clicking Refresh instructs RSWho to perform one browse cycle of the selected device or network. Since Refresh only performs one browse cycle, clicking Refresh multiple times may be necessary to discover everything on the network.

Right-click on a supported device to select Station Diagnostics, Configure DDE Topic, or other supported services for that device.
This chapter describes the features of:

- OLE for Process Control (OPC)
- Dynamic Data Exchange (DDE)

**OLE for Process Control (OPC)**

OPC, or OLE for Process Control, is a communication standard based on OLE technology provided by Microsoft and developed and maintained by the OPC Foundation, a coalition of industrial/manufacturing companies of which Rockwell Software is a member. The charter of this group is to provide an industrial standard exchange mechanism between plant floor devices and client applications. RSLinx Classic is an OPC-compliant server exposing the required interfaces for an OPC client application to access data consistent with other OPC-compliant servers. The added benefit provided from RSLinx Classic is its ability to provide several DDE formats in addition to OPC.

OLE for Process Control (OPC) is designed to allow client applications access to plant floor data in a consistent manner. OPC provides many benefits:

- Hardware manufacturers only have to make one set of software components for customers to utilize in their applications.
- Software developers do not have to rewrite drivers because of feature changes or additions in a new hardware release.
- Customers have more choices with which to develop world class integrated manufacturing systems.

With OPC, system integration in a heterogeneous computing environment is simple. Leveraging the OLE/COM environment is possible.

RSLinx Classic is an OPC compliant server. For more information about OPC, visit the OPC Foundation web site at www.opcfoundation.org. For more information on using OPC with Rockwell Software products, visit our web site at www.software.rockwell.com/support.
Dynamic Data Exchange (DDE)

Dynamic Data Exchange (DDE) is a standard inter-application communication protocol built into Microsoft Windows operating systems and supported by many applications that run under Windows. DDE takes data from one application and gives it to another application. It allows Windows programs that support DDE to exchange data between themselves.

- A DDE server is a program that has access to data and can provide that data to other Windows programs.
- A DDE client is a program that can obtain data from a server.

By specifying an application, topic, and item, a client application can exchange data with a server application.

DDE works like a conversation between two people. The people represent the different applications running under Windows, and the data they share is what they are talking about. RSLinx Classic does not know the type of data it is receiving, it only knows that a DDE link is providing the data.

For example, if you have a DDE link from RSLinx Classic to an Excel spreadsheet, Excel does not know that you are sending a counter value into a spreadsheet. All Excel sees is data.

For example, RSLinx Classic is the application name, PLC5TOPIC1 is an example topic name, and C5:0.ACC is an example item, in this case a counter accumulator in an Allen-Bradley PLC-5.

Note: Not all applications that run under Microsoft Windows support DDE. Check with an application’s manufacturer before purchasing an application for use with RSLinx Classic.

For more information about DDE, refer to the DDE (Dynamic Data Exchange) topic in the RSLinx Classic help file.
DDE/OPC client connectivity

RSLinx Classic provides connectivity for client applications using OPC or multiple DDE data formats. The OPC and AdvanceDDE interfaces provide optimized read operations by packing multiple requests from multiple clients in a single transaction. In configuring a DDE Topic, you can specify whether or not you want DDE poke operations optimized. Optimized pokes only work with PLC-5 and SLC processors.

The benefit of optimizing DDE poke operations is packing multiple updates in a single write operation, thus reducing the overall number of packets required. Operations such as downloading a recipe can take advantage of this feature.

Other DDE formats supported include FastDDE (for Wonderware clients), XL_Table and CF_Text to support Microsoft Office products, and other generic DDE client applications.
Finding the Information You Need

Use this chapter to review the sources of additional information about RSLinx Classic software. This chapter helps you to find what you need efficiently by describing how to:

- Use the online help
- Access online guides
- Use RSLinx Classic Assistance Central
- Participate in Rockwell Software training courses
- Contact Technical Support

Using the online help

RSLinx Classic online help provides general overview information, comprehensive step-by-step procedures, and context-sensitive, dialog box control definitions for working with all of the features in the software. To view online help while running RSLinx Classic:

- choose RSLinx Classic Help from the Help menu on the RSLinx Classic main window,
- click Help on any RSLinx Classic dialog box or property page,
- position the cursor over a control with which you want help and right-click, or
- press F1.
Accessing help for a control or field

To display a definition for a control or a field, click the What’s This? icon in the upper right corner of the dialog box, drag the cursor to the selected area, and then click to display the definition. In this example, the Property control was selected.
Finding step-by-step procedures

To view a list of tasks related to the current topic, move to the What do you want to do? section at the bottom of the help window and select one of the listed tasks. The current topic is replaced with a step-by-step procedure for completing the task.

For example, from the What is a driver? help topic, if you select Add a driver under the What do you want to do? section, the procedure that describes how to add RSLinx Classic drivers displays.

<table>
<thead>
<tr>
<th>What is a driver?</th>
</tr>
</thead>
<tbody>
<tr>
<td>A driver is the software interface to the hardware device that allows RSLinx Classic to communicate with your PLC. Configuring a software driver is the first step in establishing a DDE hot link.</td>
</tr>
</tbody>
</table>

Select **Communications > Configure Drivers** to display the Configure Drivers dialog box that is used for adding, editing or deleting drivers. The available hardware drivers are shown in the Available Drivers list. The presently configured drivers are displayed in the Configured Drivers list.

**Tip:** For specific information, click on the context links in the What do you want to do? section.

<table>
<thead>
<tr>
<th>What do you want to do?</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add a driver</td>
</tr>
<tr>
<td>Edit a driver</td>
</tr>
<tr>
<td>Delete a driver</td>
</tr>
<tr>
<td>View information</td>
</tr>
</tbody>
</table>

**Add a driver**

**How do I access the dialog?**

1. From the Configure Drivers dialog box, select the desired driver from the Available Drivers list.
2. Click **Add New**. The configuration dialog box for that driver appears.
3. Enter the appropriate parameters for the desired driver in the configuration dialog box.
4. Click **OK** to close the configuration dialog box. The new driver now appears in the Configured Drivers list.
Finding definitions

Within the RSLinx Classic help, blue text highlighted with an underline indicates a link to a pop-up definition or a link to a related topic. For example, in the Dynamic Data Exchange help topic, application, topic, and item are pop-up definitions, and DDE link is a link to a related topic.

Dynamic Data Exchange (DDE)

Dynamic Data Exchange (DDE) is a standard inter-application communication protocol built into Microsoft Windows supported by many applications that run under Windows. DDE takes data from one application and makes it available to other Windows programs that support DDE to exchange data between themselves.

- A DDE server is a program that has access to data and can provide that data to other Windows programs.
- A DDE client is a program that can obtain data from a server.

By specifying an application, topic, and item, a client application can exchange data with a server application. DDE works like a conversation between two people. The people represent the different applications, and the conversation is what they are talking about.

Applications using DDE talk to RSLinx Classic do not care what kind of data they are getting. All they know is providing data. What that data is and how it will be used is immaterial to the receiving application. For example, if you have a DDE link from RSLinx Classic to an Excel spreadsheet, Excel does not know that it is exchanging data. For example, RSLNX is the application name, PLCSTOPIE1 is an example topic name, and CS10BAIL counter accumulator in an Allen-Bradley PLC-5.

Tip: Not all applications that run under Microsoft Windows support DDE. Check with an application's documentation for use with RSLinx Classic.

What do you want to do?
- Set up a DDE conversation
- Read data collection tips
- Configure network DDE
- Read about polled and unsolicited mode
Using RSLinx Classic Assistance Central

From the RSLinx Classic Help menu, select **RSLinx Classic Assistance Central** to obtain the latest information about your Rockwell Software products. Use this site to learn about training sessions offered for RSLinx Classic, see what's new in the latest version, sign up for MySupport e-mails, and read what other customers have to say about RSLinx Classic.

Accessing online guides

You can gain immediate access to product documentation through the online guides included with RSLinx Classic. The online guides include this Getting Results Guide, as well as any reference guides, in an electronic book format. The online guides are included in a portable document format (PDF) on your RSLinx Classic CD. These files must be viewed using the Adobe Acrobat Reader software, which you can download for free from the Adobe website (www.adobe.com).

Training

One of the best ways to increase your proficiency at using Rockwell Software products is to attend a Rockwell Software training program. Our training programs can help you master the basics and show you how to unleash the full potential of our software.

We offer a wide range of training programs, from regularly scheduled classes conducted at Rockwell Software facilities, to custom-tailored classes conducted at your enterprise. The size of each class is kept small intentionally to maximize student engagement.

If you would like more information about our training programs, visit the Rockwell Software site on the World Wide Web or contact the Rockwell Software Training Coordinator. Our World Wide Web address and telephone numbers appear on the inside front cover of this document.

*Note: For more information on Rockwell Software training, select Help > Support and Training from within RSLinx Classic*

Technical support

If you cannot find answers to your questions in the *Getting Results with RSLinx Classic* guide, the online help, or the online guides, you can call Rockwell Software Technical Support at the numbers listed on the inside front cover of this guide. The technical support staff is available Monday through Friday from 8 A.M. to 5 P.M. Eastern Time, except holidays. You can also access the Rockwell Software Online Support Library from the web site listed on the inside front cover of this guide.
When you call

When you call, you should be at your computer and prepared to give the following information:

- product serial numbers
- product version number
- The product serial numbers and version number can be found in the software by selecting Help > About RSLinx Classic.
- hardware you are using
- exact wording of any errors or messages that appeared on your screen
- description of what happened and what you were doing when the problem occurred
- description of how you attempted to solve the problem

Note: For more information on Rockwell Software technical support, select Help > Support and Training from within RSLinx Classic
Activation

RSLinx Classic 2.50.00 (CPR 7) supports two kinds of activation—FactoryTalk and EVRSI.

If you are a new user, you will need to activate your software using FactoryTalk Activation because RSLinx Classic no longer ships with a physical “master disk” for activating software. For more information, read the ‘Activate RSLinx Classic with FactoryTalk Activation’ section of this appendix. However, if you are a current user upgrading to RSLinx Classic 2.50.00, you can continue using EVRSI to activate your software. For more information, read the ‘Activate RSLinx Classic with EVRSI’ section of this appendix.

Activate RSLinx Classic with FactoryTalk Activation

The type of FactoryTalk Activation RSLinx Classic 2.50.00 (CPR 7) supports is called node-locked activation. This type of activation can be either locked to a particular piece of hardware, such as an EtherNet card or a harddisk of a stand-alone computer, or to a hardware dongle. Depending upon the kind of device (stand-alone computer or hardware dongle) you want to activate, you can purchase either

- Local "node-locked" activation: This kind of activation activates software only on a single computer. If the activation file is copied to another computer, the software will not run on that other computer, or
- Mobile "node-locked" activation: This kind of activation is locked to hardware dongle. A dongle is a security or copy protection device that must be connected to the computer while the program runs. The activation files can be copied to multiple computers, but the software activates only on the computer where the dongle is connected.

How to activate RSLinx Classic

To activate your copy of RSLinx Classic, perform the following steps:

1. Install the FactoryTalk Activation Client available from the Optional Steps screen of the Install program.

2. Once FactoryTalk Activation Client gets installed, it will load the FactoryTalk Activation Wizard which will guide you through the steps of downloading the activation from the Internet. You can download the activation to your stand-alone computer or hardware dongle.
Some common questions
Following are some common problems that people encounter with activation and their solutions.

WHAT IS AN "ACTIVATION FILE?"
An activation file is a digitally signed, plain-text file that activates a software product and “locks” the activation to a particular piece of hardware, such as a computer’s hard disk or Ethernet card. The contents of an activation file are protected by a signature, generated by Rockwell Software, which is based on machine-specific information that you provide when you install the software.

WHAT IS A "HOST ID?"
A Host ID is an internal code that uniquely identifies a hardware device. FactoryTalk® Activation™ uses the Host ID to “lock” each software activation file to a specific hardware device.

To prevent activations from failing unexpectedly at runtime, do not lock activations to virtual network adapters, such as those used for virtual private networks (VPN) or virtual machines. Instead, lock activations to the Host IDs of fixed devices such as hardware network adapters or hard disk serial numbers. If you need help determining which network adapters are virtual adapters, contact your Information Technology department.

WHAT IS A "NODE-LOCKED" ACTIVATION?
A “node-locked” activation file “locks” the software activation to a specific hardware ID, called a “Host ID,” that uniquely identifies a local computer or a hardware dongle:

- Local, node-locked activations can activate software only on a single computer. If the activation file is copied to another computer, the software will not run on that other computer.

- Mobile, node-locked activations are locked to hardware dongles. A dongle is a security or copy protection device that must be connected to the computer while the program runs. The activation files can be copied to multiple computers, but the software activates only on the computer where the dongle is connected.

HOW DO I GET A LOCAL, NODE-LOCKED ACTIVATION FILE AND ACTIVATE MY SOFTWARE?
If the product you are activating supports node-locked activations:

1. Install your new software product.
2. Install and run the FactoryTalk Activation Tool.
3. Follow the instructions to identify your computer’s Host ID.

5. Follow the instructions to download an activation file for your new software product to the activation directory.

The default activation directory is: c:\Program Files\Common Files\Rockwell\Activations. After you download the activation file, your new software will activate when you run your software.

**HOW DO I GET A MOBILE NODE-LOCKED ACTIVATION FILE AND ACTIVATE MY SOFTWARE?**

If the product you are activating supports node-locked activations for a dongle:

1. Install your new software product.

2. Install and run the FactoryTalk Activation Tool.

3. Attach the dongle to the computer where you are running the FactoryTalk Activation Tool.

4. Follow the instructions to identify the dongle’s Host ID.

5. Go to the Rockwell Software Activation website (http://licensing.software.rockwell.com).

6. Follow the instructions to download an activation file for your new software product.

After you download the activation file, copy it to the activation directory on all of the computers to which you want to attach the dongle. The default activation directory is: c:\Program Files\Common Files\Rockwell\Activations. Your new software will activate when you attach the dongle.

**WHAT IF I DON'T HAVE INTERNET ACCESS ON MY COMPUTER?**

If the computer where you want to activate your new software does not have Internet access, but Internet access is available in your facility, you can download an activation file to the computer with Internet access. You can then copy the activation file to the computer where the activation is needed.

For example, suppose you want to install a node-locked activation file on a stand-alone computer on a factory floor, but Internet access is not available from the stand-alone computer.

1. Install your new software product on the stand-alone computer.

2. Install and run the FactoryTalk Activation Tool on the stand-alone computer.
3. Write down the Host ID of this computer, and then close the FactoryTalk Activation Tool.

4. On the computer with Internet access, install and run the FactoryTalk Activation Tool.

5. Follow the instructions and type in the Host ID copied from the stand-alone computer.


7. Follow the instructions to download an activation file for your new software product.

8. Copy the activation file to the stand-alone computer or activation server.

The default activation directory is: c:\Program Files/Common Files\Rockwell\Activations. After you copy the activation file, your new software will activate when you run it on the stand-alone computer.

**WHAT IF I DON’T HAVE INTERNET ACCESS ON MANY COMPUTERS? DO I HAVE TO GET ACTIVATIONS FOR THEM ONE AT A TIME?**

No. If multiple computers in your facility lack Internet access, you can use the FactoryTalk Activation Transfer Tool to collect Host IDs from all of those computers. You can then use the FactoryTalk Activation Wizard to download activation files for all of the Host IDs on any computer with Internet access. Finally, use the FactoryTalk Activation Transfer Tool to copy the activation files to the computers where the activations are needed.

For example, suppose you want to install node-locked activation files on several stand-alone computers on a factory floor, but Internet access is not available from the stand-alone computers.

1. Install your new software product on each stand-alone computer.

2. On one of the stand-alone computers, install and run the FactoryTalk Activation Tool. Click the Settings tab, and then click the Create Transfer Tool button. Save the Transfer Tool to removable media such as a floppy disk or USB drive.

3. Connect the removable media to the stand-alone computer, and then run the FactoryTalk Activation Transfer Tool.

4. Record the Host ID of the stand-alone computer, and then close the FactoryTalk Activation Transfer Tool.

5. Repeat steps 3 and 4 on each stand-alone computer to capture its Host ID.

6. On the computer with Internet access, run the FactoryTalk Activation Wizard.
7. Import the Host IDs from the removable media where the FactoryTalk Activation Transfer Tool is installed, and then follow the instructions to download all of the activations you need.

8. Use Windows Explorer to copy the activation files you downloaded to the removable media.

9. Use the FactoryTalk Activation Transfer Tool to copy the activation files to the appropriate stand-alone computers. The FactoryTalk Activation Transfer Tool automatically determines which activation files belong with which computers.

The FactoryTalk Activation Transfer Tool copies the activation files to the default activations directory: c:\Program Files\Common Files\Rockwell\Activations. After you copy the activation file, your new software will activate when you run it on the stand-alone computer.

**Finding more information about activation**

For help at any point, click the Help button on any FactoryTalk Activation Tool dialog or FactoryTalk Activation Transfer Tool dialog, or click the Help link on the Rockwell Software Activation website: http://licensing.software.rockwell.com.

If you cannot connect to the Internet, call Technical Support for help creating an activation file from an e-mail or a fax.

Phone: 440-646-5800 in North America. Outside of North America, call your local support organization.
Activate RSLinx Classic with EVRSI

Rockwell Software’s products are copy-protected. Only a computer with access to the activation key can run the software. The key is located in an activation file, which is located on the Master disk supplied with the RSLinx Classic product. The activation file contains one activation key per product. Each key contains one or more licenses depending on how many copies of the product you have purchased.

*Note: Store your Master disk in a safe place. If your activation becomes damaged, the Master disk may be the only means to run your software in an emergency.*

During the setup process, the setup program gives you the opportunity to move the activation file from the Master disk to the root directory of the drive on which you’re installing the software.

When you launch RSLinx Classic, the software first checks your local hard drives, then network hard drives, and finally local floppy drives for activation. If the system fails to detect either the activation file or the Master disk, your software reverts to the RSLinx Classic Lite version.

*Note: Systems attached to extensive networks can take quite a while to search for activation files on all available drives. You can use the CHECKDRIVES environment variable to specify and/or limit the drives your software checks for activation files and to specify the order in which they are checked. Refer to the activation utilities online help file by selecting Help > Copy Protection.*

How to activate RSLinx Classic

Depending on your needs, you can activate RSLinx Classic from any of the following:

**Hard drive.** The activation key resides on your computer’s hard disk. Use this method if you will typically use RSLinx Classic on only one computer. This is the default method if you activate RSLinx Classic during installation. To run RSLinx Classic on a different computer, move the activation key back to the Master disk, and then to the hard drive of the new computer.

**Diskette drive.** The activation key resides on a floppy disk (activation disk). Use this method if you will typically use RSLinx Classic on more than one computer, for example, if you want to run RSLinx Classic on a desktop computer at some times and a portable computer at others.

**Network drive.** The activation keys reside on a network drive. Use this method if you have purchased multiple licenses of the software and want several users to be able to activate the software over a network. Refer to the online help for instructions on moving activation to a network drive (refer to the “Finding more information about activation” section in this chapter to access online help).
Protecting your activation files

Certain anti-virus software packages, such as Norton Anti-virus, can corrupt the activation files. Configure your anti-virus software to avoid checking the files EVRSI.SYS and 386SWAP.PAR.

To avoid damaging your activation files, do not perform the following operations with activation files on the hard drive.

- Restore from backup
- Upgrade the operating system
- Compress or uncompress the hard drive

Defragmentation utilities will not harm activation files.

Before running any type of utility that may modify the structure or organization of the hard drive, remove activation from the hard drive:

1. Use the Move Activation utility (EvMove) to move activation files from the hard drive to an activation disk.

   Do not use the Move Activation utility if Rockwell Software products are currently running. Ensure all software programs are closed before initiating the EvMove utility.

   Run EVMOVE.EXE from your hard drive (located in C:\Program Files\Rockwell Software\RSUtil if you accepted the default directory location during installation).

2. Perform the hard disk operation.
3. Move the activation files back to the hard drive.

You must use the move utility, EvMove, to move activation files. Attempts to copy, move or e-mail an activation file by other means will damage the file.
RUNNING THE ACTIVATION UTILITIES

The utilities for moving and resetting activation are called EvMove and Reset respectively. Reset is used when an activation file has been damaged. The EVMOVE.EXE and RESET.EXE files are located on your hard drive (located in C:\Program Files\Rockwell Software\RSUtil if you accepted the default directory location during installation). To run these programs, select Start > Programs > Rockwell Software > Utilities > Move Activation or Reset Activation.

Some common questions

Following are some common problems that people encounter with activation and their solutions.

MY ACTIVATION FILES WERE DAMAGED. WHAT SHOULD I DO?

If you have lost the activation because the activation file is damaged, you need to reset activation. Follow the Reset Codes instructions on the Rockwell Software Technical Support web page, or call the technical support telephone number. The web page and telephone number are both listed on the inside front cover of this guide.

If you cannot obtain a reset code immediately, follow these instructions to use the Master disk to activate the software as a temporary solution.

To use the Master disk to activate software:
1. Set the KEYDISK environment variable to TRUE. (Please refer to the online help.)
2. Insert your Master disk in the floppy drive.
3. Run your software as usual. Your software will find the activation on the Master disk.

I ACCIDENTALLY DELETED THE SOFTWARE DIRECTORY ON MY HARD DRIVE. DO I NEED TO CALL ROCKWELL SOFTWARE FOR REPLACEMENT ACTIVATION FILES?

No. Deleting the program files does not delete your activation. The activation files are not stored in the program directory; they are located in the root directory. Your activation files will not be lost unless you format the hard drive, tamper with hidden files in the root directory, or perform certain other hard drive operations (refer to the “Protecting your activation files” section in this chapter for more information).

To get the software running again, simply reinstall the software, but do not move the activation when given the opportunity.
WHY CAN’T I MOVE ACTIVATION TO A NEW FLOPPY DISK ON A WINDOWS NT SYSTEM?

It has to do with a disk modification that NT does not allow. If you have access to a machine with a different Windows operating system, you can create a disk that will work under NT. Format a floppy and move any activation file to it under Windows XP, 2000, Me, or 98. (You can move the activation back off the disk if you want to keep it where it was.) Then take that disk to your Windows NT machine and move the activation to it.

Finding more information about activation

The online help (COPYPROT.HLP) provides more extensive information on activation including subjects such as:

- **KEYDISK.** Set this environment variable to tell your computer to look for activation on floppy drives
- **CHECKDRIVES.** Specify which drives to search for activation
- **network activation.** Move activation to a network server to allow multiple users access to the activation
- **moving activation.** See detailed instructions for moving activation
- **resetting activation.** See detailed instructions for using the Reset utility to repair a damaged activation file
- **troubleshooting.** Look up error messages, get problem-solving suggestions

You can access online help:

- from the Help button on one of the EvMove or Reset dialog boxes.
- from RSLinx Classic by selecting Help > Copy Protection from the main menu.
- without running either RSLinx Classic or the activation utilities. From the Windows Start menu, select Programs > Rockwell Software > Utilities > Activation Help (if you accepted the default directory location during installation).
Secure RSLinx Classic with RSAssetSecurity

This first release of RSAssetSecurity™ is intended to improve the security of your automation system by limiting access to those with a legitimate need. RSAssetSecurity authenticates user identities and authorizes user requests to access a FactoryTalk-enabled system. These security services are fully integrated into the FactoryTalk Directory and are included as part of the FactoryTalk Automation Platform that installs with many products.

Although security services are always present wherever FactoryTalk is installed, you must purchase and install activations in order to add more than 10 user accounts to a Network Directory and use security services across a networked system on multiple computers.

Activations are not required to add 10 or fewer user accounts to a Network Directory. In addition, activations are not required to add user accounts to a Local Directory; security services are freely available when used in a stand-alone system on a single computer.

For more information on how to use security services, please refer to RSAssetSecurity’s Online help.

How do I set up security in RSLinx Classic?

RSLinx Classic 2.50.00 (CPR 7), along with, supporting RSSecurity, now supports RSAssetSecurity. RSAssetSecurity™ is intended to improve the security of your automation system by limiting access to those with a legitimate need. RSAssetSecurity authenticates the identities of users and authorizes user requests to access a FactoryTalk-enabled system against a set of defined user accounts and access privileges held in the FactoryTalk Directory. For more information on RSAssetSecurity, read the ’About RSAssetSecurity’ topic located in RSLinx Classic’s Online Help. The table below explains the steps you would need to perform to implement one of the two security mechanisms (RSAssetSecurity and RSSecurity) supported by RSLinx Classic

<table>
<thead>
<tr>
<th>If you are...</th>
<th>Do this...</th>
</tr>
</thead>
<tbody>
<tr>
<td>a user who wants to:</td>
<td>1. Install FactoryTalk Automation Platform from RSLinx Classic Optional Steps Install screen. (During the FactoryTalk Automation Platform install you configure the FactoryTalk Directory.)</td>
</tr>
<tr>
<td>- use RSAssetSecurity, and</td>
<td>2. Install RSSecurity Emulator from Start &gt; Programs &gt; Rockwell Software &gt; FactoryTalk Tools &gt; RSSecurity Emulator.</td>
</tr>
<tr>
<td>- has never configured security using RSSecurity</td>
<td></td>
</tr>
</tbody>
</table>

41
If you are...  Do this...

Note: During RS Security Emulator install, you will see the ‘FactoryTalk Directory’ screen (see the following figure) where you will be prompted to select the FactoryTalk Directory (Network or Local) that RS Security Emulator should use. At this step, be sure to make a note of the directory you choose — you will require this information when adding security policies to FactoryTalk Directory in step 5.

3. Install RS Linx Classic from RS Linx Classic Required Steps Install screen.

4. While running RS Linx Classic’s installation wizard, you will see the Security Configuration Selection screen. On this screen, select the ‘Enable security’ and ‘Add security policies to the FactoryTalk Directory’ options.
B • SECURE RSLINX CLASSIC WITH RSASSETSECURITY

If you are... | Do this...
--- | ---
5. Click **Next** to go to the Add Security Policies to the FactoryTalk Directory install screen (see the following figure). On this screen, make sure the Log on to the … FactoryTalk Directory text shows the directory (Network or Local) you chose during RSSecurity Emulator install in step 2.

![Add Security Policies to the FactoryTalk Directory](image)

6. Click **Next** to finish RSLinx Classic install.

7. Open FactoryTalk Administration Console from **Start > Programs > Rockwell Software > FactoryTalk Administration Console** to add user accounts and set security settings to secure RSLinx Classic.

**Note:**
- For more information on how to add user accounts, read the Add a user account topic in FactoryTalk Administration Console help, located at Manage FactoryTalk-enabled systems > Log on and configure security > Configure security > How To > Work with user accounts > Add a user account.
- For more information on how to secure RSLinx Classic's features, read the Secure Product Features topic in RSAssetSecurity help, located at Configure Security > How to > Set up product policies > Secure product features.
- For more information on what you can secure in RSLinx Classic, read the What can I secure in RSLinx Classic topic in RSLinx Classic Online help, located at How to > Secure RSLinx Classic with RSAssetSecurity > What can I secure in RSLinx Classic.
8. Open RSLinx Classic from Start > Programs > Rockwell Software > RSLinx > RSLinx Classic, and select Security > Set Security User from the main menu. In the New User dialog box, enter the username and password of the user you created in FactoryTalk Administration Console in step 7, and click Ok.

*Note:* Because access to features in RSLinx Classic is governed by the permissions you set for a user in FactoryTalk Administration Console, some features out of the 13 securable features in RSLinx Classic may be inaccessible (for example, if the user you entered in step 8 does not have the appropriate permission).

This completes the security setup for RSLinx Classic.

If you are... | Do this...
---|---
a user who wants to: | 1. Install FactoryTalk Automation Platform from RSLinx Classic Optional Steps Install screen. (During the FactoryTalk Automation Platform install you configure the FactoryTalk Directory.)  
   - use RSAssetSecurity, as well as  
   - import an existing RSSecurity Configuration into the FactoryTalk Directory  
3. Locate the RSSecurity Configuration (*.bak) file, and select File > Export to backup the *.bak file.  
5. Uninstall RSSecurity Server/Client (whichever is installed on this machine) from Start > Settings > Control Panel > Add/Remove Programs.  
6. Install RSSecurity Emulator from Start > Programs > Rockwell Software > FactoryTalk Tools > RSSecurity Emulator.  
   *Note:* During RSSecurity Emulator install, you will see the 'FactoryTalk Directory' screen (see the following figure) where you will be prompted to select the FactoryTalk Directory (Network or Local) that RSSecurity Emulator should use. At this step, be sure to make a note of the directory you choose — you will require this information when importing the .bak file into the FactoryTalk Directory in step 10.
7. Install RSLinx Classic from RSLinx Classic Required Steps Install screen.

8. While running RSLinx Classic’s installation wizard, you will see the Security Configuration Selection screen. On this screen, select the ‘Enable security’ option, but do NOT select the ‘Add security policies to the FactoryTalk Directory’ option.
9. Click **Next** to continue with the installation.

10. Import RSSecurity Server database by launching **Start > Programs > Rockwell Software > FactoryTalk Tools > Import RSSecurity Configuration**.

   **Note:** While running the Import RSSecurity Configuration utility, you will see the 'RSAssetSecurity Import' dialog box (see the following figure). In the 'Destination' listbox on this dialog box, be sure to import the .bak file to the directory where you installed the Emulator (see step 7). (Selecting the default option in the destination field stores your file in the Network directory.)

11. Open RSLinx Classic, and select **Security > Set Security User** from the main menu. In the New User dialog box, enter the username (domain name\username) and password of the RSSecurity user.

   **Note:** If you do not remember the usernames of the users that existed in your old RSSecurity setup, perform the following steps:

   a. Launch FactoryTalk Administration Console by selecting **Start > Programs > Rockwell Software > FactoryTalk Administration Console**.

   b. In the Explorer pane, expand the FactoryTalk Local or Network Directory tree, and then expand the Systems folder until the Users folder is visible.

   c. In the Users folder, the users who have domain associated with their usernames (for example, na\Bob) are your RSSecurity users.

   **Note:** Because access to features in RSLinx Classic is governed by the permissions you set in the security server, some features out of the 13 securable features in RSLinx Classic may be inaccessible (for example, if the user you entered in step 11 does not have the appropriate permission).

This completes the security setup for RSLinx Classic.
What can I secure in RSLinx Classic?

The following table explains the features you can restrict access to in RSLinx Classic. For example, you might restrict the ability to shut down the RSLinx Classic service to a small group of users, to prevent parts of your automation system from going down at runtime.

**Note:** If you selected Network Directory during the RSLinx Classic security setup procedure, you must purchase RSAssetSecurity activation to secure the following list of features. For more information, please contact your local Rockwell Automation distributor.

<table>
<thead>
<tr>
<th>Securable feature</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Clear DDE/OPC Event Log</td>
<td>Displays information on any DDE/OPC error messages logged while running RSLinx Classic with DDE/OPC compliant programs.</td>
</tr>
<tr>
<td>Configure CIP Options</td>
<td>Administers how PCCC requests that use the CIP protocol are sent over networks.</td>
</tr>
<tr>
<td>Configure Client Applications</td>
<td>Maps configured and running RSLinx Classic drivers to legacy INTERCHANGE C API, as well as displays the link identifier of the virtual network maintained by RSLinx Classic for the use of Client Applications in the virtual link unsolicited messaging model.</td>
</tr>
<tr>
<td>Configure ControlLogix Gateway</td>
<td>Provides you with information about the modules in your ControlLogix Gateway.</td>
</tr>
<tr>
<td>Configure DDE/OPC Topic</td>
<td>Configures DDE/OPC topic.</td>
</tr>
<tr>
<td>Configure Drivers and Shortcuts</td>
<td>Configures (add, edit, or delete) drivers and shortcuts that allow RSLinx Classic to communicate with your PLC, as well as provide quick access to specific networks.</td>
</tr>
<tr>
<td>Configure Gateway</td>
<td>Allows you to enable the RSLinx Classic Gateway.</td>
</tr>
<tr>
<td>Configure Network Properties</td>
<td>Allows you to configure network properties.</td>
</tr>
<tr>
<td>Edit DDE/OPC Project</td>
<td>Allows you to edit your DDE/OPC project.</td>
</tr>
<tr>
<td>Edit Options</td>
<td>Displays the options dialog box which contains the General and DDE tabs.</td>
</tr>
<tr>
<td>Reset Station Diagnostic Counters</td>
<td>Clears the counters in the station diagnostic screens.</td>
</tr>
<tr>
<td>Shutdown</td>
<td>Shuts down RSLinx Classic.</td>
</tr>
<tr>
<td>View NT Event Log</td>
<td>Records important system occurrences such as RSLinx Classic drivers successfully starting and stopping.</td>
</tr>
</tbody>
</table>
Considerations when using RSlinx Classic with RSAssetSecurity

Keep the following in mind when using RSlinx Classic with RSAssetSecurity:

**NETWORK/LOCAL DIRECTORY**

The FactoryTalk Automation Platform can install two completely separate and independent FactoryTalk Directories: a Local Directory and a Network Directory. User accounts, passwords, and security permissions to securable features are completely separate and cannot be shared between the Network Directory and the Local Directory. Configuring any of these items on one directory does not configure them on the other. Similarly, changing the password to a user account in one directory does not change the password the other directory, even if the account has the same name in both directories.

When configuring RSlinx Classic to work in one of the two directories, please keep the following in mind:

- RSlinx Classic’s security policies and RSSecurity Emulator must be installed in the same directory (either Local or Network).
- If you configured RSlinx Classic to work in Network Directory and want to use RSAssetSecurity to administer centralized security across the network, you will need to purchase RSAssetSecurity activation.

*Note: Using RSAssetSecurity on the Local directory does not require activation. On a network directory, RSAssetSecurity does not require activation for ten or fewer users. If you intend to have more than ten users (including administrative users) on a Network directory, you must purchase and activate RSAssetSecurity licenses for the additional users.*

- If you configured RSlinx Classic to work in Local Directory and want to use RSAssetSecurity, you do not need to purchase RSAssetSecurity activations. However, remember that, when working in Local directory you can administer security only on a single computer.
RESET NETWORK TREE

When RSLinx Classic is reinstalled, all security settings that were previously configured for networks and devices are lost. You must redefine these security settings in the Networks and Devices tree, or in RSWho. For more information, read the Network and Devices are not displayed correctly topic in RSAssetSecurity’s help, located at Configure security > Troubleshooting security > Network and Devices are not displayed correctly.

MISCELLANEOUS

Keep the following additional RSAssetSecurity considerations in mind:

- If you did not check ‘enable security’ option during RSLinx Classic install, but want to enable security now, you will need to uninstall and then reinstall RSLinx Classic.

- Every time you are in RSLinx Classic, be sure to verify that the Username displayed in the Current Security User text box of the Set Security dialog box (Security > Set Security User) is correct. If it is incorrect, enter the new Username and Password, and click OK.
Glossary

**Activation disk** — Any disk (floppy or hard) containing an activation file. An activation disk can be used to activate the software. This is different from a key disk (Master Disk) in that at least one license of the software must be available on the activation disk to activate the software.

**Activation file** — A hidden, read-only, system file that “activates” a Rockwell Software product. The software will run only if your system can find the correct activation file.

**Activation key** — Activation files contain a database of activation keys. Each key is particular to a certain product and must be accessible on a local or remote drive for that product to run.

**Driver** — The software interface to the hardware device that will be used to communicate between RSLinx Classic and your processor.

**Dynamic Data Exchange (DDE)** — A form of inter-process communication. When two or more programs that support DDE are running simultaneously, they can exchange information and commands.

**Key disk** — A floppy disk that can be used to activate the software even if that disk contains zero licenses. The Master Disk is the only key disk. This differs from an activation disk in that an activation disk must contain at least one license.

**License** — Authorization to use a specified number of instances of software. A product’s activation key contains a license for each copy of the software you have purchased. For example, if you bought seven copies of RSLinx Classic, then the RSLinx Classic key on the Master Disk contains seven “licenses” of RSLinx Classic. You can move the activation file for RSLinx Classic to seven different computers.

**Links** — The data path established for one or more channels between two or more stations. DDE links can be hot, warm, or cold.

**Master disk** — This disk is supplied with the software. It contains a database of keys in an “activation file” that enables the software to run. Be sure to store your Master Disk in a safe place. If your activation file becomes damaged, the only way you can run your software (until the activation is reset) is with your Master Disk.
OPC — Provides an industry-standard mechanism to communicate and exchange data between clients and servers using OLE technology.

Packet — The transmission unit exchanged at the network layer.

Poke — DDE’s version of a write.

Read — To acquire data from somewhere (memory, an output, another station).

Topic — Represents a specific path to a processor.

Write — To load data into somewhere (memory, an output, another station).
Index

A
activation ■ 31, 41
EVRSI ■ 36
activate ■ 36
damaged ■ 38
moving ■ 39
network ■ 39
removing ■ 37
resetting ■ 39
troubleshooting ■ 39
utilities ■ 38
FactoryTalk
activate ■ 31
activation file ■ 32
Host ID ■ 32
Internet access ■ 33
local node-locked ■ 32
mobile node-locked ■ 33
node-locked activation ■ 32
anti-virus software ■ 37
application workspace ■ 13
Assistance Central ■ 29
autorun ■ 16

C
CHECKDRIVES ■ 36, 39
classes ■ 29
close ■ 11
communications device ■ 16
compressing the hard drive ■ 37
configure a driver ■ 7
configure a topic ■ 8
diagnostic ■ 12, 25
control definitions ■ 25
Control menu ■ 10
copy a link ■ 9

D
defragmentation utilities ■ 37
delisting the software directory ■ 39
diagnostics ■ 12
directory location ■ 17
document conventions ■ 2
documentation set ■ 1
driver configuration ■ 7
Dynamic Data Exchange ■ 22

electronic book format ■ 1, 29
ethernet card ■ 16
EvMove ■ 37
EVRSI ■ 36

F
FactoryTalk Activation ■ 31
FactoryTalk Administration Console ■ 43
FactoryTalk Automation Platform ■ 41
feedback ■ 2

G
Gateway version ■ 5

H
hard drive space ■ 15
hardware requirements ■ 15
Host ■ 32

I
install
FactoryTalk Automation Platform ■ 41
RSLinx Classic ■ 15
RSSecurity Emulator ■ 41
intended audience ■ 1
size ■ 10, 47
software license agreement ■ 17
software requirements ■ 16
standard setup ■ 17
starting RSNetWorx for DeviceNet ■ 15, 18
status bar ■ 13
step-by-step procedures ■ 25, 27
support ■ 29
support library ■ 29
SVGA graphics adapter ■ 16
system administrator
  privileges ■ 15
system requirements ■ 15

tasks ■ 27
technical support ■ 29
title bar ■ 10
toolbar ■ 12
topic configuration ■ 8
training ■ 29
troubleshooting

EVRSI activation ■ 39
installation ■ 18
types of RSLinx Classic ■ 3

U
uncompressing the hard drive ■ 37
updating an existing installation ■ 17
upgrading the operating system ■ 37

V
version numbers ■ 30

W
What’s This? help ■ 26
Windows
  2000 ■ 16
  2003 ■ 16
  98 ■ 16
  Me ■ 16
  NT ■ 16, 39
  XP ■ 16
RSLinx Classic Getting Results Guide