Preface

Purpose of this document

This getting results guide provides you with information on how to install and navigate the RSNetWorx™ for DeviceNet™ software. It explains how to effectively use the RSNetWorx for DeviceNet software and how to access and navigate the online help.

Intended audience

We assume that you are familiar with:

- IBM® compliant personal computers
- Microsoft® Windows® operating systems
- RSLinx® Classic™ communications software

How does the getting results guide fit in with other Rockwell Software product documentation?

The Getting Results with RSNetWorx for DeviceNet guide can be considered the entry point into Rockwell Software’s documentation set for this product. Other components of the documentation set include online help, Online Books, a product tutorial, and electronic release notes.

The documentation set contains pertinent, easily accessible product information. This set ships with the software product, and is designed to free you from tedious paper shuffling and reduce information overload.

Online help

The online help includes all overview, procedural, screen, and reference information for the product. The help contains these basic components: overview topics, quick start topics, step-by-step procedures, troubleshooting topics, and screen element descriptions (for example, text boxes, drop-down lists, and option buttons). All of the help is context-sensitive with the application and provides you with immediate access to application tasks and screen element descriptions. Refer to the “Finding the information you need” chapter in this guide for a more detailed description of the online help.

Product Manuals

Within RSNetWorx for DeviceNet, we provide a Product manuals feature that allows you to immediately access and search your product documentation from the Help menu. This feature includes the Getting Results with RSNetWorx for DeviceNet guide, as well as
several hardware product reference guides, in an electronic book format. As a part of the product installation, you have the option of installing these electronic books to your local hard drive during installation, or access them directly from the CD-ROM.

*Note: The Product Manuals included with RSNetWorx for DeviceNet are in portable document format (PDF), and must be viewed using the Adobe® Acrobat® Reader software included on your RSNetWorx for DeviceNet CD. You can install or run Acrobat Reader directly from the CD.*

**Tutorial**

RSNetWorx for DeviceNet contains a product tutorial, which includes basic overview information and specific tasks and examples for successfully working with the product. This tutorial is available from Start > Programs > Rockwell Software > RSNetWorx > RSNetWorx for DeviceNet Tutorial.

**Document conventions**

The conventions used throughout this document for the user interface comply with those recommended by Microsoft. If you are not familiar with the Microsoft Windows user interface, we recommend that you read the documentation supplied with the operating system you are using before attempting to use this software.

**Feedback**

Please use the feedback form packaged with your software to report errors or let us know what information you would like to see added in future editions of this document. You can also send an email message to info@software.rockwell.com with any comments about Rockwell’s products and services.
Contents

Preface iii

Purpose of this document .......................................................... iii
Intended audience ................................................................. iii
How does the getting results guide fit in with other Rockwell Software product documentation? .......................................................... iii
Online help .............................................................................. iii
Product Manuals ...................................................................... iii
Tutorial .................................................................................... iv
Document conventions ................................................................ iv
Feedback .................................................................................. iv

1 • Welcome to RSNetWorx for DeviceNet 1

Features and benefits ............................................................... 1
Understanding DeviceNet concepts ........................................... 3
Exploring RSNetWorx for DeviceNet ........................................ 4
  Title bar .................................................................................. 5
  Menu bar .................................................................................. 6
  Tool bars .................................................................................. 7
  Hardware and Favorites lists .................................................... 9
  Configuration view .................................................................. 10
  Diagnostics view .................................................................... 11
  Message view ......................................................................... 12
  Status bar ................................................................................ 13
  Quick Start steps .................................................................... 13
  Online mode .......................................................................... 14
  Offline mode .......................................................................... 16

2 • Installing and Starting RSNetWorx for DeviceNet 19

Before you begin ....................................................................... 19
  Considerations when using RSLinx Classic .............................. 19
  Activation ............................................................................... 19
System requirements ................................................................... 20
  Hardware requirements ............................................................ 20
  Software requirements ............................................................. 21
Software Compatibility ............................................................. 21
Installing RSNetWorx for DeviceNet ................................................. 21
Installing a client copy from a dedicated server ............................ 22
Updating an existing installation ..................................................... 23
Starting RSNetWorx for DeviceNet software ............................... 23
Troubleshooting installation ......................................................... 24

3 • Advanced Concepts ................................................................ 25
EDS-based devices ................................................................. 25
EDS library ................................................................................. 25
DeviceNet node commissioning tool ........................................... 26
Commissioning devices on a DeviceNet network ....................... 26
Commissioning a device via a point-to-point connection .......... 27
Faulted Address Recovery Wizard ............................................. 27
Class Instance Editor ............................................................... 28

4 • Finding the Information You Need .......................................... 29
Using the online help ............................................................... 29
Accessing help for a control or field ......................................... 30
Accessing help for error messages ........................................... 30
Finding step-by-step procedures .............................................. 32
Finding definitions ..................................................................... 33
Accessing the Product Manuals .............................................. 34
Accessing the Answer Station .................................................. 34
Tutorial ..................................................................................... 35
Training .................................................................................... 36
Technical support ..................................................................... 36
When you call ............................................................................ 36

A • Activation ............................................................................. 37
Protecting your activation files ................................................... 37
Activating RSNetWorx for DeviceNet ....................................... 38
Running the activation utilities ............................................... 38
Finding more information about activation .............................. 39
Some common questions .......................................................... 39
My activation files were damaged. What should I do? .............. 39
I accidentally deleted the software directory on my hard drive. Do I need to call Rockwell Software for replacement activation files? ............. 40
Why can’t I move activation to a new floppy disk on a Windows NT system? .. 40
B • Security  41
  How do I set up security in RSNetWorx? ................................. 41
  What can I secure in RSNetWorx? ..................................... 44

Glossary  47

Index  49
Welcome to RSNetWorx for DeviceNet

RSNetWorx for DeviceNet is a 32-bit Windows application program that allows you to configure DeviceNet devices. Using a graphical or spreadsheet representation of your network, you can configure all devices on the network.

This chapter contains the following sections:

- Features and benefits
- Understanding DeviceNet concepts
- Exploring RSNetWorx for DeviceNet
- Quick Start steps

Features and benefits

The current release of RSNetWorx for DeviceNet contains the following features:

- RSNetWorx now supports RSAssetSecurity™. RSAssetSecurity is intended to improve the security of your automation system by limiting access to those with a legitimate need. RSAssetSecurity authenticates user identities and authorizes user requests to access a FactoryTalk-enabled system. These security services are fully integrated into the FactoryTalk Directory and are included as part of the FactoryTalk Automation Platform that installs with many products.
- DeviceNet Tag Generator is supported. The DeviceNet Tag Generator lets you create individual structured tags in RSLogix 5000 for each DeviceNet device. For more information, read the Tag Generator Online Help available from Start > Programs >Rockwell Software > RSLogix 5000 > DeviceNet Tag Generator.
- 1756-DNB/C (Major Revision 10) that supports larger ADR sizes is supported.
- This version allows you to change the 1756-DNB Major revision 7 configuration while the scanner is in run mode.
- Embedded EDS is supported. With this functionality, you can now change the state of your device from unknown to known by uploading and registering its EDS, instead of obtaining the EDS file from an external website or a CD.
- We have changed support of Flex I/O (1793, 1794, 1797) on DeviceNet to use an EDS based approach. Although the user interface is different from the one previously presented: the date in your .DNT files will be automatically converted to the new format needed for the EDS based approach; the capabilities are a superset of what you could do with older method; the new method allows modules to be added to the software by adding a new EDS file for the module; and the user interface is consistent with the EDS based method used for most devices on DeviceNet.
- A Windows-based point and click interface that allows you to easily configure DeviceNet devices.
A user interface that allows you to browse online through various networks, devices, bridges, etc., to choose the network you want to view.

Simplified, task-oriented device configuration.

The ability to edit configurations either online or offline.

The ability to go online and scan the current network for devices. If any devices are discovered that are not already in the current configuration, they can be added to the configuration.

Simple and complete network upload/download. You can upload a configuration directly from the network or download a configuration to the online network.

Comprehensive support for Electronic Data Sheet-based (EDS) descriptions of devices. Add new device descriptions, or update them via floppy disk, the Internet, or from the device itself.

Tools to resolve differences between product revisions if your online devices and offline devices do not match.

Support for advanced Rockwell Automation scanner features, such as shared inputs and automatic device replacement (ADR).

Comprehensive context-sensitive online help in the HTMLHelp format.

Reports generated in HTML format.
If you have purchased an activation for RSNetWorx MD, you will also be able to:

- quickly detect and resolve conditions that arise when initially commissioning a system, minimizing initial start-up times and costs.
- debug and correct network/device problems, thereby reducing network downtimes and related costs.
- detect preventive maintenance needs within the devices on your network, thereby preventing system downtimes.

**Understanding DeviceNet concepts**

The DeviceNet network is a control area network that logically connects input/output (I/O) devices to processors via DeviceNet scanners rather than directly to discrete I/O modules located in processor racks. Scanners reduce the burden placed on processors by handling all the I/O device management.

Each DeviceNet network supports up to 64 nodes. The data rate and node address of all the devices connected to the network are user-configurable. Both the signal and the power wires are bundled in the same cable. Several different types of connectors are available. The signal lines are terminated at each end to insure that the line remains balanced.

The topology of a DeviceNet network can be a drop line configuration (devices are connected to the network by drop lines and network taps), a trunk line configuration (devices are connected in a daisy chain fashion), or any combination of these configurations. For example, several devices could be daisy-chained together and then connected to the network via a network tap.

The DeviceNet specification is maintained by the Open DeviceNet Vendor’s Association, Inc. (ODVA). ODVA is an independent organization of product suppliers. For more information about ODVA products and services, visit their web site at [http://www.odva.org](http://www.odva.org).
Exploring RSNetWorx for DeviceNet

When you start RSNetWorx for DeviceNet software, the RSNetWorx for DeviceNet window appears. It shows the current network (DeviceNet is the default name) in its view. The following illustration shows the RSNetWorx for DeviceNet window and the design elements associated with it. Each of the design elements are described in the sections following this illustration.
Title bar

The title bar shows the RSNetWorx icon, the name of the current RSNetWorx configuration, the name of the software product, (i.e., RSNetWorx for DeviceNet), and the Minimize, Maximize, and Close buttons.

To view the Control Menu, click the RSNetWorx icon on the title bar. The following items appear on the Control Menu.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Restore</td>
<td>Restores the window to its former size after you enlarged it by using the Maximize command or shrunk it by using the Minimize command.</td>
</tr>
<tr>
<td>Move</td>
<td>Allows you to reposition the window on the desktop using the arrow keys on the keyboard.</td>
</tr>
<tr>
<td>Size</td>
<td>Allows you to resize the window by using the arrow keys on the keyboard.</td>
</tr>
<tr>
<td>Minimize</td>
<td>Shrinks the window to an icon, which is located on the task bar. This performs the same function as if you clicked the Minimize button on the title bar.</td>
</tr>
<tr>
<td>Maximize</td>
<td>Enlarges the window to occupy the entire screen. This performs the same function as if you clicked the Maximize button on the title bar.</td>
</tr>
<tr>
<td>Close</td>
<td>Exits the RSNetWorx application. This performs the same function as if you clicked the Close button on the title bar.</td>
</tr>
</tbody>
</table>
**Menu bar**

The RSNetWorx for DeviceNet menu bar contains the following menus:

<table>
<thead>
<tr>
<th>Menu</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>File</td>
<td>Create, print, and save a network configuration, or exit RSNetWorx for DeviceNet.</td>
</tr>
<tr>
<td>Edit</td>
<td>Invoke actions such as cut, copy, and paste on selected items in the network configuration.</td>
</tr>
<tr>
<td>View</td>
<td>Set and change RSNetWorx for DeviceNet interface displays and access specialized tools.</td>
</tr>
<tr>
<td>Network</td>
<td>Choose browsing options, upload or download network information, or view network properties.</td>
</tr>
<tr>
<td>Device</td>
<td>Upload or download device information, resolve device mismatches, or view device properties.</td>
</tr>
<tr>
<td>Diagnostics</td>
<td>Start and stop diagnostics, add/remove devices from the diagnostic scan, select and troubleshoot a fault, specify diagnostic options, or generate a diagnostics report.</td>
</tr>
<tr>
<td>Tools</td>
<td>Access the EDS Wizard, the node commissioning tool, or the Faulted Address Recovery (FAR) wizard.</td>
</tr>
<tr>
<td>Help</td>
<td>View help options for RSNetWorx for DeviceNet and other Rockwell Software products and services.</td>
</tr>
</tbody>
</table>
Tool bars

The tool bars contain shortcuts to several commonly used functions. Each button on the tool bars is a graphical representation of a command (except the Symbol Legend) that is also available from the RSNetWorx for DeviceNet menu bar. RSNetWorx for DeviceNet contains the standard tool bar and the tools tool bar.

The following items appear on the RSNetWorx for DeviceNet standard tool bar.

<table>
<thead>
<tr>
<th>Icon</th>
<th>Menu Selection</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>![File Icon]</td>
<td>File &gt; New</td>
<td>Creates a new network configuration.</td>
</tr>
<tr>
<td>![File Icon]</td>
<td>File &gt; Open</td>
<td>Opens an existing network configuration. The arrow to the right of the Open icon provides quick access to recently used files.</td>
</tr>
<tr>
<td>![File Icon]</td>
<td>File &gt; Save</td>
<td>Saves the current network configuration.</td>
</tr>
<tr>
<td>![File Icon]</td>
<td>File &gt; Print</td>
<td>Prints the current network configuration.</td>
</tr>
<tr>
<td>![Edit Icon]</td>
<td>Edit &gt; Cut</td>
<td>Cuts the selected device from the network configuration and places it on the clipboard.</td>
</tr>
<tr>
<td>![Edit Icon]</td>
<td>Edit &gt; Copy</td>
<td>Copies the selected device to the clipboard.</td>
</tr>
<tr>
<td>![Edit Icon]</td>
<td>Edit &gt; Paste</td>
<td>Pastes the device from the clipboard to the current network configuration.</td>
</tr>
<tr>
<td>![Help Icon]</td>
<td>Help &gt; What’s This?</td>
<td>Places the cursor in What’s This? help mode. Place the cursor on the control you want help with and right-click to see the context-sensitive help.</td>
</tr>
</tbody>
</table>
The following items appear on the RSNetWorx for DeviceNet tools tool bar.

<table>
<thead>
<tr>
<th>Icon</th>
<th>Menu Selection</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image1.png" alt="Icon" /></td>
<td>View &gt; Zoom-In</td>
<td>Increases the size of the images located in the current network configuration. The choices available are high, medium, and low. Zoom-In only applies to the graph view.</td>
</tr>
<tr>
<td><img src="image2.png" alt="Icon" /></td>
<td>View &gt; Zoom-Out</td>
<td>Decreases the size of the images located in the network configuration. The choices available are high, medium, and low. Zoom-Out only applies to the graph view.</td>
</tr>
<tr>
<td><img src="image3.png" alt="Icon" /></td>
<td>View &gt; Hardware</td>
<td>Displays a list of all available hardware devices.</td>
</tr>
<tr>
<td><img src="image4.png" alt="Icon" /></td>
<td>View &gt; Favorites</td>
<td>Displays a list of hardware devices that you have added to your favorites list.</td>
</tr>
<tr>
<td><img src="image5.png" alt="Icon" /></td>
<td>Network &gt; Single Pass Browse or Network &gt; Continuous Browse</td>
<td>Locates all currently available devices based on the drivers configured in RSLinx Classic. Allows you to browse once and stop (single pass) or browse continuously (continuous browse).</td>
</tr>
<tr>
<td><img src="image6.png" alt="Icon" /></td>
<td>Network &gt; Online</td>
<td>Places RSNetWorx for DeviceNet in online mode. To go offline, click the button or choose Network &gt; Online again.</td>
</tr>
<tr>
<td><img src="image7.png" alt="Icon" /></td>
<td>View &gt; Diagnostics</td>
<td>Displays the Diagnostic view, allowing you to view the diagnostic parameters for all of the devices on your network, and indicates the current diagnostic status of your network. These functions are only available when the RSNetWorx MD activation is available.</td>
</tr>
<tr>
<td><img src="image8.png" alt="Icon" /></td>
<td>View &gt; Refresh</td>
<td>Refreshes the window. This will reorder the graphic display by device address.</td>
</tr>
<tr>
<td><img src="image9.png" alt="Icon" /></td>
<td>No menu selection</td>
<td>Displays the Symbol Legend, which contains descriptions of the device comparison states.</td>
</tr>
</tbody>
</table>
Hardware and Favorites lists

A device can be added to the network configuration by selecting it from the Hardware view and dragging it to the Configuration view. Once a device is added, it will display in the appropriate configuration. The Favorites view displays all hardware devices that you have defined as favorites by selection from the Hardware list.
**Configuration view**

The Configuration view displays network information in a graphical, spreadsheet, or master/slave form. For example, this graphical application workspace shows the devices that currently exist on the network. The Spreadsheet view of the configuration displays the names of all devices on the network along with state, node, slot, and description information. You can add a device to the project by selecting it from the Hardware view and dragging it into the configuration view. The Master/Slave Configuration view displays any scanner to target device relationships that exist among the devices in your current DeviceNet configuration.
Diagnostics view

RSNetWorx MD provides a hierarchal view of the real-time status (or health) of a network. At a glance, you can quickly and easily determine the overall status of your network, or any device on your network, by viewing a single status indicator. Click the Diagnostics tab in the network configuration to display this view.

Note: If you have not purchased an activation for RSNetWorx MD, you will be unable to perform the diagnostics functionality. For more information, see the overview of the RSNetWorx MD functionality in the online help.
Message view

The Message view, which appears in the bottom portion of the workspace, displays a log of messages. Each message consists of the following four parts:

- an icon
- an error code (including a distinguishing software component designator and a 16-bit numeric designator)
- a timestamp that displays the date and time the message is generated
- a description of the message

This view may contain informational, warning, and/or error messages, as indicated in the following table:

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Error" /></td>
<td>Error</td>
</tr>
<tr>
<td><img src="image" alt="Warning" /></td>
<td>Warning</td>
</tr>
<tr>
<td><img src="image" alt="Informational" /></td>
<td>Informational</td>
</tr>
</tbody>
</table>

Note: If you want more information on any particular message, you can select the message and press the F1 key to access the online help. You can show, clear, copy, and/or clear and hide messages by making the appropriate selection from the View > Messages command on the main menu, or by right-clicking and selecting the Message option while in the Message view.
Status bar

The status bar, which is located at the bottom of the RSNetWorx for DeviceNet main window, provides information about the status of the software.

The left portion of the status bar displays informational messages about the operation of RSNetWorx for DeviceNet software. For example when you highlight a device in the configuration view, a brief description of that device appears on the status bar.

The right portion of the status bar displays the following:

- Offline
- Online - Not Browsing
- Starting Browse...
- Browsing - Node address or Node, slot address

Quick Start steps

This section walks you through the tasks you will need to perform in order to use RSNetWorx for DeviceNet software. To remain focused on the high-level nature of each task and the flow of these tasks, the following steps do not include the step-by-step procedure for accomplishing each task. When you are ready to use RSNetWorx for DeviceNet software, you should follow the detailed procedures found in the Quick Start, which is located in the RSNetWorx for DeviceNet online help.

To access the online quick start, select Help > Quick Start from the menu bar on the RSNetWorx for DeviceNet window. To view information about any control in the RSNetWorx for DeviceNet software, remember to use the What’s This? help (available by positioning the cursor over a control and right-clicking the mouse).
Online mode

Before you start

Before you can add a device to a DeviceNet network, it may need to be commissioned. This means that the node address and the data rate must be programmed into the device. Node commissioning, which is also called device commissioning, is the process of assigning a node address and a data rate to a device for use on a DeviceNet network. The node address and data rate are referred to as the network parameters.

Most DeviceNet devices are factory commissioned with default values per the DeviceNet specification. Usually, the node address is set to 63 and the data rate is set to 125K baud. As long as the factory default parameters do not conflict with those of other devices already on the network, you can connect the new device to the network and then use the Node Commissioning tool within the RSNetWorx for DeviceNet software to change the node address and data rate. If the data rate conflicts, use a separate network to commission the device or a local connection between the device and the PC.

Some devices do not support software-based node commissioning. For those devices, the product will have some alternative way (for example, thumbwheel switches) to set the address and data rate. See the specific device’s documentation for more information.

Step 1 – Create a new configuration and browse for an online network

The first step in using RSNetWorx for DeviceNet in the online mode is to create a new DeviceNet configuration (by selecting File > New). Once you create the configuration, an empty network displays in the Configuration view.

Next, go online and select a communications driver using the RSWho browse utility. A graphical representation of the network appears in the Configuration view. If you would like to see a tabular view of the information, select the Spreadsheet tab or the Master/Slave tab.

Note: At various times, you may want to save the work you have completed on your network configuration. To save a configuration file (*.dnt), click File > Save.

Step 2 – Upload and configure the online DeviceNet network

After creating your configuration and going online, you must upload the configuration of each device and the entire DeviceNet network. Once your configuration has been uploaded, you can then edit your network properties. Editing network properties includes entering a network name and description.
Step 3 – Configure the DeviceNet devices

After uploading and configuring the entire DeviceNet network, you must configure the devices on the network. To configure a device, select a device in the configuration view and choose **Device > Properties** from the main menu. Configuring your devices consists of tasks like:

- configuring general device properties
- editing and monitoring device parameters

In addition you can also view I/O message data and the contents of the EDS file.

As you configure each device, you may need to choose to upload from the device or download to the device before changing its configuration. This reconciliation process keeps the online device and the current configuration synchronized. When you are in online mode, the configuration displayed for the device represents the configuration in the online device.

Step 4 – Configure the DeviceNet scanner

When you have completed your device configuration(s), you can then configure the scanners on your DeviceNet network. To configure a scanner, select a scanner in the configuration view and choose **Device > Properties** from the main menu. Configuring your scanner includes advanced tasks like configuring a scanlist (a list of the devices that you want the scanner to scan), and mapping device input and output data. In addition, you may also want to configure general device properties, specify module parameters (including scan-time related items), or view a summary of the scanner configuration.

Step 5 – Save your network configuration

The final step is to save your DeviceNet configuration information to a file. To save your configuration file (*.dnt), select **File > Save**. Your DeviceNet devices are now configured and ready to use.

You can use the RSNetWorx for DeviceNet software to further customize your DeviceNet configuration. For example, you can re-assign node addresses, modify a device’s configuration, etc. And, when you are not using these applications to configure your network, you can use RSNetWorx for DeviceNet software to monitor and troubleshoot the devices on your network. For information on how to accomplish these tasks, see the comprehensive online help.

*Note: If you have not purchased the required activations for RSNetWorx, the advanced capabilities described in steps 6 and 7 will not be available. For more information on these advanced capabilities, contact your local Rockwell Automation sales office or see the following topics in the RSNetWorx online help: RSNetWorx MD, RSNetWorx MD Service Monitor, RSNetWorx Device Health Logging, and RSNetWorx Audit Logging.*
Step 6 - Diagnose and troubleshoot your online network

Once you save your configuration, you can diagnose the network and determine the status of all of the devices on that network. If any of the devices are exhibiting diagnostics problems, you can troubleshoot those devices and return your network to proper operating condition.

Step 7 - Schedule network diagnostics

After diagnosing and troubleshooting your online network, you can schedule diagnostics to occur for each network that has an associated offline configuration file (*.dnt) developed in RSNetWorx, allowing you to support an unattended, background mode of diagnostic operation. Further, via the RSNetWorx MD Service Monitor, you can start, stop, and establish the startup mode for each network diagnostic schedule that you have configured.

Offline mode

Step 1 – Create a new configuration and describe your network topology

The first step in using RSNetWorx for DeviceNet in the offline mode is to create a new DeviceNet configuration (by selecting File > New). Once you create the configuration, an empty network displays in the Configuration view.

Next, describe your network topology by dragging a device or scanner from the Hardware view and dropping it in the network configuration. Repeat this process until you have defined your entire DeviceNet network in the software. If you would like to see a tabular view of the information, select the Spreadsheet tab or the Master/Slave tab.

*Note: At various times, you may want to save the work you have completed on your network configuration. To save a configuration file (*.dnt), click File > Save.*

Step 2 – Configure the DeviceNet network

After creating your configuration, you can edit your network properties. Editing network properties includes entering a network name and description.
Step 3 – Configure the DeviceNet devices

After configuring your DeviceNet network, you can configure the devices on the network. To configure a device, select a device in the configuration view and choose Device > Properties from the main menu. Configuring your devices consists of tasks like:

- configuring general device properties
- editing and monitoring device parameters

In addition you can also view I/O message data and the contents of the EDS file.

Step 4 – Configure the DeviceNet scanner

When you have completed your device configuration(s), you can then configure the scanners on your DeviceNet network. Configuring your scanner includes advanced tasks like configuring a scanlist (a list of the devices that you want the scanner to scan), and mapping device input and output data. In addition, you may also want to configure general device properties, specify module parameters (including scan-time related items), or view a summary of the scanner configuration.

Step 5 – Save your network configuration

The final step is to save your DeviceNet configuration information to a file. To save your configuration file (*.dnt), select File > Save. Your DeviceNet devices are now configured and ready to use.

You can use the RSNetWorx for DeviceNet software to further customize your DeviceNet configuration. For example, you can re-assign node addresses, modify a device’s configuration, etc.
Installing and Starting RSNetWorx for DeviceNet

This chapter explains how to install and start RSNetWorx for DeviceNet software. This chapter includes information on the following:

- system requirements
- software compatibility
- installation methods
- installation procedure
- starting procedure
- troubleshooting

After installing the software, we recommend that you read the release notes located in the online help. The release notes may contain more up-to-date information than was available when this document was published. To view the release notes, start RSNetWorx for DeviceNet, and then choose Help > Release Notes from the main menu.

Before you begin

Before you begin to install RSNetWorx for DeviceNet software, you should know about some activation considerations.

Considerations when using RSLinx Classic

Before you can use RSNetWorx for DeviceNet software, you must install RSLinx Classic software. To ensure that you are using the most current and compatible version of RSLinx Classic, it is also included on the RSNetWorx for DeviceNet CD.

*Note: If the installation program encounters an incompatible and/or previous version of RSLinx Classic on your computer, it will notify you to install the version of RSLinx Classic included on the RSNetWorx for DeviceNet CD.*

Activation

Rockwell Software uses a software key to implement copy protection for Windows-based software products. Every software product has a unique key. The key is located in an activation file, which is on a Master disk that was shipped with your software. You can install the software on any number of computers; however, you are only licensed to run the software on one computer at a time per license. After you install the RSNetWorx for DeviceNet software, the Setup program will prompt you to insert the RSNetWorx for DeviceNet Master disk into your disk drive. Then, the Move Activation utility will move a unique key from the RSNetWorx for DeviceNet Master disk to your hard disk. If, at a
later date, you want to move the activation to another computer, or just remove it altogether, you will have to move the key back onto the Master disk. For more information about moving software keys, copy protection, and software activation, see Appendix A.

Notes: Installing, uninstalling, or updating the software does not affect the activation, other than when you are prompted to move activation.

If you are updating to a new version of the software, you do not need to move the activation.

System requirements

To run RSNetWorx for DeviceNet, your system must meet the following minimum hardware and software requirements:

Hardware requirements

To run RSNetWorx for DeviceNet, your system must meet the following hardware requirements:

- an Intel Pentium™ or Pentium-compatible microprocessor, including hyper-threading models
- 32 MB of RAM
- 1259 MB of maximum disk space (EDS files take 683 MB). These sizes are based on a Microsoft FAT file system. A Microsoft NTFS file system will use much less space.
- a CD-ROM drive
- a 3.5-inch 1.44 MB diskette drive
- 16-color VGA graphics adapter (640 x 480 resolution minimum, 800 x 600 resolution recommended)
- a mouse or other Windows compatible pointing device is recommended

If you will be using a 1784-PCIDS adapter card, it must have version 1.08 or later firmware and you will need to install version 1.10 or later of the PCIDS device driver software. For further information about installing the 1784-PCIDS adapter card or device driver, refer to the DeviceNet PCI Communication Interface Card Installation Instructions, publication number 1784-5.31. Also, for more information about the communications interfaces supported, refer to the online help.
Software requirements

To run RSNetWorx for DeviceNet, you require one of the following operating systems:

- Microsoft Windows 2000 (Service Pack 4)
- Microsoft Windows 2000 Terminal Server
- Microsoft Windows 2003 Server (Service Pack 1)
- Microsoft Windows 2003 Terminal Server
- Microsoft Windows XP (Service Pack 2)

Software Compatibility

RSNetWorx for DeviceNet 7.00.00 is a component of Rockwell Software's latest Coordinated Product Release (CPR 7). RSNetWorx for DeviceNet 7.00.00 (CPR 7) has been tested with, and is compatible with, Rockwell Software's CPR 7 release of the following products:

- FactoryTalk Automation Platform (2.00.10)
- RSLinx Classic (2.50.00)
- RSLogix 5 (7.00.00)

RSNetWorx for DeviceNet 7.00.00 has also been tested with RSLogix 5000 (v12, v13, v14, v15).

Note: It is recommended that you use all products from the same CPR release.

Installing RSNetWorx for DeviceNet

You can install one or more Rockwell Software products to a single personal computer. Select the required Rockwell Software product and each required component for installation.

Notes: While installing RSNetWorx for DeviceNet software, you will have the opportunity to specify a directory. The suggested default directory is:

```
x:\Program Files\Rockwell Software\RSNetWorxII
```

where x is the drive where the operating system is installed.

We recommend that you use the default directory whenever possible. This subdirectory contains all of the application files required to run the product.

In procedures that appear throughout this document, it is assumed that you used the default name. If you did not use the default name, substitute the actual name you specified for the default name shown.
To install RSNetWorx for DeviceNet software, perform the following steps:

1. Start your operating system if it does not start automatically.
2. Insert the RSNetWorx for DeviceNet CD-ROM into the CD-ROM drive.

<table>
<thead>
<tr>
<th>If autorun is:</th>
<th>Then:</th>
</tr>
</thead>
<tbody>
<tr>
<td>enabled</td>
<td>The Setup program starts automatically and the RSNetWorx for DeviceNet opening screen appears. Proceed to step 3.</td>
</tr>
<tr>
<td>disabled</td>
<td>Perform the following steps:</td>
</tr>
<tr>
<td></td>
<td>1. Click <strong>Start</strong>, and then click <strong>Run</strong>. The Run dialog box appears.</td>
</tr>
<tr>
<td></td>
<td>2. In the Open field, type `x:\autorun`, where \x is the letter of the drive containing the RSNetWorx for DeviceNet CD-ROM.</td>
</tr>
<tr>
<td></td>
<td>3. Click <strong>OK</strong>. The RSNetWorx for DeviceNet selection dialog box appears.</td>
</tr>
</tbody>
</table>

3. Follow the instructions that appear on the screen to install RSNetWorx for DeviceNet and any other required software packages.
4. At your discretion, follow the instructions that appear on the screen to install any optional software packages.
5. When you are finished installing the software, remove the RSNetWorx for DeviceNet CD-ROM from the CD-ROM drive and the Master disk from the disk drive. Store them in a safe place.

**Installing a client copy from a dedicated server**

As a client to a client-server installation, you can install one or more Rockwell Software products from the dedicated server location to an end-user destination. To install the RSNetWorx for DeviceNet software from the server, perform the following steps:

1. Map a network drive to the dedicated server location provided by your system administrator. The system administrator must have copied the entire CD contents, and provided only Read and Execute permissions of the files. Users installing the software cannot have write access to the files.
2. Double-click autorun.exe in the client installation directory.
3. See the “Installing RSNetWorx for DeviceNet Software” section in this chapter.
Updating an existing installation

Perform the following steps to update an existing installation to a newer version:

1. From the Start menu, select **Settings > Control Panel**.

2. To remove the existing installation, double-click the Add/Remove Programs icon, select RSNetWorx for DeviceNet from the list, and click **Add/Remove**. Click **OK** to close the Add/Remove Programs dialog box.

3. Insert the RSNetWorx for DeviceNet CD-ROM into the CD-ROM drive.

**If autorun is:** **Then:**

<table>
<thead>
<tr>
<th>enabled</th>
<th>The installation program starts automatically and the selection dialog box appears. Proceed to step 4.</th>
</tr>
</thead>
<tbody>
<tr>
<td>disabled</td>
<td>Perform the following steps:</td>
</tr>
<tr>
<td>1.</td>
<td>Click <strong>Start</strong>, and then click <strong>Run</strong>. The Run dialog box appears.</td>
</tr>
<tr>
<td>2.</td>
<td>In the Open field, type <code>x:\autorun</code>, where <code>x</code> is the letter of the drive containing the RSNetWorx for DeviceNet CD-ROM.</td>
</tr>
<tr>
<td>3.</td>
<td>Click <strong>OK</strong>. The selection dialog box appears.</td>
</tr>
</tbody>
</table>

4. Follow the instructions that appear on the screen. For more information, see the “Installing RSNetWorx for DeviceNet Software” section in this chapter.

*Note: If activation was previously installed, it is not necessary to move the activation. If activation was not previously installed, insert the Master disk into the 3.5-inch disk drive and follow the instructions that appear on the screen. For more information on activation, see Appendix A.*

Starting RSNetWorx for DeviceNet software

To start RSNetWorx for DeviceNet software, click **Start**, and then select **Programs > Rockwell Software > RSNetWorx (folder) > RSNetWorx for DeviceNet** (executable).

To create a desktop icon, click **Start**, and then select **Programs > Rockwell Software > RSNetWorx for DeviceNet shortcuts**, and drag the RSNetWorx for DeviceNet shortcut to the location of your choice.

*Note: We assume that you used the default names for the directory and program group. If you did not use the default names, substitute the actual names that you specified for the default names shown.*
Troubleshooting installation

If RSNetWorx for DeviceNet does not start up or run properly, consider the following:

- Do you have the correct version of RSLinx Classic installed? RSNetWorx for DeviceNet requires RSLinx Lite 2.2 Service Pack 1 or later.
- Does your computer have enough memory? Running RSNetWorx for DeviceNet requires a minimum of 32 MB of RAM.
- Have you reinstalled an earlier Service Pack, or removed a component, such as DCOM, that RSNetWorx for DeviceNet requires?
- Have you checked the RSNetWorx support on the web for troubleshooting information? Go to http://support.rockwellautomation.com, click Knowledgebase, and search for Tech Notes on RSNetWorx for DeviceNet.
- Have you checked the RSNetWorx Answer Station? In RSNetWorx, select Help > RSNetWorx Assistance on the Web.
Advanced Concepts

This chapter contains the following sections:

- EDS-based devices
- EDS library
- DeviceNet node commissioning tool
- Faulted Address Recovery wizard
- Class Instance Editor

**EDS-based devices**

RSNetWorx for DeviceNet relies on an electronic data sheets (EDS) for configuring devices. An electronic data sheet is an ASCII file that is created by the manufacturer and supplied with the device.

As long as the EDS file for the device you want to configure is registered with the RSNetWorx for DeviceNet software, you can configure its target connection configuration (attributes) and how it will communicate with other devices on the DeviceNet network. Although the procedure for configuring a device is basically the same for all devices, each device will have a unique set of properties.

**EDS library**

The electronic data sheet (EDS) library is a collection of EDS files that have been registered with RSNetWorx for DeviceNet. The EDS files, which are provided by the device manufacturers, contain configuration and identification information for the devices.

RSNetWorx for DeviceNet software can access only those devices that have been registered. You must use the EDS Wizard for registering EDS files for unknown devices, or if you have updated EDS files to install. To access the EDS Wizard, select Tools > EDS Wizard.
Although you get a large number of electronic data sheet (EDS) files with the RSNetWorx for DeviceNet software, there may be a time when you need to acquire/create additional EDS files. The most common ways of getting these files are to:

- obtain them on distribution diskettes that accompany the devices.
- download them from DeviceNet sites on the world wide web. You can either select the device in the network configuration, right-click the mouse and select Re-register Device, and click Download EDS File in the EDS Wizard or access one of the following world wide web sites from which EDS files are available:
  - http://www.ab.com/networks/eds (Allen-Bradley technical support site)
  - http://www.odva.org (Open DeviceNet Vendor’s Association site)
- create the EDS file using the EDS Wizard.

**DeviceNet node commissioning tool**

The DeviceNet node commissioning tool lets you commission, that is, set the node address and the data rate parameters of, devices that are either connected:

- to a DeviceNet network, or
- via a point-to-point connection.

**Commissioning devices on a DeviceNet network**

Before you can add any node to a live DeviceNet network, it must be commissioned. This means that a node address and a data rate must be programmed into the device. Most devices are preset with a node address, which is usually set to 63, and a data rate, which is usually set to 125K baud. These default preset values will need to be changed to meet your application needs. Once a device has been commissioned and attached to a network, you can use the RSNetWorx for DeviceNet node commissioning tool to edit the node address that was set previously.

*Note: Some devices do not permit software setting of the node address or data rate. Refer to the device documentation for specific information.*

Exercise caution while editing node addresses when on a network. When you apply a new node address, it immediately overwrites the node address data in the device currently specified. If you re-assign node addresses, first determine the order in which this needs to be done so that all the devices will still have unique node addresses throughout the address assigning process. If your scanner supports Automatic Device Replacement (ADR), your system may automatically perform this commissioning.

For example, if two of the devices on your network are a photoelectric sensor and a hand controller and you accidentally change the node address of the hand controller to be the
same as that of the photoelectric sensor, then the hand controller will no longer have a
unique address, which means that it will not be able to communicate on the network. If
you cannot access a device, because you have used its node address for another device,
you will have to remove it from the network, recommission it, then reinstall it on the
network. For information on how to recover a faulted device, see the Faulted Address
Recovery wizard in this chapter.

**Commissioning a device via a point-to-point connection**

When the baud rate of a device does not match the DeviceNet network (for example,
when adding a new device [out of the box] or when moving a device from one DeviceNet
network to another) and the dip switches are not provided, it may be necessary to establish
a point-to-point connection to that device and prepare it for integration onto your existing
DeviceNet network. Using the Node Commissioning Tool, you can establish a point-to-
point connection to a device and change the node address and/or the data rate parameters
to match your existing DeviceNet network.

You should not change the data rate of devices while they are connected to a network; otherwise,
erratic operation may result. We recommend that if you need to change the data rate of a device,
that you complete the following:
1. Remove it from the network.
2. Establish a point-to-point connection between the PC, which hosts the RSNetWorx for
   DeviceNet software, and the target device.
3. Recommission the device.
4. Reconnect the device to the network.

**Faulted Address Recovery Wizard**

The Faulted Address Recovery wizard allows you to recover select faulted devices with
duplicate node addresses on your DeviceNet network. In addition, you can detect faulted
devices on your DeviceNet network and “flash” the LEDs on those devices to locate them
in your application.

*Notes: The faulted address recovery function is not supported by all devices. For more
information, consult your hardware documentation or contact your hardware vendor.*

*The Faulted Address Recovery feature requires RSLogix 2.20, Service Pack 1 or later.*
Class Instance Editor

The Class Instance Editor is a tool that allows you to send data to, and read data from, a DeviceNet device that is not otherwise configurable with RSNetWorx for DeviceNet. Using the Class Instance Editor, you can enter raw data and download it to the device, or read the data from the device.

We do not recommend configuring devices with the Class Instance Editor unless you are instructed to do so by technical support personnel for the hardware product.

To use the editor, you will need to know the service code, class, instance, and attribute by their appropriate hexadecimal codes within the device. This information may be available on the printed data sheet accompanying the device.

Note: For further information about configuring a device with the Class Instance Editor, contact the manufacturer of the device. For more information on how to enter data into the Class Instance Editor, contact Rockwell Software technical support.
Finding the Information You Need

Use this chapter to review the sources of additional information about RSNetWorx for DeviceNet software. This chapter helps you to find what you need efficiently by describing how to:

- Use the online help
- Access product manuals
- Access the Answer Station
- Complete the product tutorial
- Participate in Rockwell Software training courses
- Contact Technical Support

Using the online help

RSNetWorx for DeviceNet online help provides general overview information, comprehensive step-by-step procedures, and context-sensitive, dialog box control definitions for working with all of the features in the software. To view online help while running RSNetWorx for DeviceNet:

- choose Contents from the Help menu on the RSNetWorx for DeviceNet main window
- click Help on any RSNetWorx for DeviceNet dialog box or property page
- position the cursor over any control with which you want help and right-click
- press F1
- click the What’s This? icon located in the toolbar or in the upper right corner of dialog boxes, then click any control
Accessing help for a control or field

To display a definition for a control or a field, click the What’s This? icon in the upper right corner of the dialog box, drag the cursor to the selected area, and then click to display the definition. You can also right-click on a control to display the definition. In this example, the Name control was selected.

Accessing help for error messages

The message view, which appears in the bottom portion of the workspace, displays a log of messages. This view may contain informational, warning, and/or error messages.

<table>
<thead>
<tr>
<th>Message Code</th>
<th>Date</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>DNET.0102</td>
<td>1/21/2003 15:56:52</td>
<td>Mode changed to offline.</td>
</tr>
<tr>
<td>DNET.0001</td>
<td>1/21/2003 15:56:37</td>
<td>The browse operation has timed out. Verify that</td>
</tr>
<tr>
<td>DNET.0101</td>
<td>1/21/2003 15:56:14</td>
<td>Mode changed to online. The online path is F</td>
</tr>
</tbody>
</table>

To troubleshoot a particular message, you can select the message and press the F1 key or right-click on the message and select Troubleshoot to access the online help.
For example, if you select the DNET:0001 error code shown here and press F1, the browse operation has timed out help topic displays:

From the message view, you can also select a message and choose View > Messages > Troubleshoot to display online help for the message. You can also show, clear, copy, and/or clear and hide messages by making the appropriate selection from the View > Messages command on the main menu. The copy menu item copies the selected message to the Windows clipboard so it can be pasted into other applications (for example, an e-mail message).
Finding step-by-step procedures

To view a list of tasks related to the current task-based topic, move to the What do you want to do? section at the bottom of the help window and select one of the listed tasks. The contents pane of the help window is updated, displaying a step-by-step procedure for completing the selected task.

For example, from the Configuring EDS-based devices topic, if you select Learn how to configure EDS devices under the What do you want to do? section, the help topic that describes how to configure an EDS-based device appears.
Finding definitions

Within the RSNetWorx for DeviceNet help, blue text highlighted with an underline indicates a pop-up definition or a link to a related topic. For example, in the DeviceNet node commissioning tool help topic, node address is a pop-up definition. Click the link to see the definition of a node address.
Accessing the Product Manuals

You can gain immediate access to product documentation through the Product Manuals feature in RSNetWorx for DeviceNet. Product Manuals include this Getting Results Guide, as well as many reference guides, in an electronic book format. Select Help > Product Manuals to access this documentation.

Accessing the Answer Station

The RSNetWorx Answer Station is a convenient link to the vast amount of helpful information available on the Web for RSNetWorx users. This website can help increase your productivity, ensure the success of your projects, and maximize your performance. The Answer Station is divided into Documentation, Support, Downloads, and Services — four straightforward categories that will help you:

- Discover the scope of Rockwell’s offerings
- Quickly navigate to the information you need
- Access support information that will keep your project on track — including FAQs, downloads, and Knowledgebase resources
- Get the latest news about your product — documentation, Knowledgebase articles, etc.
- Easily find project jumpstart information — asset management, consulting, training, and more

To access the Answer Station, click Help > RSNetWorx Assistance on the Web.
Tutorial

RSNetWorx for DeviceNet contains a product tutorial, which includes basic overview information and specific tasks and examples for successfully working with the product. This tutorial is available from Start > Programs > Rockwell Software > RSNetWorx > RSNetWorx for DeviceNet Tutorial.
Training

One of the best ways to increase your proficiency at using Rockwell Software products is to attend a Rockwell Software training program. Our training programs can help you master the basics and show you how to unleash the full potential of our software.

We offer a wide range of training programs, from regularly scheduled classes conducted at Rockwell Software facilities, to custom-tailored classes conducted at your enterprise. The size of each class is kept small intentionally to maximize student engagement.

If you would like more information about our training programs, visit the Rockwell Software site on the World Wide Web or contact the Rockwell Software Training Coordinator. Our World Wide Web address and telephone numbers appear on the inside front cover of this document.

Note: For more information on Rockwell Software training, select Help > Support and Training from within RSNetWorx for DeviceNet.

Technical support

If you cannot find answers to your questions in the Getting Results with RSNetWorx for DeviceNet guide, the online help, or the Online Books documentation, you can call Rockwell Software Technical Support at the numbers listed on the inside front cover of this guide. You can also access the Rockwell Software Online Support Library and receive information about Autofax Product Information System from the web site listed on the inside front cover of this guide.

When you call

When you call, you should be at your computer and prepared to give the following information:

- product serial numbers
- product version number
- The product serial numbers and version number can be found in the software by selecting Help > About RSNetWorx
- hardware you are using
- exact wording of any errors or messages that appeared on your screen
- description of what happened and what you were doing when the problem occurred
- description of how you attempted to solve the problem

Note: For more information on Rockwell Software technical support, select Help > Support and Training from within RSNetWorx for DeviceNet.
Activation

Rockwell Software’s products are copy-protected. Only a computer with access to the activation key can run the software. The key is located in an activation file, which is originally located on the Master disk supplied with the RSNetWorx for DeviceNet product. The activation file contains one activation key per product. Each key contains one or more licenses depending on how many copies of the product you have purchased.

*Note: Store your Master disk in a safe place. If your activation becomes damaged, the Master disk may be the only means to run your software in an emergency.*

During the setup process, the setup program gives you the opportunity to move the activation file from the Master disk to the root directory of the drive on which you’re installing the software.

When you launch RSNetWorx for DeviceNet, the software first checks your local hard drives, then network hard drives, and finally local floppy drives for activation. If the system fails to detect either the activation file or the Master disk, you will receive an error message stating that activation is required to run the RSNetWorx for DeviceNet software; the software will run in Demo mode.

*Note: Systems attached to extensive networks can take quite a while to search for activation files on all available drives. You can use the CHECKDRIVES environment variable to specify and/or limit the drives your software checks for activation files and to specify the order in which they are checked. Refer to the activation utilities online help file by selecting Help > Copy Protection.*

Protecting your activation files

Certain anti-virus software packages, such as Norton Anti-virus, can corrupt the activation files. Configure your anti-virus software to avoid checking the files EVRSI.SYS and 386SWAP.PAR.

To avoid damaging your activation files, do not perform the following operations with activation files on the hard drive:

- Restore from backup
- Upgrade the operating system
- Compress or uncompress the hard drive

Defragmentation utilities will not harm activation files.

Before running any type of utility that may modify the structure or organization of the hard drive, remove activation from the hard drive by completing the following steps:
1. Use the Move Activation utility (EvMove) to move activation files from the hard drive to an activation disk.

Do not use the Move Activation utility if Rockwell Software products are currently running. Ensure all software programs are closed before initiating the EvMove utility.

Run EvMove by selecting Start > Programs > Rockwell Software > Utilities > Move Activation.

2. Perform the hard disk operation.

3. Move the activation files back to the hard drive.

You must use the move utility, EvMove, to move activation files. Attempts to copy, move or e-mail an activation file by other means will damage the file.

Activating RSNetWorx for DeviceNet

Depending on your needs, you can activate RSNetWorx for DeviceNet from any of the following:

Hard drive. The activation key resides on your computer’s hard disk. Use this method if you will typically use RSNetWorx for DeviceNet only on one computer. This is the default method if you activate RSNetWorx for DeviceNet during installation. To run RSNetWorx for DeviceNet on a different computer, move the activation key back to the Master disk, and then to the hard drive of the new computer.

Diskette drive. The activation key resides on a floppy disk (activation disk). Use this method if you will typically use RSNetWorx for DeviceNet on more than one computer, for example, if you want to run RSNetWorx for DeviceNet on a desktop computer at some times and a portable computer at others.

Network drive. The activation keys reside on a network drive. Use this method if you have purchased multiple licenses of the software and want several users to be able to activate the software over a network. Refer to the online help for instructions on moving activation to a network drive (refer to the “Finding more information about activation” section in this chapter to access online help).

Running the activation utilities

The utilities for moving and resetting activation are called EvMove and Reset respectively. Reset is used when an activation file has been damaged. The EVMOVE.EXE and RESET.EXE files are located on your hard drive (located in C:\Program Files\Rockwell Software\RSUtil if you accepted the default directory location
during installation. To run these programs, select Start > Programs > Rockwell Software > Utilities > Move Activation or Reset Activation.

Finding more information about activation
The online help (COPYPROT.HLP) provides more extensive information on activation including subjects such as:

KEYDISK. Set this environment variable to tell your computer to look for activation on floppy drives

CHECKDRIVES. Specify which drives to search for activation

network activation. Move activation to a network server to allow multiple users access to the activation

moving activation. See detailed instructions for moving activation

resetting activation. See detailed instructions for using the Reset utility to repair a damaged activation file

troubleshooting. Look up error messages, get problem-solving suggestions

You can access online help:
- from the Help button on one of the EvMove or Reset dialog boxes.
- from RSNetWorx for DeviceNet by selecting Help > Copy Protection from the main menu.
- without running either RSNetWorx for DeviceNet or the activation utilities. From the Windows Start menu, select Programs > Rockwell Software > Utilities > Activation Help.

Some common questions
Following are some common problems that people encounter with activation and their solutions.

My activation files were damaged. What should I do?
If you have lost the activation because the activation file is damaged, you need to reset activation. Follow the Reset Codes instructions on the Rockwell Software Technical Support web page, or call the technical support telephone number. The web page and telephone number are both listed on the inside front cover of this guide.

If you cannot obtain a reset code immediately, follow these instructions to use the Master disk to activate the software as a temporary solution.

To use the Master disk to activate software:
1. Set the KEYDISK environment variable to TRUE. (Please refer to the online help by selecting Start > Program Files > Utilities > Activation Help for more information).

2. Insert your Master disk in the floppy drive.

3. Run your software as usual. Your software will find the activation on the Master disk.

I accidentally deleted the software directory on my hard drive. Do I need to call Rockwell Software for replacement activation files?

No. Deleting the program files does not delete your activation. The activation files are not stored in the program directory; they are located in the root directory. Your activation files will not be lost unless you format the hard drive, tamper with hidden files in the root directory, or perform certain other hard drive operations (refer to the “Protecting your activation files” section in this chapter for more information).

To get the software running again, simply uninstall the software using the Control Panel’s Add/Remove Programs option, then reinstall the software, but do not move the activation when given the opportunity.

Why can’t I move activation to a new floppy disk on a Windows NT system?

It has to do with a disk modification that NT does not allow. If you have access to a Windows 95 or 98 machine, you can create a disk that will work under NT. Format a floppy and move any activation file to it under Windows 95 or 98. (You can move the activation back off the disk if you want to keep it where it was.) Then take that disk to your Windows NT machine and move the activation to it.
Security

This first release of RSAssetSecurity™ is intended to improve the security of your automation system by limiting access to those with a legitimate need. RSAssetSecurity authenticates user identities and authorizes user requests to access a FactoryTalk-enabled system. These security services are fully integrated into the FactoryTalk Directory and are included as part of the FactoryTalk Automation Platform that installs with many products.

Although security services are always present wherever FactoryTalk is installed, you must purchase and install activations in order to add more than 10 user accounts to a Network Directory and use security services across a networked system on multiple computers.

Activations are not required to add 10 or fewer user accounts to a Network Directory. In addition, activations are not required to add user accounts to a Local Directory; security services are freely available when used in a stand-alone system on a single computer.

For more information on how to use security services, refer to RSAssetSecurity’s Online help.

How do I set up security in RSNetWorx?

RSNetWorx 7.00.00 (CPR 7) supports RSAssetSecurity. RSAssetSecurity™ is intended to improve the security of your automation system by limiting access to those with a legitimate need. RSAssetSecurity authenticates the identities of users and authorizes user requests to access a FactoryTalk-enabled system against a set of defined user accounts and access privileges held in the FactoryTalk Directory. For more information on RSAssetSecurity, refer to the ‘About RSAssetSecurity’ topic in RSNetWorx for DeviceNet Online Help.

Follow the steps below to secure RSNetWorx:

1. Install FactoryTalk Automation Platform from RSNetWorx Optional Steps Install screen. (During the FactoryTalk Automation Platform install you configure the FactoryTalk Directory.)

2. Install RSNetWorx from RSNetWorx Required Steps Install screen.

Note: For more information on FactoryTalk, FactoryTalk Automation Platform, FactoryTalk Administration Console, and FactoryTalk Directory, refer to the Glossary.
3. While running RSNetWorx’s installation wizard, you will see the Enable Security and Select a FactoryTalk Directory install screen (shown below). On this screen, select the ‘Enable security’ option. And then select the FactoryTalk directory (Network or Local) that will be used to authenticate and authorize user access.
4. Click **Next** to go to the Add Security Policies to the FactoryTalk Directory screen (see the following figure). On this screen, make sure the Log on to the … FactoryTalk Directory text shows the directory you chose on the previous screen.

5. Enter the username and password you created while configuring the FactoryTalk Directory.

6. Click **Next** to finish installing RSNetWorx.
What can I secure in RSNetWorx?

RSNetWorx implements RSAssetSecurity through three securable actions: Access, Modify, and Go Online. These securable actions let you restrict user access to actions, such as opening a project file, creating a new project file, making changes to a project file, uploading or downloading to a device, browsing to a device from the network, viewing the properties of a device, etc., in RSNetWorx.

<table>
<thead>
<tr>
<th>Securable action</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Access</td>
<td>The Access securable action allows you to perform actions such as opening an offline project file for viewing, viewing the properties of a device, etc.</td>
</tr>
</tbody>
</table>
| Modify           | The Modify securable action allows you to perform actions such as creating a project file, making changes to a project file, saving any pending edits, etc.  

*Note: To modify a project file, you need both Access (to open the file) and Modify (to make changes) securable actions.*

<table>
<thead>
<tr>
<th>Go Online</th>
<th>The Go Online securable action allows you to download information saved in a project file or upload information into a project file, as well as browse to a device on the network.</th>
</tr>
</thead>
</table>

*Note:*
- To download information saved in an existing project file, you need **Access** (to open the file), **Go Online** (to go online to prepare to download), and **Modify** (to download) securable actions.
- To upload information into an existing project file, you need **Access** (to open the file), **Go Online** (to go online to prepare to upload), and **Modify** (to upload) securable actions.
- To upload information into a new project file, you need **Go Online** (to go online to upload) securable action.
To allow or deny user access to one or more of the above securable actions, you will need to:

1. Start FactoryTalk Administration Console from **Start > Programs > Rockwell Software > FactoryTalk Administration Console**. You will see the Log On to FactoryTalk screen, as shown below.

2. Enter your username and password, and select the directory you want to log on to. (The username and password were set when you set up an account during FactoryTalk Directory configuration.)

   **Tips for choosing a directory:**

   - Click **Network** to access Network (also called Distributed) applications on the Network Directory Server.
   - Click **Local** to access Local (also called Stand-alone) applications on the Local Directory. Local applications are always located on your local computer. You cannot access local applications remotely.
   - If you cannot log on to a particular directory on your computer, it may be because it has not yet been configured. For more information, refer to the Right FactoryTalk Directory is not configured on this computer topic in FactoryTalk help. You can launch FactoryTalk Help from FactoryTalk Administration Console.
3. In FactoryTalk Administration Console, click on the RSNetWorx folder (located under System > Policies > Product Policies), to expand it. You will see the Feature Security file.


5. In the Feature Security Properties dialog box, click the securable action you want to grant the user access to.

6. In the Configure Securable Action dialog box, from the list of users, select the user you want to grant access to, and click Add.

Note: For more information on FactoryTalk and RSAssetSecurity, refer to RSNetWorx for DeviceNet Online Help.
Glossary

**Activation disk** — Any disk (floppy or hard) containing an activation file. An activation disk can be used to activate the software. This is different from a key disk (Master Disk) in that at least one license of the software must be available on the activation disk to activate the software.

**Activation file** — A hidden, read-only, system file that “activates” a Rockwell Software product. The software will run only if your system can find the correct activation file.

**Activation key** — Activation files contain a database of activation keys. Each key is particular to a certain product and must be accessible on a local or remote drive for that product to run.

**DeviceNet network** — A topology for industrial automation networks.

**FactoryTalk** is a manufacturing information platform that integrates plant-wide control systems and connects the enterprise with the production facility.

The FactoryTalk Automation Platform:

- provides common services (such as diagnostic messages and access to real-time data) and shares plant resources (such as tags and graphic displays) throughout a production facility
- allows defining plant-floor resources once, and then allows simultaneous access to those resources across product boundaries
- supports centralized security services

**FactoryTalk Administration Console** — Part of the FactoryTalk Automation Platform, FactoryTalk Administration Console is an optional, stand-alone tool that allows you to:

- Create and configure application, area, and data server elements in the FactoryTalk Directory.
- Back up and restore an entire directory or an individual application.
- Set up redundancy for OPC data servers.
- Configure client computers to recognize the location of a FactoryTalk Directory Server computer.
- Configure options for routing and logging diagnostic messages.
- View system-wide diagnostic messages.
- Configure system-wide policy settings.
Secure your FactoryTalk-enabled system with RSAssetSecurity™ security services.

Run FactoryTalk Administration Console from the Windows Start menu: Start > Programs > Rockwell Software > FactoryTalk Administration Console.

FactoryTalk Directory — FactoryTalk Directory provides a central lookup service for software products participating in a FactoryTalk-enabled automation system.

The FactoryTalk Automation Platform includes two separate directories: a Local Directory and a Network Directory. Either directory, or both directories, can be configured on the same computer. Project information, including security settings, cannot be shared between a Local Directory and Network Directory, even if both directories are configured on the same computer. Create and configure application, area, and data server elements in the FactoryTalk Directory.

Local Directory — all project information and participating software products are located on a single computer, and the FactoryTalk-enabled system cannot be shared across a network or accessed remotely.

Network Directory — organizes project information from multiple software products across multiple computers on a network.

Some FactoryTalk-enabled products require a Network directory, others require only a Local directory, and some require that both directories be configured.

Key disk — A floppy disk that can be used to activate the software even if that disk contains zero licenses. The Master Disk is the only key disk. This differs from an activation disk in that an activation disk must contain at least one license.

License — Authorization to use a specified number of instances of software. A product’s activation key contains a license for each copy of the software you have purchased. For example, if you bought seven copies of RSLogix 5, then the RSLogix 5 key on the Master Disk contains seven “licenses” of RSLogix 5. You can move the activation file for RSLogix 5 to seven different computers.

Master disk — This disk is supplied with the software. It contains a database of keys in an “activation file” that enables the software to run. Be sure to store your Master Disk in a safe place. If your activation file becomes damaged, the only way you can run your software (until the activation is reset) is with your Master Disk.

RSNetWorx configuration — A collection of user-defined parameters for networks.
**Index**

**A**
- activation  ■ 37, 41
- damaged  ■ 39
- file  ■ 19, 37
- key  ■ 37
- moving  ■ 19, 40
- network  ■ 39
- resetting  ■ 39
- troubleshooting  ■ 39
- utilities  ■ 38
- adding a device  ■ 9
- Answer Station  ■ 34
- anti-virus software  ■ 37
- autofax information system  ■ 36
- authorun  ■ 22

**B**
- benefits  ■ 1
- browse  ■ 2, 6

**C**
- changing
  - interface displays  ■ 6
- CHECKDRIVES  ■ 37, 39
- class instance editor  ■ 25
- classes  ■ 36
- clearing messages  ■ 31
- closing RSNetWorx  ■ 5
- compressing the hard drive  ■ 37
- configuration view  ■ 10
- configuring
  - devices  ■ 25
- context-sensitive help  ■ 2, 7, 29
- control area network  ■ 3
- control definitions  ■ 29
- control menu  ■ 5
- copy protection  ■ 37, 41
- copying
  - devices  ■ 6, 7
  - messages  ■ 31
- creating a network configuration  ■ 6, 7
- customizing your configuration  ■ 15, 17
- cutting devices  ■ 6, 7

**D**
- data rate  ■ 3, 14
- default parameters  ■ 14
- definitions  ■ 33
- defragmentation utilities  ■ 37
- deleting the software directory  ■ 40
- design elements  ■ 4
- device
  - adding  ■ 9
  - comparison states  ■ 8
  - configuring  ■ 25
  - mismatch  ■ 6
  - properties  ■ 6
- device menu  ■ 6
- DeviceNet window  ■ 4
- diagnostics  ■ 8
  - adding/removing devices  ■ 6
  - selecting a fault  ■ 6
  - specifying options  ■ 6
  - starting  ■ 6
  - stopping  ■ 6
  - troubleshooting a fault  ■ 6
- diagnostics menu  ■ 6
- diagnostics view  ■ 11
- document conventions  ■ iv
- documentation set  ■ iii
- dotted underline in help  ■ 33
- downloading  ■ 2, 6
- drop line configuration  ■ 3
E
edit menu 6
EDS 25
   library 25
      Registry Wizard 6
EDS wizard 25
electronic book format iv, 34
e-mail correspondence iv
error messages 12, 30, 37
EvMove 38

F
FactoryTalk 41, 47
FactoryTalk Administration Console 45, 47
FactoryTalk Automation Platform 41, 47
FactoryTalk Directory 41, 42, 48
faulted address recovery wizard 25
favorites view 9
features 1
feedback iv
file menu 6
finding available networks 8

G
graphical network information 10

H
hardware devices
   available 8
diagnostics 8
favorite 8
hardware requirements 20
hardware view 9
help menu 6
hiding messages 31

I
I/O
   device management 3
informational messages 12
input device 3
installation 19
   methods 21
intended audience iii
interface displays
   changing 6
   setting 6

K
KEYDISK 39

L
license 19
listing hardware devices
   available 8
   favorites 8
Local Directory 48

M
maintenance and diagnostics 3
master disk 19, 37
maximizing windows 5
memory 24
menu bar 6
message codes 12
message view 12
messages
   clearing 31
   copying 31
   hiding 31
minimizing windows 5
monitor devices 15
mouse 20
moving
   activation 19, 40
   windows 5

N
network 26
   activation 39
   configuration 2, 13
   creating a configuration 6
   opening a configuration 7
   parameters 14
   printing a configuration 6
   properties 6
   saving a configuration 6
Network Directory 48
network menu 6
node 3
  address 3, 14, 26
  commissioning 14
  commissioning tool 6, 14, 25

O
offline 2
online 2, 8
online help iii, 2, 19, 29
Open DeviceNet Vendor’s Association 3
opening a network configuration 7
operating system compatibility 19
output device 3

P
parameters, network 14
pasting devices 6, 7
PDF files iv
pointing device 20
point-to-point connection 26
pop-up definition 33
printing a network configuration 6, 7
product
  serial numbers 36
  suppliers 3
  version number 36
product manuals iii, 34

Q
Quick Start 13
quick start
  offline mode 16
  online mode 14

R
RAM 20, 24
refresh tree and diagram 8
release notes iii, 19
repositioning the window 5
requirements
  hardware 20
  software 21
resetting activation 39
restoring from backup 37
restoring windows 5
RSAssetSecurity 41
RSLinx iii, 2, 19, 24
RSNetworx icon 5
RSNetWorx MD 3
RSWho 2
saving a network configuration 6, 7
Securable action 44
serial numbers 36
setting interface displays 6
shortcuts 7
sizing windows 5
software compatibility 19, 21
software requirements 21
starting RSNetWorx for DeviceNet 19, 23
status bar 13
step-by-step procedures 29, 32
support 36
support library 36
symbol legend 7, 8
system requirements 20, 21
tasks 32
technical support 36
title bar 5
tool bar 7
tools menu 6
topology 3
troubleshooting 31
  activation 39
  installation 24
trunck line configuration 3
tutorial iv, 35
uncompressing the hard drive 37
updating an existing installation 23
upgrading the operating system 37
uploading 2, 6
V
version numbers ■ 36
VGA graphics adapter ■ 20
view menu ■ 6

W
warning messages ■ 12
What’s This? help ■ 30
Windows
  2000 ■ 21
  2000 Terminal Server ■ 21
  95 ■ 40
  98 ■ 40
  ME ■ 21
  NT ■ 40
  XP ■ 21

Z
zoom selection
  zoom in ■ 8
  zoom out ■ 8